Sign in to follow this  
Mawej

Bug With Typing In Polish Diacritic Letter

Recommended Posts

Hello.

I want to report some kind of annoying bug which occurs when I try to type in polish diacritic mark in polish language "Ä…" "Ä„" (alt + a, in polish layout keyboard). Everytime I do it, it delete all the words which I've typed in before I put that letter. It clears whole type box and left only that one type. It is annoying and it happens only in wurm. I have unstable client with experimental, but it also happens on normal client (some of friends told same). It occurs in every type in box like chat, in game wiki etc, and it has been for a couple last days. It doesn't happen with other polish diacritic marks. I hope I provide enough information for fixing that bug :).

With greetings, Mawej.

Edited by Mawej
  • Like 1

Share this post


Link to post
Share on other sites

I think it is meant to be that way to keep people from trolling maybe? Not entirely sure but I don't think it is a bug.


Share this post


Link to post
Share on other sites

I think it is meant to be that way to keep people from trolling maybe? Not entirely sure but I don't think it is a bug.

Why would you think it would keep people from trolling? And it is bug, it has been working very well, since I started playing at least one year ago. Recent patches might unintended changed it.

  • Like 1

Share this post


Link to post
Share on other sites

There has been a change where ctrl+a shortcut selects all text in an input box, it might be connected.


  • Like 2

Share this post


Link to post
Share on other sites

if there is an issue with a supported language (input wise) it should be looked into.


 


personal conversation, alliance and village chat can be held in any supported language - letter recognition has nothing to do with trolling, but plays a large role in normal conversation.


not only in latin letters (ISO), kyrilic is supported as well as nordic letters (Unicode)


Share this post


Link to post
Share on other sites

I'm not familar with the polish layout but on the gerrman layout the left and right alt keys behave different.

The right alt key always reports a fake control key press. So AltR+A is probably reported as Ctrl+Alt+A and triggers the Ctrl+A code

Share this post


Link to post
Share on other sites

Confirmed same here. Annoying as hell.


Share this post


Link to post
Share on other sites

Hmm I should probably add an option in the settings to disable ctrl+a shortcut. Any thoughts?

Share this post


Link to post
Share on other sites

polish, turkish, nordic, kyrilic.

do they all use the ctrl+key setup? i know german doesn't need it.

Share this post


Link to post
Share on other sites

Hmm I should probably add an option in the settings to disable ctrl+a shortcut. Any thoughts?

That might be workaround, but I think it is better than nothing at all. Could it only check if normal ctrl + a was pressed? So that won't work with alt + a. Don't know how it works in java, but I hope it is possible :D. For polish language there is only alt + a combination, ctrl + a isn't combination for any letter if that is the case.

If anything better solution for this bug won't be found, then I think that option to disable ctrl+a should be ok.

Share this post


Link to post
Share on other sites

I have same problem.  When I try to type Ä…(alt+a) my words disappears completely.
 

Share this post


Link to post
Share on other sites

Checked it, dissable select all text is working :)

Problem solved

I think it isn't really solved, because I still think better solution might be found for this case. Better than nothing, but think about new players which won't know about this "solution" for this bug.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this