Aldur

Wurm Assistant - Enrich Your Wurm Experience

Recommended Posts

thanks it works got all back 

 

many thanks

Share this post


Link to post
Share on other sites

I was looking at the latest post which explains an interested party could write up a new WA feature. i am assuming this would be as an add on. In the post, it says the information to do so can be found at GitHub. I went to GitHub and there it says the instructions for creating an add on can be found at the wiki. I think I have found myself in an infinite loop!! Help! LOL I can feel my brain starting to crash!🤪

Share this post


Link to post
Share on other sites

Hi @Leorasorry about this confusion. Once upon a time I thought plugins are a good idea, even started a wiki on GitHub but there was no interest in using it, so it all died and today I'd not even recommend the "plugin" approach, even though it works.

 

If you'd like to write something for WA, the most sensible way would be to work with source code and use me for pointers. 😁

Share this post


Link to post
Share on other sites

Hello again!!

 

First Aldur, thanks so much for your amazing response times here. I'm blown away with my last post in this thread, you had a fix out in less than 24h!!! ❤️

 

The reason for today's post is because of a combat trait not being picked up by Granger.

 

"It seems especially loyal."

 

This trait should actually be:

 

[09:15:05] It will fight fiercely. It is a tough bugger. It has a certain spark in its eyes. It seems more friendly. It has a slow metabolism. It looks more friendly than normal. It is especially loyal. It looks stationary. It has been bred in captivity.

 

Thanks again, and cheers!!

Share this post


Link to post
Share on other sites

Hi @Pukariasorry for a little slower response this time :D 
Will fix tomorrow, thanks for spotting and reporting!

Share this post


Link to post
Share on other sites

Heya !

 

Is it normal when i export / import my herd to another computer it doesn't import the "Paired with" column ? I have to do pairs manually again. Any clue ?

Share this post


Link to post
Share on other sites

Hi @Syhl Hmm might be an omission. Will check. Thanks for spotting!

  • Like 1

Share this post


Link to post
Share on other sites

@Pukaria trait fixed

@Syhl not an easy fix, turns out "paired with" works with IDs, not creature names. I'd have to change this a lot to make that work. Added to my todo.

Edited by Aldur

Share this post


Link to post
Share on other sites
4 hours ago, Aldur said:

 

@Syhl not an easy fix, turns out paired with worth with IDs not creature names. I'd have to change this a lot to make that work. Added to my todo.

 

Thank you for your work :)

  • Like 1

Share this post


Link to post
Share on other sites

Hello.

Thank you for the sweet set of tools.

 

Everything was working fine, I went to add a few timers to some new toons, and on one, the timers don't generate notifications, and the other toon isn't even listed anywhere, but the folder is there in my wurm players directory. 

 

Thanks for any help

Share this post


Link to post
Share on other sites

Hi @Sinnjinnit will be difficult to debug the issues you reported without the data. Unfortunately I didn't code good enough debugging support, so this step is manual. 

 

First try the most common fixes, which are usually related to:

1. antivirus software, disable for a moment and try

2. wurm assistant targeting wrong wurm directory (doubtful but worth suggesting)

3. wurm online client having bad config, for example no skills logging (also don't think so this is the case)

 

If nothing helps:

 

Would you be willing to send me two zipped folders in their entirety:

  • C:\Users\piotr\AppData\Local\AldursLab\WurmAssistantData (unless it was moved elsewhere)
  • The wurm game directory, which is usually at C:\Users\[name]\wurm or in steamapps library (you can skip the packs folder)

 

⚠️ Please note that I will have access to all your logs, including conversations. If you don't want to share so much, delete some log files. But without event and skills logs, I will not be able to reproduce the issues.

Share this post


Link to post
Share on other sites
Posted (edited)

I'm thinking about the Patreon I've set up and wondering if it would be good idea to somehow show appreciation for the subscriptions that you folks make (beer button). Do you think this is good idea? I feel I'm not appreciative enough.

 

I thought about adding a list of supporters into the app itself and allow to add custom message to their entry.

 

Please share your opinion regardless if you support or not.

Edited by Aldur

Share this post


Link to post
Share on other sites

Also I'm now going to invest (finally!! 🎉) some more time into WA, to fix the pile of harder bugs that I've been noting and move WA4 forwards. Although I don't want to make any promises, because I've had couple such moments in the past... then the life took me away.

 

What I do want is to ask you to remind me important issues or suggestions. So I can update my todo list and prioritize it. Especially the things that bug you a lot. I may also try to insert a poll into the app itself.

  • Like 2

Share this post


Link to post
Share on other sites
On 3/4/2022 at 3:33 AM, Aldur said:

I'm thinking about the Patreon I've set up and wondering if it would be good idea to somehow show appreciation for the subscriptions that you folks make (beer button). Do you think this is good idea? I feel I'm not appreciative enough.

 

Speaking only for myself, a small Patreon donation is my way to appreciate what you've done and continue to do for all of us.  I don't need any extra bells and whistles, or 'subscriber only!' goodies.  I just am so thankful that you continue to support this tool that makes my favorite parts of the game so much more enjoyable.  If it weren't for Granger, raising a farm full of animals would be such an unpleasant headache that I probably wouldn't even do it.  Take whatever time you would have spent on "subscriber appreciation" and pour it all back into Wurm Assistant.  :)

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I have no idea what's going on lately with granger, but I've been having issues adding new babies and getting the message that the selected herd has that name already when it doesn't; I have to have a 'sortingherd' setup that's basically empty to add problem children to that and then transfer to the appropriate herd

 

I'd gotten somewhat used to dealing with that, but now I've had a baby literally overtake one of the adult horses and replace them with the baby's info; when I tried putting the adult back in I managed to get a screenshot of the message

eagriKB.png

 

*edit*

my vision has been crap the last couple years  so I'm actually wondering how screwed up my herds are if I missed that happening in the past and only just glanced over in time to see it happen

Edited by Lisabet

Share this post


Link to post
Share on other sites

Hi @Lisabet

 

How do you have option below (screenshot) set in your Granger? I think what you observe, will happen when that option is unchecked.

When unchecked, Granger first tries to match by creature name (here: "Landhard"). If no Landhard is found, it tries to match by branding name (here: "HD4") and finds unrelated creature, because you use these names for tracking traits.

 

2022-03-13-10h01-02.png

 

PS. I've updated description of that option to be clear about this. I think it became confusing during last Granger update, where this part changed a little.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I just left message for Lisabet about this problem, as I had the same awhile back. Can't be 100% sure of course but my own experiments showed the problem was when I had more than one creature with 'trait' names added, so it would mix up horses for example that both had 'D4' added to the regular names. I removed those extra names and the problem stopped. Now I read your response above that makes sense and that option was unticked in my granger, so I've now ticked it. Hope I understand that setting correctly now :)

Edited by Tilda

Share this post


Link to post
Share on other sites

tyvm, I'll let you know if I have issues in the future; I didn't have that box checked until now so likely you're right

Share this post


Link to post
Share on other sites

This option should be ticked, that's the default for Granger. But for old WA installations, it may be that it used to be unticked in the past and it didn't update to new default (my bad, sorry about that). 😟

Share this post


Link to post
Share on other sites

to be fair, I might have unticked it myself thinking it was unnecessary (as per the old wording was a bit confusing)

 

I do wonder what happens though if I have say two donkeys both named Sad and I nickname one DD2 and the other DD2.5 because they both have 2 draft traits; will it still refuse to add properly?

Share this post


Link to post
Share on other sites

If all creatures have different branding names eg:

  • Sad 'DD2'
  • Sad 'DD2.5'

and assuming that option is unticked, then it should work correctly.

  • Like 1

Share this post


Link to post
Share on other sites

One little thing I've been meaning to check on but kept forgetting, Granger is not recording that the male is "not in the mood" after breeding for me. So when checking a female for partner options there are many highlighted even if they were just bred. Sorry if this was already mentioned and I missed it :) 

Share this post


Link to post
Share on other sites
Posted (edited)

There is indeed an issue with detecting that, some previous post explained it.

 

I have an idea to improve it.

Edited by Aldur
  • Like 1

Share this post


Link to post
Share on other sites

I have a request

Can we get a countdown timer for meditation ability cooldown? I don't mean recall home where the timer can be shortened with levels, I mean the set 18 hour CD ones like erupt/freeze, enchant grass, ect.

Share this post


Link to post
Share on other sites

Hi @Madnath, there is already a meditation timer in WA and it shows the countdown.

Assuming it still works correctly, there have been some reports over time of odd bugs that I've never managed to figure out.

Or do you mean something else?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now