Recommended Posts

Quote

2018/12/22 21:30:53.787 > Info > BackupManager > Data backup system has been locked.
2018/12/22 21:30:53.852 > Info > AppMigrationsManager > Wurm Assistant data is at version 3. No upgrade required.
2018/12/22 21:30:54.247 > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.Timers.TimersFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.
2018/12/22 21:30:54.343 > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.Calendar.CalendarFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.
2018/12/22 21:30:54.343 > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.Triggers.TriggersFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.
2018/12/22 21:30:54.343 > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.SoundManager.SoundManagerFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.
2018/12/22 21:30:54.347 > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.Granger.GrangerFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.
2018/12/22 21:30:54.372 > Info > FeaturesManager > Feature initialized: Log Searcher
2018/12/22 21:30:54.372 > Info > FeaturesManager > Feature initialized: Crafting Assistant
2018/12/22 21:30:54.372 > Info > FeaturesManager > Feature initialized: Reveal Creatures Parser
2018/12/22 21:30:54.372 > Info > FeaturesManager > Feature initialized: Skill Stats
2018/12/22 21:30:54.372 > Info > FeaturesManager > Feature initialized: Combat Assistant
2018/12/22 21:30:54.664 > Info > WaVersion > Parsed WA version: MinorVersion: 3.3, BuildCode: stable-win, BuildNumber: 103, BuildStamp: 12/8/2018 10:29:00 PM +01:00

 

 

Windows 7 Pro x64

.Net 4.7.2 installed

 

It's been a while, have I missed something?  Never seen this one before.

 

Update:  I reinstalled the 2010 C++ distributable and it's fine now.  Not sure if mine was corrupted or just older, but it's all good.

Edited by Nomadikhan

Share this post


Link to post
Share on other sites
On 12/16/2018 at 12:26 AM, LightningRoc said:

[17:23:12] > Warn > WurmApi > WurmCharacterDirectories: Validation issue > logs subdir does not exist, character dir path: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\players\LightningRoc
[17:23:13] > Warn > WurmApi > WurmCharacterDirectories: Validation issue > logs subdir does not exist, character dir path: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\players\LightningRoc
[17:23:13] > Warn > WurmApi > WurmCharacterDirectories: Validation issue > logs subdir does not exist, character dir path: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\players\LightningRoc
[17:23:14] > Warn > WurmApi > WurmCharacterDirectories: Validation issue > logs subdir does not exist, character dir path: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\players\LightningRoc
[17:23:14] > Warn > WurmApi > WurmCharacterDirectories: Validation issue > logs subdir does not exist, character dir path: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\players\LightningRoc
[17:23:15] > Warn > WurmApi > WurmCharacterDirectories: Validation issue > logs subdir does not exist, character dir path: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\players\LightningRoc
[17:23:15] > Warn > WurmApi > WurmCharacterDirectories: Validation issue > logs subdir does not exist, character dir path: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\players\LightningRoc
[17:23:16] > Warn > WurmApi > Blacklist`1: Character directories blacklist > Adding key C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\players\LightningRoc to blacklist because at least 10 issues were reported. List will be reset after application restart.
[17:23:16] > Warn > WurmApi > WurmCharacterDirectories: Validation issue > logs subdir does not exist, character dir path: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\players\LightningRoc

 

not sure how to fix but i think this is why i cannot add any horses to the granger app

 

 

Yes this is the reason of Granger not working, but am not sure how this happened. Does that directory exist?

 

I've just tested this on WU by doing fresh install and joining random server. Then started WA, set the wurm client path manually to "C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\PlayerFiles\" and it found my char and everything worked.

 

Maybe you have moved you steam library elsewhere?

Share this post


Link to post
Share on other sites

Sorry if this has been addressed but I was unable to locate it.

 

Steped away from the game for about 6 months and came back. This used to run great but now getting this error on startup.

 

12/25/2018 4:11:15 AM > Local version is: None
12/25/2018 4:11:15 AM > Obtaining latest version for build stable-win
12/25/2018 4:11:15 AM > Latest version for build stable-win is: 103
12/25/2018 4:11:15 AM > Downloading...
12/25/2018 4:11:15 AM > Downloading...
12/25/2018 4:11:15 AM > Downloading package for build stable-win for version 103
12/25/2018 4:11:17 AM > download completed
12/25/2018 4:11:17 AM > Installing...
12/25/2018 4:11:17 AM > Installing...
12/25/2018 4:11:18 AM > Launcher failed to download or install WA3 version MinorVersion: , BuildCode: stable-win, BuildNumber: 103, BuildStamp: 1/1/0001 12:00:00 AM +00:00 of build stable-win. Error: Access to the path 'C:\Users\XXXXX\Desktop\Wurm\WurmAssistant3Launcher\stage\Extracted' is denied.
12/25/2018 4:11:19 AM > Error while attempting to start Wurm Assistant: The system cannot find the file specified
12/25/2018 4:11:19 AM > Could not start WA for version: MinorVersion: , BuildCode: stable-win, BuildNumber: 103, BuildStamp: 1/1/0001 12:00:00 AM +00:00
 

I have tried to redownolad, run as administrator, etc and still same result. I have verified that the file exists. My antivirus shows no log of blocking it. any suggestions?

 

Edited by EleDoK

Share this post


Link to post
Share on other sites

Even though your Antivirus does not show this in the log, it has most likely blocked the app. It may also be another windows security feature.

Please try to move Launcher to eg C:\wurmassistant\ and try running from there.

If that doesn't work, you can try adding Launcher folder to AV exclusion list, though that is a last resort solution.

Share this post


Link to post
Share on other sites

Please make smile examine not overwrite give birth date when animal isn't pregnant. The setting of given birth 24 hours / 7 days is cleared.

Share this post


Link to post
Share on other sites

one thing that i think that this would benefit from is a prospecting helper, something that shows you where the veins are in relation to where you are...

 

Share this post


Link to post
Share on other sites

Not enjoying setting game up here. I get first time opening screen then all but sound track (waves? water?) crashes. Saying "Java heap .... "(something). Been at it (trying to initially play game after all installation/updates) an hour or so. Updated Java, but no difference. About to give up unless someone knowledgeable can help, or direct me to site where help might be available. Apologies if am in wrong forum. Please advise, thanks. (p.s. My PC is easily capable of higher requirement games such as Elite Dangerous (which I've played long term) and am told should handle easily this sort of game. pps. I like a few games, but am far from technically gifted re PC's! 

  

Share this post


Link to post
Share on other sites
Quote

Not enjoying setting game up here. I get first time opening screen then all but sound track (waves? water?) crashes. Saying "Java heap .... "(something). Been at it (trying to initially play game after all installation/updates) an hour or so. Updated Java, but no difference. About to give up unless someone knowledgeable can help, or direct me to site where help might be available. Apologies if am in wrong forum. Please advise, thanks. (p.s. My PC is easily capable of higher requirement games such as Elite Dangerous (which I've played long term) and am told should handle easily this sort of game. pps. I like a few games, but am far from technically gifted re PC's! 

 

This topic is for the Wurm Assistant utility program and not for Wurm Online or Wurm Unlimited support, however if you're getting Java heap space errors that suggests you may have installed the 32 bit version of Java which has limited address space. If possible uninstall the 32 bit Java and install the 64 bit version of Java available here Windows Offline (64 bit) https://java.com/en/download/manual.jsp

Share this post


Link to post
Share on other sites

2019-02-20 20:22:20 > First run, establishing update source url
2019-02-20 20:22:20 > Update source url established to: http://wa-ws.azurewebsites.net/api/WurmAssistant3
2019-02-20 20:22:20 > Local version is: None
2019-02-20 20:22:20 > Obtaining latest version for build stable-win
2019-02-20 20:22:21 > Latest version for build stable-win is: 103
2019-02-20 20:22:21 > Downloading...
2019-02-20 20:22:21 > Downloading...
2019-02-20 20:22:21 > Downloading package for build stable-win for version 103
2019-02-20 20:22:27 > download completed
2019-02-20 20:22:27 > Installing...
2019-02-20 20:22:27 > Installing...
2019-02-20 20:22:27 > Launcher failed to download or install WA3 version MinorVersion: , BuildCode: stable-win, BuildNumber: 103, BuildStamp: 0001-01-01 00:00:00 +00:00 of build stable-win. Error: 1 is not a supported code page.
Parameter name: codepage
2019-02-20 20:22:28 > Error while attempting to start Wurm Assistant: The system cannot find the file specified
2019-02-20 20:22:28 > Could not start WA for version: MinorVersion: , BuildCode: stable-win, BuildNumber: 103, BuildStamp: 0001-01-01 00:00:00 +00:00

Share this post


Link to post
Share on other sites
On 10/10/2012 at 12:59 PM, Aldur said:

Microsoft .NET Framework 4.5. You should have it on newer versions of windows, but if not... official download link here:

https://www.microsoft.com/en-us/download/details.aspx?id=30653

Microsoft Visual C++ 2010 SP1 (this exact version, not newer ones!) Redistributable Package (x86), official download link here:

https://www.microsoft.com/en-us/download/details.aspx?id=8328

 

Do you have the correct Microsoft files installed?

Share this post


Link to post
Share on other sites

This might have been some maintenance on Azure server. I've tried it now and it downloads, but it's wee bit slow. Guys at microsoft should handle this eventually, but I'll check it out later this evening.

Share this post


Link to post
Share on other sites

Hi folks.

 

I have good news / bad news sort of news.

 

TLDR:

 

Bad news are that I will no longer put any work on WA, short of maybe critical fixes if they ever are needed.

Good news are that I will probably write a couple entirely new tools for Wurm Online. They will cover some stuff WA already does and some things it does not.

 

Longer story:

 

Since some time now I'm running rather busy life. As anyone who worked in IT already knows, being a developer means pretty much doing double job. One job is the thing we get paid for right now. Second job is learning stuff we will be paid for in the future. This second job gets more difficult every year, as the tech keeps on advancing faster and faster. 

 

When I've made WA, it was a strong addition to my portfolio, but today it's a bit of an old dinosaur. It's quality is completely unrepresentative of my current skills and It's technology is outdated and neither something I currently work with nor something I want to be working with. I can't use current WA to advertise myself to potential clients I wish to work for. I need to spend my free time building software that is modern and I need to focus on smaller apps, so that they are finished and polished before technology makes another leap.

 

There are a couple very popular features in WA that I think are worth re-coding as more modern apps - and there were couple ideas for new tools, that might be worth exploring. That is my current plan for next months. I can't promise they will be "better" when compared to the old megazord, but I will do my best to make them attractive alternatives.

 

This has to come at a price and that price is to let WA itself retire. Hopefully devs won't be making too many breaking changes, so there is a good chance WA will keep on working for a good while.

Share this post


Link to post
Share on other sites

Getting some errors when trying to update hellie horses into herds on granger, messages im getting

 

"There was data mismatch when trying to update creature ,reason: old data father name was different than new father name? "

 

"Trait mismatch below inspect skill treshold". Can it be fixed?

Share this post


Link to post
Share on other sites

Hi

 

For first, please compare father name between Granger and in game messages. You can fix these in Granger manually on each hellhorse, if they are different.

 

As for second, this may happen if horse traits change, or when another character with low AH skill is used for smilexamine and WA somehow doesn't pick the skill difference correctly.

This can also be fixed manually in Granger.

 

Let me know if you need any more help. :)

Share this post


Link to post
Share on other sites

i understand you retireing WA. however, if you decide to keep the timers function for what ever reason, it would be nice to be able to associate a timer with a particuar skill. like i have one for picking herbs that i would like to show my current gardening skill level like i can with the built in meditation timer.

 

again this is more a suggestion if you decide to keep the timers section.

Share this post


Link to post
Share on other sites
Posted (edited)
On 11/20/2018 at 11:38 PM, Aldur said:

Did you receive this error during smilexamining? I've checked the code and it appears to be possible only when using "Editing creature colors" windows. Though that tool is known to miss usages, so I want to confirm.

 

2019/08/09 14:42:01.280 > Error >  > Something went wrong! > Existing CreatureColorEntity with Id: Black is flagged ReadOnly.

 

I did receive this message while smilexamining.

I'm running Windows stable version (win 7-64), just started using Granger, and a few horses would be correctly examined. The third horse created this error. After that error smilexamining stopped working completely. It just doesn't respond.

I restart Assistant and I can examine one horse but the next one creates this error.

 

Next I tried the beta version but that just plain doesn't work at all. Can't get smilexamine to do anything. The herd is active and the character is listed.

 

I went back to stable version and tested some more.

It seems the colours that cause the problem are the old ones - gold, black, brown. All of them caused the error and none of the newer colours caused it. I didn't have all the colours to test but at least a few each of appaloosa, black silver, both pintos and ebony worked fine.

 

Edited by Crassius

Share this post


Link to post
Share on other sites

Hi folks. I'll look at this once I'm back from vacation. Maybe I can fix some bugs. :)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now