• Announcements

    • Keenan

      Password Reset!   06/28/17

      Just as a reminder (thank you Wurmhole) - all passwords have been reset! You will need to use the Forgot Password link to reset your password in order to log in and participate.

2149 posts in this topic

Opened fine last night, but now when I tried to load it up it just flashes the screen that says version already installed and never actually opens anything up.

 

EDIT: I spoke too soon... a system restart seemed to fix it, for now.

Edited by Araninke

Share this post


Link to post
Share on other sites

OMG! Great tool!

 

Thank you very much your effort this very useful tool. I used it before my computer crashed/melted down. Just now getting back to using your Wurm Assistant/Granger on my new computer

 

I am just taking this opportunity to post my appreciation. I can only imagine how much effort you have to put into such a thing to keep it up and working. Thanks.

 

Funny thing is, I saw ur Granger, loaded all my horses into it my last computer, but - never figured out what the different colors were for. LOL. Just now, I clicked on a horse, and noticed all the colors changed. Very awesome. So I guess, green means GO! Very useful.

 

Another note to post here... I am not sure what Alendhor was talking about when he posted...

 

On ‎11‎/‎1‎/‎2016 at 9:44 PM, Alendhor said:

I've been told to tell you that you need to bring the naked lady icon back.

 

...but ya, it does sound like a good idea to me too.

 

;-)

 

Thanks - and good job on Wurm Assistant !!

Share this post


Link to post
Share on other sites

Thank you TeeeBOMB. Enjoy! :)

 

 

PS. Araninke, this happens when WA is already running. If the GUI is nowhere to be found, you can try to find and kill process: "AldursLab.WurmAssistant3.exe". After that restart shouldn't be needed.

Edited by Aldur

Share this post


Link to post
Share on other sites

Hi.  Is there a way to adjust the Path Question timer to be correct with my actual server? (server is double speed on path questions)

Share this post


Link to post
Share on other sites

Posted (edited)

Speaking of sermons... Aldur, dare say how many beers would it take for you to add a sermon group rotation list feature?  :D

 

Something that let's us enter or paste names to a list, reads logs to tell people when to preach and when it needs to rotate the list.. then copies to clipboard the list for us to paste in chat?  I mean I'm fairly sure your plugin feature and documentation would allow us to do that... but it's beyond me.

Edited by Nomadikhan

Share this post


Link to post
Share on other sites

Posted (edited)

great app in theory.. too bad I can't seem to get the dang thing to work

Edited by Katna

Share this post


Link to post
Share on other sites

Is there a way you can not remove deceased parents from granger? It makes preventing inbreeding difficult if you don't copy the parents to notes before examining them later.

Share this post


Link to post
Share on other sites

Hi Kelody. Has something changed with wurm inbreeding? Back in the day, when parent was deceased, it was assumed to no longer affect inbreeding in any way.

Share this post


Link to post
Share on other sites

has worked great for quite a while, and now im suddenly getting an error and it wont open

 

Spoiler

Newtonsoft.Json.JsonReaderException: Unterminated string. Expected delimiter: ". Path 'traitViewState', line 15, position 1493.
   at Newtonsoft.Json.JsonTextReader.ReadStringIntoBuffer(Char quote)
   at Newtonsoft.Json.JsonTextReader.ParseString(Char quote, ReadType readType)
   at Newtonsoft.Json.JsonTextReader.ReadAsBytes()
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.ReadForType(JsonReader reader, JsonContract contract, Boolean hasConverter)
   at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateObject(Object newObject, JsonReader reader, JsonObjectContract contract, JsonProperty member, String id)

 

Share this post


Link to post
Share on other sites

I'm at a loss on this, i've used WA for a couple years or so now with no issues. A couple weeks back i formatted my PC and did a clean install. As was necessary i redownloaded WA and now it messes up when loading and half the features don't appear.

 

On first clean install i get an immediate error window telling me i have to restart WA

 

Quote

Application startup was interrupted by an ugly error! 

System.IO.FileNotFoundException: Could not find file 'C:\Users\Jordan\AppData\Local\AldursLab\WurmAssistantData\upgrade.dat'.
File name: 'C:\Users\Jordan\AppData\Local\AldursLab\WurmAssistantData\upgrade.dat'
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
   at System.IO.File.Copy(String sourceFileName, String destFileName)
   at AldursLab.WurmAssistant3.Systems.DataBackups.BackupManager.CreateDataBackup() in C:\TeamCity\buildAgent\work\885ec67097b8af0e\src\Apps\WurmAssistant\WurmAssistant3\Systems\DataBackups\BackupManager.cs:line 60
   at AldursLab.WurmAssistant3.Systems.DataBackups.BackupManager.CreateTodaysDataBackupIfNotExists() in C:\TeamCity\buildAgent\work\885ec67097b8af0e\src\Apps\WurmAssistant\WurmAssistant3\Systems\DataBackups\BackupManager.cs:line 41
   at AldursLab.WurmAssistant3.Bootstrapper.<OnStartup>b__4_0() in C:\TeamCity\buildAgent\work\885ec67097b8af0e\src\Apps\WurmAssistant\WurmAssistant3\Bootstrapper.cs:line 123
   at AldursLab.WurmAssistant3.Bootstrapper.HandleExceptions(Action action) in C:\TeamCity\buildAgent\work\885ec67097b8af0e\src\Apps\WurmAssistant\WurmAssistant3\Bootstrapper.cs:line 151

 

Then it restarts and half the features are missing with 5 errors

 

Quote

[13:24:41] > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.Timers.TimersFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.
[13:24:42] > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.Calendar.CalendarFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.
[13:24:42] > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.Triggers.TriggersFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.
[13:24:42] > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.SoundManager.SoundManagerFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.
[13:24:42] > Error > FeaturesManager > Unable to resolve IFeature named AldursLab.WurmAssistant3.Areas.Granger.GrangerFeature > Could not load file or assembly 'irrKlang.NET4.dll' or one of its dependencies. The specified module could not be found.

 

Anyone know what i did to screw this up? xD

Share this post


Link to post
Share on other sites

Hello. Looks like a simple bug, I'll try to fix within 2 days. Sorry for the trouble. :)

2 people like this

Share this post


Link to post
Share on other sites
On 4/20/2017 at 9:28 AM, Aldur said:

Hi Kelody. Has something changed with wurm inbreeding? Back in the day, when parent was deceased, it was assumed to no longer affect inbreeding in any way.

 

Keenan has confirmed this and my own experience does as well.

 

On 9/14/2016 at 1:42 PM, Keenan said:

 

I know it's crazy to understand this, but I've actually looked at the very code that handles this. 

Take a moment on that, I can wait.

 

Literally, the parent data is still alive and well. Can't look up the names because they're dead, but the IDs live on.

The check is purely based on the IDs stored in those fields.

Killing parents doesn't prevent inbreeding.

I know how it works beyond that, and I am not at liberty to say outside of the fact that - as I already stated - it's not a huge factor. 

 

I suppose some folks just like beating dead horses (or killing horses and then beating them), but I'm done. :)

 

 

 

Share this post


Link to post
Share on other sites

Holy horse! Guess I need to change that in Granger. It does explain some odd bad traits I was getting once in the past though.

Share this post


Link to post
Share on other sites

Updated Wurm Assistant Stable to build 86

* Fixed errors about missing upgrade.dat

* Granger will no longer clear parents on smilexamines

Share this post


Link to post
Share on other sites

Maaaaybe? :)

1 person likes this

Share this post


Link to post
Share on other sites
On 5/26/2017 at 4:11 PM, Aldur said:

Holy horse! Guess I need to change that in Granger. It does explain some odd bad traits I was getting once in the past though.

 

Fun fact: This has actually caused animals to suddenly have strange species as parents. We don't usually reuse creature IDs, but in the odd chance that the server has an issue before saving used IDs, it can happen. I've heard of a horse with a crocodile parent once.

 

If you see this, it's harmless and should be fairly rare. Just saw I was quoted and figured I'd bring a little entertainment with me.

5 people like this

Share this post


Link to post
Share on other sites
On 5/26/2017 at 7:00 PM, Aldur said:

Updated Wurm Assistant Stable to build 86

* Fixed errors about missing upgrade.dat

* Granger will no longer clear parents on smilexamines

 

/cheer

/mourn all the parents slaughtered

1 person likes this

Share this post


Link to post
Share on other sites

I really like the Granger feature, but it stopped working in the last few days. I keep getting the error while smiling:

"processing creature cancelled, AH skill or server group unknown for player Menyet"

 

The log shows a little more:

[10:08:26] > Info > GrangerFeature > processing creature cancelled, AH skill or server group unknown for player Menyet (skill:  ; server: Name: Deliverance, WebStatsUrl: http://freedom002.game.wurmonline.com/battles/stats.html, ServerGroup: FREEDOM

 

I cleared the cache and got the error message at restart:

[10:14:16] > Info > WurmApi > WurmCharacterSkills: Skill info rejected, server could not be identified for this entry: Timestamp: 2017. 03. 18. 18:00:18, Source: , Content: Hatchet increased  to 53

 

any idea why it cant see my skill? (The skill stats window can get my skills without any trouble.)

Share this post


Link to post
Share on other sites

Hi Menyet. I have answered you on a PM.

Share this post


Link to post
Share on other sites

I am trying to figure out how to modify a trigger case and have been unable to come up with an answer.

 

I have an audio trigger set up for "You stop leading .+" to alert me if an animal gets stuck on something.  It goes off when I intentionally stop leading them to put them in a pen, but that's okay.

 

However, I frequently am on and off my riding horse.  Because when you choose Ride, it displays the "stop leading X" message, I hear the warning audio every time I get on the horse.  This is a bit too much.

 

There are two messages in a row in Event that relate to this action:

  • You mount on the aged fat Zarashark as the driver.
  • You stop leading the aged fat Zarashark.

Is there a way to suppress the "stop leading" audio if it immediately follows "You mount"?

Share this post


Link to post
Share on other sites

Hi Gorwst, unfortunately I don't think that's possible in the current WA version. I've had plans to make this possible, but no time to get this done, sorry.

Share this post


Link to post
Share on other sites

Was doing some leatherworking the other day and realised the crafting tool doesn't work with some functions of tailoring. Did a quick search and couldn't see it mentioned here to you Aldur so i dunno if you're aware soooo i tested.

 

For Cloth Tailoring
The XXXX has some stains that must be washed away.

The XXXX has an open seam that must be backstitched with an iron needle to improve.
 

For Leatherworking
has some holes and must be tailored with an iron needle to improve.

A mallet must be used on the XXXX in order to smooth out a quirk.

 

All of these have no effect on the widget. Also if it bothers you at all the "awl" message doesn't say "an awl" it says "some holes punched with an". Similar true of leather knife and the "slipstitch" message for cloth tailoring needle.

Cheers :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now