Sign in to follow this  
Budda

WPlanner V3.0.0 - Wurm Mapping Program - Patch for broken maps

Recommended Posts

Manual fix for now.

 

Have started work on the new version - kind of a large scope, so don't expect it too soon :)

 

sneak-peeks about whats new? Teeny-tiny hints perhaps? XD

 

me be very curious

Edited by Lycanthropic

Share this post


Link to post
Share on other sites

Any eta on a fix for the launcher or updated mapping tool? It seems the thread has died and no news yet?


Share this post


Link to post
Share on other sites

anyone using this on windows 8 ? my win 8 doesnt find the jre or something weird... *sighs* 

Share this post


Link to post
Share on other sites

is this program working for anyone? confirmation out there? lol im back at the gui at 60-65% :( i thought i had this working before... i have a new computer though now so i dunno if im missing something or what... :) 


Share this post


Link to post
Share on other sites

so if i use my zip program with the jar file i can see all the files and folders inside of it... including the gui folder... and i pulled it out copied it into the main folder but I'm not seeing how to repoint the gui thing o.O how i do that? :) 


Share this post


Link to post
Share on other sites

nm i got it working ;) THANKS... ;) I mean... no one helped me but i know if u were online right now you would ;0 


Share this post


Link to post
Share on other sites

What did you do to get this working? It looks like a great tool. Would be even better if it worked.


Share this post


Link to post
Share on other sites

Can someone tell where to put the gui folder from the jar? into data folder or into wplanner folder? and how to change the config file? what line to add/change??


Share this post


Link to post
Share on other sites

Well... for me it worked with the "lounching the jar file" solution, but firstly i reinstaled it to non-windows partition.. (to D:/ instead of C:/) then i didn't need to run it as an administrator and it worked..


Share this post


Link to post
Share on other sites

Just had to say, I still love this program.  I'm butchering a copy of the graphics.jar, stripping it down to the only file it's read for.. terrain.  Adding custom images such as tree objects, hedge fences, creature icon objects (for lairs), cornered cobblestone terrain, etc.


 


Thanks for making this program!  Is there anyway we can beseech you to give it a good last update?  Fix the terrain loading issue for people, and make loading custom files easier (primarily graphics.jar... maybe option to let it read from a directory the way you have it reado objects/fences)? 


Share this post


Link to post
Share on other sites

Working on an update (rewrite) now that loads the needed files from a webserver instead of requiring you to have Wurm installed.


 


Bit of a preview below, way the gui works means it leaves open the option for me to allow custom skinning of the program via CSS, different themes etc.


 


preview4.PNG


  • Like 3

Share this post


Link to post
Share on other sites

Looking smooth :)


 


And the 3D glasses promise competition for Warlander I presume?


Share this post


Link to post
Share on other sites

Working on an update (rewrite) now that loads the needed files from a webserver instead of requiring you to have Wurm installed.

 

Bit of a preview below, way the gui works means it leaves open the option for me to allow custom skinning of the program via CSS, different themes etc.

 

preview4.PNG

 

Awesome to hear!  Can we get the option to specify our own files or locations for files?  I have custom terrain I'm working on that's not in graphics.jar, tree objects, hedge fences etc..

Share this post


Link to post
Share on other sites

Awesome to hear!  Can we get the option to specify our own files or locations for files?  I have custom terrain I'm working on that's not in graphics.jar, tree objects, hedge fences etc..

 

Yeah I'll keep in some sort of option for loading custom files etc like the current version.

  • Like 2

Share this post


Link to post
Share on other sites

My hero, and not just til the end of time either!


Share this post


Link to post
Share on other sites

Gets stuck at Loading... Terrain images

 

Sadly I also have this problem (also on Win 7).

 

But I am waiting with baited breath for your update, it looks like a great program that will be really handy :)

 

Do you have any sort of guide for using it? Or am I being blind and missing a post about that here?

Thanks!

Share this post


Link to post
Share on other sites

i think when you see the program running its pretty selfexplanatory,


 


the update seems great


Share this post


Link to post
Share on other sites

Sadly I also have this problem (also on Win 7).

 

But I am waiting with baited breath for your update, it looks like a great program that will be really handy :)

 

Do you have any sort of guide for using it? Or am I being blind and missing a post about that here?

Thanks!

For now, there is a post on one of the previous pages here where he uploads an alternative wplanner.jar.  download that and do not use wplanner.exe.  It'll run fine.  Just overwrite your existing wplanner.jar in the install folder.

Share this post


Link to post
Share on other sites

Program gets stuck on "loading gui images" for me. I already downloaded fix for "loading... terrain" bug given by Budda on post 251 and replaced the .jar file... loading terrain bug fixed, new loading gui images bug introduced.


 


I used this program years ago and wish to again. I know little about fixing files and such but any help I welcome. Thanks.


Edited by geode

Share this post


Link to post
Share on other sites

I was having the Terrain loading issue described here and it was fixed by following the instructions here: http://forum.wurmonline.com/index.php?/topic/42986-wplanner-v300-wurm-mapping-program-patch-for-broken-maps/?p=856935


 


That solved the Terrain issue but left me stuck at 65% on Loading GUI...


 


I have a workaround but I'm not sure it's "ok" as it's basically dismantling the program.


 


Download the .jar file from post Buddas post #251 (linked above). Extract that copy of the WPlanner.jar into a folder named WPlanner. Once you have extracted the main Wplanner.jar into the folder, open the folder and extract the files.jar file into the same folder. The end result should be a folder named WPlanner that contains the following subfolders: data, gui, META-INF, net, org


 


Make sure the WPlanner folder is in the main WPlanner directory.


 


C:\Program Files (x86)\BuddaT.net\WPlanner\WPlanner


 


The red text is the main directory, the blue text should be the folder you either created there or added. Next, open WPlanner.ini and modify the last line to:


 


Class Path=C:\Program Files (x86)\BuddaT.net\WPlanner\WPlanner;


 


Finally, execute WPLanner.exe as an administrator. The program should load successfully.


 


Share this post


Link to post
Share on other sites

Tried what Beanbag suggested verbatim. No dice.


 


Also, I was wondering if the last line should say:


 


Class Path=C:\Program Files (x86)\BuddaT.net\WPlanner\WPlanner;


 


OR


 


Class Path=C:\Program Files (x86)\BuddaT.net\WPlanner\WPlanner\WPlanner.jar;


 


Either way, I tried both and neither work. Still stuck on loading GUI at 65%.


 


Any ETA on version 4 Budda?


Share this post


Link to post
Share on other sites

Seeing a lot of people have issues with running this program in the meantime, I determined a method to get it to work for me. You results may vary, but I like to think it's simple enough.

 

1. Replace the Wplanner.jar file as Budda described (http://forum.wurmonline.com/index.php?/topic/42986-wplanner-v300-wurm-mapping-program-patch-for-broken-maps/?p=856935)

 

2. Double-click the Wplanner.jar file and allow the program to run from it - do not use the Wplanner.exe.

 

That's all I did and it works just fine.

+1 This worked for me. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this