Kamiraa

Custom Weapons Mod Help

Recommended Posts

I am playing on a server which runs the custom weapons mod containing the Headsplitter Axe as well as others. My serverpacks is up and running fine and I can see other custom graphics such as hitching posts. However, all of the custom weapons show as the placeholder question mark bags. Quite annoying as my deed-mates are both dual-wielding these bags all the time! I have tried wiping all mods, re-downloading them, verifying files through Steam, loading the game using ONLY the serverpacks mod, running patcher.bat each time, etc. Not sure what I am doing wrong. Any suggestions? :)

Share this post


Link to post
Share on other sites

Try wiping all the weird long name .jars from your packs folder. (leave the ones with normal names like graphics.jar, sound.jar ... )

Share this post


Link to post
Share on other sites

I had 6 of those weird .jars and deleted them, but am still not able to see the custom weapons in game. I appreciate the suggestion, thanks!! :)

Share this post


Link to post
Share on other sites

No problem! Was worth a shot!

Similar issue going on in this thread:

If you get the same message as @RPIII"unexpected end of file" or something, and you happen to both be playing on the same server, then I'm heavily leaning on it being a server-side issue as I said in my last comment on that thread. Can you confirm about that message in your F1 console?

Share this post


Link to post
Share on other sites

Well now my client isn't loading ANY of the custom graphics. Tried fresh downloads of the mod loader and serverpacks, ran patcher.bat again. Checked for weird files in the packs folder again. Verified files through Steam. Someone on my server told me to rename client.jar to client-old.jar and rename client-patched.jar to client.jar. That didn't change anything either LOL. So, I seem to be making things worse :) Most other players on the server can see the custom weapons just fine. Could it still be a problem on the server side then? I wasn't getting these errors before, but now I have a string of messages like the one below in my F1 console:

 

SEVERE: Unexpected end of file from server

java.net.SocketException: Unexpected end of file from server
    at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:851)
    at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:678)
    at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:848)
    at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:678)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1587)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1492)
    at java.net.URL.openStream(URL.java:1045)
    at org.gotti.wurmonline.clientmods.serverpacks.PackDownloader.run(PackDownloader.java:33)
    at java.lang.Thread.run(Thread.java:748)

Initializing font texture for SansSerif (15, bold). Texture Size: 256
Missing texture data requested: graphics.jar:texture/terrain/slab_n.dds
Initializing font texture for Monospaced (15). Texture Size: 256

 

Edited by Kamiraa

Share this post


Link to post
Share on other sites

Yep definitely seems server side. The person I linked to last time said they contacted admins and they'll check it out soon. You're probably on the same server but you can also contact them if it doesn't get fixed. Hope they can sort it out!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now