barry22

Game client randomly crashing

Recommended Posts

Hi I’m running wurm online on 64-bit client my PC is more  and powerful enough to run the game But I keep getting random crashes  I do not see any error pop up when the game crashes it just crashes and shuts down the game Any help I could get with this issue would be appreciated

Share this post


Link to post
Share on other sites
Posted (edited)

First, this is tech help for Wurm UNLIMITED and you mention Wurm ONLINE. The subforum for tech help in WO is here, and it may be more actively monitored by game devs and players who can help (WU is often left to its own devices these days):  https://forum.wurmonline.com/index.php?/forum/26-technical-issues/

 

I will ask a mod to move the thread for you. Meantime here are a few things to try:

 

*** If you have a laptop with "switchable" graphics, you may need to toggle it from the powersaving Intel graphics chip to the more powerful dedicated gaming graphics (AMD/NVidia). Tell me if you need help with this step.

 

*** I suggest you get graphics drivers from the chip manufacturer and NOT from Windows Update, as Windows Update is notoriously unfriendly to OpenGL games like Wurm. Tell me if you need help with this step:

 

Intel: https://www.intel.com/content/www/us/en/download-center/home.html

AMD-Radeon:  https://www.amd.com/en/support

NVidia/Geforce:  https://www.nvidia.com/download/index.aspx

 

***  You could be dropping packets. If you are playing thru Wifi, try testing with an ethernet cable. If you are already using cable, it may be an older cable with frayed lines, try swapping in a new cable (when I had constant sporadic crashes, this is what solved it for me. Maybe not your issue though).

 

***  If you are using steam, have it verify files. Ask me if you need help with this step.

 

Can you post also your operating system, ram and graphics adapter. Also if possible the laptop model. 

 

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

Hi thank you forgetting back to me I believe all my drivers are up-to-date and my specs are 16ram GeForce 1080ti Intel processor i7 

Share this post


Link to post
Share on other sites

I am running the game on a 4K monitor

Share this post


Link to post
Share on other sites

Moved to Client Bugs.

Share this post


Link to post
Share on other sites

something I have recently learned is see if changing Windows power plan to High Performance makes any difference.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Explora said:

something I have recently learned is see if changing Windows power plan to High Performance makes any difference.

I tested this unfortunately it did not fix my issueI 

Edited by barry22

Share this post


Link to post
Share on other sites
Posted (edited)

I have updated my graphics drivers and tried downloading various Java versions Still has not fix the crashing issue Also updated the drivers for the Intel I used all the fixes suggested Unfortunately the crashing is still persisting

Edited by barry22

Share this post


Link to post
Share on other sites
Posted (edited)

If you DO have a laptop with both Intel and GeForce graphics (and it sounds like you do) , there is an issue specific to Java based games (like Wurm) where you must open the NVidia graphics control panel and direct it to "always use Geforce/dedicated graphics", because if you do NOT switch this then the laptop thinks Java is an office desktop app and keeps switching back over to the intel chip again.

 

You probably would also be getting random crashes in the Java version of Minecraft. Because the two games are coded very similar (since some overlap in the original developers), a lot of things that fix crashing in minecraft will also fix crashing in Wurm. Since there are like 1000000 times more Minecraft players than Wurm players, looking up "fixing crashes in minecraft" often turns up more answers then searching for Wurm fixes.

 

Here are a couple threads discussing the issue of laptops with "switchable graphics" running Java games.

 

The control panel part -probably- looks like this, however I am not as familiar with Win 10 and newer versions of GeForce Control Panel:

 

6-Manage-Settings-Global.jpg

 

 

Also try not to post multiple threads on the same topic, as it won't get more assistance just less attention from people who give up on which thread has the most recent info.

 

 

One last question -- I see you have been playing Wurm for at least 8 years and no major technical problems till recent. Did you change computers? Reinstall a new operating system?

 

Make any other changes different from when you (seemingly) played fine in 2018 2019 2020 2021 etc?

 

Also if you could answer a few of the questions you skipped over. Do you play on Wifi or ethernet? Same ISP? Are you playing from a different location than before? Are you playing through Steam? 

 

You could also try reinstalling Wurm. Back up first any chat logs/screenshots etc that you want to save.

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

For a start I do not play on a laptop Just to clarify that also I have not changed computer in the last four years No I am not playing on wireless and no I am not playing through steam I downloaded the client directly from wurm website

 

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Ok you had mentioned updating both intel and Geforce drivers and that threw me off, sorry about that!

 

I would try reinstalling Wurm, I guess. Can't think of much else to suggest.

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites
Posted (edited)

Also just to clarify I have not been playing this game for four years I’ve only just come back to it after four years Also I have already tried uninstalling and reinstalling

Edited by barry22

Share this post


Link to post
Share on other sites
Posted (edited)

Ah ok, I saw you registed in 2014 and had posts up in 2018 / 2019. So it has been crashing ever since you came back?

 

If you just came back to it recent, but still had it installed on your system,  I would make sure you downloaded the NEWEST client as the older clients are not likely to be very functional.

 

Another thing to check -- look in Java and Control Panel to see if you have BOTH 32- and 64- bit Java. YOU DO NOT WANT BOTH because the game seems to automatically use the 32 bit version. Uninstall all Java from the system then ONLY use this manual offline install for 64 bitv (the third option, Windows Offline (64-bit) filesize: 83.46 MB).  You do not want to use some of the newest versions of java, like Java 17 or 18, i think. I play WU instead of WO these days and someone else might have suggestions on which is the "newest" java that is useable.

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

I downloaded the 64-bit which is directly from the wurm online Website which I’m assuming is the most up-to-date version

Share this post


Link to post
Share on other sites
Posted (edited)

I have not tried the offline version of Java would that still work?

also I have tried older versions Java did not fix it for me 

Edited by barry22

Share this post


Link to post
Share on other sites
Posted (edited)

Yes but I would first UN install all other javas from the computer, then ONLY install the offline one I linked.

 

If you have multiple version of Java it can severely mess up the game.

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

these is also this recent post from Ostentatio that I would try:

 

 Also let us know if disabling FBO support in the Compatibility settings tab helps; this will have undesired effects,

but it has improved stability for some and it would help to know who that works for.

 

 

 

Share this post


Link to post
Share on other sites
15 minutes ago, Brash_Endeavors said:

Yes but I would first UN install all other javas from the computer, then ONLY install the offline one I linked.

 

If you have multiple version of Java it can severely mess up the game.

Okay I will give both a try tomorrow and see if it fixes it hopefully it will fix 

Share this post


Link to post
Share on other sites

I don't know if you saw this, but in case not thought it might help.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

I believe I have fix this issue i’ve been playing now for about two hours no crashes I will tell you what I did if anyone else is experiencing these issues by following the instructions that I was told on this post  I uninstalled Java insured it was completely uninstalled and uninstalled wurm I also uninstalled my graphics drivers and re-downloaded them and updated them and  then I install Java offline version also I insured that i disabling FBO support  by following the steps I believe it will fix the issue thank you for your help I would ask if any other People are experiencing these issues of crashing I would ask the moderators to point them to this thread and  kind regards barry22

Edited by barry22
  • Like 1

Share this post


Link to post
Share on other sites

Yeah that crash is annoying, had that for the last couple of years. Glad you got it running better.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now