Morinaka

Weird frame rate options presented on Linux

Recommended Posts

Trying out WU on linux Pop! OS, all up date, both OS and nvidia drivers, using a GTX 1060 6GB. The game itself loads fine, so it's not broken in that way.

I have an Asus TUF Gaming VG27AQ 144Hz g-sync compatible monitor, on Windows 10 this is not an issue for WU, i can select 144Hz in wurm graphics settings, turn v-sync off and let variable refresh rate handle the rest, all nice and smooth.

 

But in linux the only options i'm presented with in the WU options are 53, 52, 51 and 50Hz for some reason, this causes a lot of stuttering, v-sync on or off. I can't see any way in the config files to force or add a 144Hz option, does it exist?

NZeyxek.png

Any one else come across this problem by any chance? Known bug?

Any explanation, even if it doesn't resolve the issue would be nice to know.

Share this post


Link to post
Share on other sites

It's probably a driver issue, Linux tends to default to open source drivers, and requires you to specifically install drivers for closed source vendors, like Nvidia.

 

Not being familiar with Pop! I'm uncertain how you'd do that, but I'm sure it'll be there somewhere, iirc nvidia 460 is close to the most current linux drivers.

 

Share this post


Link to post
Share on other sites

I definitely have the proprietary drivers installed, Pop! offers a distro with those enabled by default, and i have the Nvidia X Server settings window, and it says drivers are 470.63.01.

Share this post


Link to post
Share on other sites

Is this a desktop, or a laptop hooked up to an external monitor?  Apparently setting discrete graphics in BIOS (to avoid hybrid mode) might help:

 

 

 

 

 

 

Do you have more than one display? Sounds like x11 is finicky about multiple monitors with different refresh rates. Not sure whether either of these are any help:

 

 

 

 

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

It's a desktop machine, a desktop GTX 1060 6GB connected via displayport to a single Asus TUF Gaming VG27AQ 144Hz g-sync compatible monitor as stated in the initial post.

I can also set the refresh rate to 144HZ just fine in the operating system settings or with xrandr in the command line, so i don't think it's any of the issues you linked to.

Share this post


Link to post
Share on other sites

OK, i decided to upgrade my video card (not just because of wurm), and i've from nvidia to amd, and now the problem is no longer there.

So i guess the issue is with nvidia's linux drivers not being very good with wurm.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now