Brian

Wurm Map Generator FX

Recommended Posts

Hello Brian,

 

i encountered a problem with the 1024 map. as you can see on the picture it doesnt fill the map-view-display. i dont know why that is!

 

ombcg24v.png

 

 

Edited by Zaidonia
i forgot the picture

Share this post


Link to post
Share on other sites
On 2/28/2021 at 12:31 PM, LightningRoc said:

Im placing biomes and trees and such but they dont seem to be appearing.  ANy idea why this might be?

 

Do you mean they're not appearing on the biome map, or in the world once the server starts up?

Share this post


Link to post
Share on other sites
On 3/1/2021 at 2:48 AM, Zaidonia said:

Hello Brian,

 

i encountered a problem with the 1024 map. as you can see on the picture it doesnt fill the map-view-display. i dont know why that is!

 


I can't see the picture, but if you have a reasonably high-resolution monitor, a 1024 map won't fill up the entire screen if you have it maximized. The view only uses one pixel per tile for display, so for example my display has a height of 1440; only 1024 pixels of that would be taken up by the map, the rest (other than buttons, etc) would be empty space.

Share this post


Link to post
Share on other sites

Is it possible to actually generate biomes above 4000? I notice it is (finally) possible to generate mountains above that height but I cannot seem to get snow to generate or manually place at altitudes above ~4200

Share this post


Link to post
Share on other sites

Figured it out

Edited by Sperg

Share this post


Link to post
Share on other sites
On 4/22/2021 at 11:09 PM, Sperg said:

Figured it out

Cool, sorry I've been away but glad you got it figured out.

Share this post


Link to post
Share on other sites

I seem to not get notifications as expected on this thread. If anyone needs assistance with this map editor, you can send an email to Brian@BSuttonDC.us

Share this post


Link to post
Share on other sites
On 4/6/2021 at 12:08 AM, spacegeek said:

Is it possible to actually generate biomes above 4000? I notice it is (finally) possible to generate mountains above that height but I cannot seem to get snow to generate or manually place at altitudes above ~4200

Sorry, I just now saw this.

 

I know of no reason why this shouldn't be possible. I'd double-check the biome settings/cutoff. If you are still having the problem, email me at Brian@BSuttonDC.us.

 

Share this post


Link to post
Share on other sites

I don't see a download link for this. Just the documentation and installation instructions.

Share this post


Link to post
Share on other sites
8 minutes ago, Reddtoo said:

I don't see a download link for this. Just the documentation and installation instructions.

I had trouble with this, too.  If you go here:

http://bsuttondc.us/apps/wMapGen/docs/about/install.html

it looks like it can be done if you also install the Java Launcher, here:

http://bsuttondc.us/apps/launcher/docs/install/installation.html

 

I didn't want to install the launcher, and I couldn't figure out how to get this map generator without it. Not saying there isn't a way, just that it got too confusing for me so I quickly gave up.

Share this post


Link to post
Share on other sites

Ah, hoop jumping. We all love to jump through hoops. 😉

Thanks again Batta. I might give this a shot. Not saying I'll follow through with all of it. Ima kind of a lazy one.

Share this post


Link to post
Share on other sites

You're using java and this is Windows only. Shame. I am on Linux, and having this as a self-executing jar file would be wonderful as it seems all other map generators are now out of date. I may have to make my own or find another game.

Share this post


Link to post
Share on other sites
12 hours ago, Victor said:

You're using java and this is Windows only. Shame. I am on Linux, and having this as a self-executing jar file would be wonderful as it seems all other map generators are now out of date. I may have to make my own or find another game.

Lots of us are still regularly making maps using the existing map generators, so they are definitely not all out of date.  Sometimes you have to go to the last page, or close to the last page, to see if there is an updated version with a new link. But this is the same for most of the mods, so nothing new with that.

Edited by Batta

Share this post


Link to post
Share on other sites

I might be able to compile it for Linux. My focus was on Windows, since that seems to be what everyone was using. From past experience, I couldn't get past the Mac issues, but I've had success with Linux in the past. 

 

I'll look into it.

Share this post


Link to post
Share on other sites

I have an experimental launcher for Linux accessible at: https://bsuttondc.us/apps/launcher/docs/install/installation.html (you may need to refresh the page).

I don't have a Linux machine, so it's anybody's guess if it will work. Theoretically, when you run it (if it runs) it should update the installer first, then you can go to https://bsuttondc.us/apps/wMapGen/docs/about/install.html to configure the map generator.

 

Please let me know if it works for you; email me at Brian@BSuttonDC.us if there are issues for us to work through.

Share this post


Link to post
Share on other sites

Far from a legit issue,

But I noticed when I try to Generate Hight Map on 1638, it goes through the motions and then nothing happens lol.

I see my CPU working at about 35% for about a minute or two and then drops off but there is nothing in the viewer.
I tried hitting drop dirt just to see what would happen, after like 5 minutes CPU at 40-50%, nothing happened, lol.

I mean not that i need a map that big, but it appears to be either a bug or something wrong with my pc xD

Share this post


Link to post
Share on other sites
On 5/1/2022 at 1:57 PM, Yaz said:

Far from a legit issue,

But I noticed when I try to Generate Hight Map on 1638, it goes through the motions and then nothing happens lol.

I see my CPU working at about 35% for about a minute or two and then drops off but there is nothing in the viewer.
I tried hitting drop dirt just to see what would happen, after like 5 minutes CPU at 40-50%, nothing happened, lol.

I mean not that i need a map that big, but it appears to be either a bug or something wrong with my pc xD


I'm seeing it as well, so it's not your PC.
It's some kind of bug. I don't think I had tested that size; I know there were issues with the 8192 size that I dealt with, looks like I'll need to see if there's something I need to do with the 16k as well. Or just remove it if I can't get it to work properly.

Thanks for noticing. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now