Sign in to follow this  
Xikk

Affinity food timers shorter than expected [FIX FOUND]

Recommended Posts

Posted (edited)

This has been identified (thanks for the help from others) as a problem with transferring chopped things between FSBs.

If you always keep your chopped things in the same FSB and always have, it's not an issue.

 

However, after a few rounds of experimentation (I won't bore you with the details) I found a fix if you've broken your chopped ingredients.

 

Pull everything chopped out of your FSB, into your inventory or other non-bulk container.

Freshly chop a non-chopped item of each, and put it into the FSB that has been emptied of chopped things.

Now drop your chopped things back in on top. Timers should be back to normal.

 

I have checked this three times and it seems to work.

 

[Putting new chopped things on top of a "broken" stack does not work, FSB has to be empty of "chopped" things and receive a freshly chopped thing to reset it - no, I don't understand this but I'm sure somehow it makes sense in the code]

 

 

 

Original post:

 

So, I've been making affinity foods on Harmony for a couple weeks now (having done it for years in WU).

 

My recent recipe combination generally gives between 4-6 hours of affinity time on a 0.03kg bite. As well as testing them myself, I have several clients who have confirmed this in the thread here: https://forum.wurmonline.com/index.php?/topic/177822-alistas-kitchen-affinity-food-closed-temporarily/

 

This morning I cooked two meals that were fine (4+ hour timers), and then at some point, around 10am BST I think, something changed. Two more meals I cooked, using the same general recipe (differing by herbs), came out with ~1.5 hours instead.

I thought it might have been using fried meat from a SMC. Tested with one using fresh minced/fried meat and one using fried meat from SMC, exactly the same recipe (all components identical), both came out ~1.5 hours.

Then I thought, I wonder if it's a few particular recipe combos that were off. So I found a previous recipe that definitely gave 4h+, cooked it fresh, and it's also giving ~1.5 hours.

I expect some variance in timers (i.e. if it was 3.5 hours instead of 4, it would be the herb changes, no big deal) but this range of recipes have been coming out at between 4 and 6 hours. To drop down to 1.5, it feels like something is wrong.

 

Unfortunately I don't have a large enough amount of ingredients to be able to test much more extensively. I hope someone can look into this.

 

Thank you ❤️ 

 

Edited by Xikk
  • Like 1

Share this post


Link to post
Share on other sites

My priest has 99.76 HFC.

 

For years I cook and feed myself, my alliance, and not only once i supply food for various public events (impalongs, etc).

 

My usual 99.05 ql full house pizza, without any special ingredients (no sausages, no bacon, no fish, no baked/cooked ingredients, etc), gives around 15 hours affinity from one bite.

 

Right before the new cluster launched I cooked a pizza which - surprise!  - gives around 1 hour affinity after a big bite. I have it stored in the small magic chest, in the kitchen, where I keep the regular food for consumption, separated by specific affinity food.

 

The recipe is the same one I use for years - chopped herbs, chopped veggies, ground spices, cheese and feta cheese, nuts, raw meat, dough, passata. Nothing changed (sure I could add more insect than canine meat, or beef or lamb, but that shouldn't have any impact on affinity timer!), is the same 99.05ql, ~30kg pizza i keep making since the cooking system changed.

 

Please check what is happening?

 

Share this post


Link to post
Share on other sites

For the food which gave shorter timers, did you store the chopped ingredients in Food Storage Bin?

 

If you take an ingredient from FSB, chop it and use in food, everything is fine.

If you chop the ingredients, put it in FSB and later take it out already chopped, timers don't add the chopping action complexity.

 

Share this post


Link to post
Share on other sites

I always chop around 150 of each herb and veggie, and ground 150 of each spice, and always use them from FSB, where I store them already chopped and never had the timer issue until now.

Share this post


Link to post
Share on other sites
Posted (edited)

I'm super glad it's not just me.

My affinity foods come out in the 50-54 QL range currently, for reference, if needed. ~62 HFC currently.

 

I also pre-chop things in batches and store them in an FSB, nothing's changed between cooking "correct" timer food and cooking this new failfood.

Edited by Xikk

Share this post


Link to post
Share on other sites
49 minutes ago, Evening said:

Right before the new cluster launched I cooked a pizza which - surprise!  - gives around 1 hour affinity after a big bite. I have it stored in the small magic chest, in the kitchen, where I keep the regular food for consumption, separated by specific affinity food.

 

 

Evening - can you clarify - has this been happening as a random thing, or consistently for you?

Share this post


Link to post
Share on other sites

It happened once, because I cooked the day before Steam launch, and played on the new servers ever since.

Share this post


Link to post
Share on other sites
Posted (edited)

Interesting.

 

I'd be really interested to know if you've found the same thing if you've cooked today on the new servers? (assuming you're doing cooking there)

 

I could handle it if it's a one-off bug, but after cooking 4 5 meals with the problem I don't want to take a chance on wasting more, already scarce, ingredients.

Edited by Xikk

Share this post


Link to post
Share on other sites

Update:

 

I cooked another pizza a few minutes ago, for a friend, on the old cluster, and I have the same issue:

 

d4fbf3570c0eb89e62b6e83d08f06059.jpg

 

"If" cooking with processed ingredients, stored in a FSB, is affecting the timers, then it is an unannounced change, because, as I said, I cook the same way since the cooking update came to live and I NEVER had this issue before.

Moreover, a decrease in timers from 15 hours to 1 hour would be simply ridiculous, no matter how stored the ingredients are!

 

I "count" on a bug, and I hope it will be fixed soooon, because affinities from cooking are a very important feature in our day to day lives!

Share this post


Link to post
Share on other sites
Posted (edited)

I'd question the "pre-chopped" FSB-stored ingredient thing, as I fry all of my chopped things before adding them into a meal anyway.

I've not done extensive research into whether chop+fry = higher complexity than unprocessed+fry or if the game "remembers" the previous state of an ingredient at all; I mainly chop to increase QL.

 

Having said that, I think I did transfer ingredients between FSBs just before this problem cropped up. 

 

Have I somehow ruined all of my ingredients?

I'll test it later pulling things in and out of the FSB, and with some freshly chopped ingredients too.

 

 

EDIT: I also just found this: 

Which, thinking hard about it, I might have done with some of my chopped stuff -> pans this morning. Maybe that's it.

Edited by Xikk
Additional info

Share this post


Link to post
Share on other sites

same issue, he also transferred fsb contents aswell so i'd guess transferring fsbs is messing with it

Share this post


Link to post
Share on other sites

It would be really handy to have this in the known issues list!

 

I just hope I can fix it...

Share this post


Link to post
Share on other sites

I found a solution!

 

Only a minor faff to sort your chopped ingredients out if you're suffering from this - edited original post with fix info.

Share this post


Link to post
Share on other sites
On 8/18/2020 at 2:10 PM, Xikk said:

I found a solution!

 

Only a minor faff to sort your chopped ingredients out if you're suffering from this - edited original post with fix info.

 

Have you tried, or can you please try the meal again in a day or two, and after a server restart, to confirm that the longer affinity timer is still there? Just in case.

 

It's pretty amazing anyway if this is indeed what was happening here. Thank you for your patience with it! I wouldn't call the workaround you found "minor" though, it may seem like a minor annoyance on new servers, but on old servers with tens of thousands of (potentially chopped) veggies per FSB it needs a proper fix.

 

In any case, the more important thing, it seems to me, is that if you're right, then we may finally know that there is a bug indeed here, and how to reproduce it.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Anarres,

Since the server conveniently just fell over, I have tested as you asked - the longer affinity timer on new food (post 'ingredient fixing') is still fine, those that were shorter than expected are still the same way.

 

I am all experimented out, but since I originally transferred chopped things into an fsb where there was none (thereby causing the bug), and putting 'broken' chopped things on top of a fresh chopped one sorted it out, I would reason that putting a fresh chopped one in an empty fsb and then transferring chopped on top of it from another fsb may have the same effect - and a solution on older servers.

 

Given past reports, I expect this can be reproduced and tested if others have more resources available and don't mind spending a little time on it.

 

I really hope this can be at least documented as a known issue, if not fixed entirely.

 

Thank you!

Edited by Xikk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this