Jpopuza

[Fixed] Newly crafted items not accurately updating item number in inventory.

Recommended Posts

I was making pegs.  It was saying I was making pegs.  But the number of pegs in my inventory wasn’t going up at the speed I was making them.  It said my inventory was full but it was like 29 below 100 items.  I put all the pegs in my inventory into a bsb and logged out.  When I logged back in there were 29 pegs now showing up in my inventory.  I had double checked the filter equipment, so that wasn’t the problem.  First time I’ve seen this.

Share this post


Link to post
Share on other sites
Posted (edited)

I took up 10 bricks, they vanished in the inventory, but the weight was still there, plus i couldn't take any more up. 
I relogged and the bricks were there again, i then tried to remove them and pickup some wood scrap instead, but they disappeared to, basically no matter what i pick up, it disappears until i relog. 

I tried to /Suicide, after this i could pickup items again, but only like 6-7 times then the issue returned.

I have tested on another PC, with same issue. 
I have verified files, same issue.
I removed everything i had on me, same issue.
I tested on an alt account on same computer, he did NOT have the issue.
I tried to delete all player files from the installation, same issue.

I tried a second /suicide, but the issue returns once again.

I had a GM by (Confucius) who could see the 10 bricks in my inventory, but i couldn't.  He has screenshot from his view plus my screenshot (below)
https://prnt.sc/tqqtn1

 

Character name:  denully
Server: Exodus

 

Update: Edit: i tried to see if i could maybe still build something, if the items were just invisible but still there, but when trying to build a wall (having invisible bricks on me) i get this error:  ERROR: stone brick not found, WurmID: 4285068570789634

 

Update: I have run around tested picking up a lot of things now and from what i can tell this issue only happens (to me) with the following items:  Stone Bricks, Clay, Cotton, Wood Scrap and Mortar

Edited by denully

Share this post


Link to post
Share on other sites

Thanks for the report, JP

Share this post


Link to post
Share on other sites
Posted (edited)

Duplicate post from merge.

Edited by denully
Duplicate post

Share this post


Link to post
Share on other sites

Merged with 

  same issue. 

Share this post


Link to post
Share on other sites

Same issue. Picked up some Sand, was not in Inv, was walking slow. Sand appeared on relog

Share this post


Link to post
Share on other sites

I only noticed when the carried weight of inventory was too high. I had been doing mortar, and after that about ten kg of joinable hot food (stew) with an oven. I'm pretty sure the bug didn't occur before the cooking stage. Relogging may have done something regarding the inventory, but it did not correct it.

Share this post


Link to post
Share on other sites

This is unpleasant. I am not enjoying this happening to me at all. No Sir not even a little. Every time i pick up some bricks the game just leaves me with 493kg on me that i can't see ....

Share this post


Link to post
Share on other sites
Posted (edited)

I just picked up 4 logs from a pile and had the same thing happen to me. My weight went up but the items were not in my inventory. Relogging made the logs visible.

Edited by Romadador

Share this post


Link to post
Share on other sites
22 minutes ago, Nadroj said:

This is unpleasant. I am not enjoying this happening to me at all. No Sir not even a little. Every time i pick up some bricks the game just leaves me with 493kg on me that i can't see ....

same sadly, impossible for me to play as it can't really do anything that requires me to pickup anything. :( we just gotta hope a solution is found fast, GM has informed DEV's as well, so hopefully it has some attention, the other post is also getting more and more users with same issue. 
 

Share this post


Link to post
Share on other sites
Posted (edited)

noticed twitter said "The server shut down: Reason: Hot fix for invisible inventory items. 30 minutes downtime expected."  however the issue remains, at least for me.

 

did try all the previous steps again,  relog, reinstall, other PC, different items, apart from /suicide again. Items still disappear after picking up 2-3 items.

 

Edit: moved my new findings up in my longer post with info.

Edited by denully

Share this post


Link to post
Share on other sites
Posted (edited)

Now this happens to me too, with stone shards becoming invisible in my inventory. It didnt happen before, just today for the first time. Relogging helps. Server Exodus. 

 

Now this is funny, after relogging I have two stacks of stone shards in my inventory, and I am about 100 kg over my max weight. I can access one stack, cannot access the other stack.

Edited by Brocules

Share this post


Link to post
Share on other sites

Yea also to mee too i wanted to make a new set of brick's and theme are hidden after creation, only log off an log in will make theme reappear into my inventory. This is weard because with 1 hour before i have made theme without any issue. Also that were made from fresh mined stone not from crate, i have tried this also but right now seems that still not working still dissapear and need to relog each time.

Share this post


Link to post
Share on other sites

We originally weren't getting this problem, though we noticed Denully and a few others mentioning it in the CA_HELP. (Both before and after the Fix was implemented)

Now we are receiving this problem with Mortar, possibly pottery bricks, but definitely mortar.

We were adding items to the wall in an attempt to "use up" the invisible mortar, though it simply wasn't continuing the wall in anyway, DESPITE using up the Pottery Bricks. Added almost 15 bricks and 15 "Invisible" mortar to a wall, with only the bricks disappearing and no advancement on progression of the wall.



Just thought I'd add to this as well.

Share this post


Link to post
Share on other sites

Mortar and bricks are invisible in the inventory. its correct in weight but cant use them [15:06:36] ERROR: stone brick not found, WurmID: 3288084372259586. After i relog they are there and can use them again. Just adding to confirm all.

Share this post


Link to post
Share on other sites

After the update, I still have problems with invisible items. Keel sections and logs not being visible, only appearing after restart.

Share this post


Link to post
Share on other sites
Posted (edited)

So far the latest Patch (few min ago) seems to have resolved the issue for me at least.

Edited by denully

Share this post


Link to post
Share on other sites

This patch should have fixed the issue.  https://forum.wurmonline.com/index.php?/topic/176965-patch-notes-30jul20/

 

If you still have a problem with inventory, be sure your inventory filter icons are all off so that you are seeing your total inventory.  If there is something in your inventory which you cannot drop or move, put in a support ticket for GM assistance.

 

If you have a different inventory issue, please open a new bug and detail what actions caused the issue.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.