Sign in to follow this  
Zera

Character Rename

Recommended Posts

So I'm aware there's a command that can be used:

#rename <oldname> <newname> <SteamID 64>

But for some reason when I try to use this command ingame, I'm given this Event message:
[00:54:47] Not all servers are connected (0). Try later. This is an Error.

 

There aren't any other servers.. I don't run cluster.

I've tried this command both with the player Online and Offline.

 

And changing the name manually in the database (either I missed a step or something) didn't appear to work as the new name was unable to connect at all and the old name wanted to make a new character.

 

Can anyone help me out here on how I should go about doing this?

Share this post


Link to post
Share on other sites
11 hours ago, Zera said:

So I'm aware there's a command that can be used:

#rename <oldname> <newname> <SteamID 64>

Are you sure it's not supposed to be:

#rename <oldname><newname><adminpassword>

 

If you're on a hosted server, try the password you use to log in to your control panel.

Share this post


Link to post
Share on other sites
44 minutes ago, Batta said:

Are you sure it's not supposed to be:

#rename <oldname><newname><adminpassword>

 

If you're on a hosted server, try the password you use to log in to your control panel.

 

no it is the steamid 64 as 3rd param

Share this post


Link to post
Share on other sites
11 hours ago, Zera said:

So I'm aware there's a command that can be used:

#rename <oldname> <newname> <SteamID 64>

But for some reason when I try to use this command ingame, I'm given this Event message:
[00:54:47] Not all servers are connected (0). Try later. This is an Error.

 

There aren't any other servers.. I don't run cluster.

I've tried this command both with the player Online and Offline.

 

And changing the name manually in the database (either I missed a step or something) didn't appear to work as the new name was unable to connect at all and the old name wanted to make a new character.

 

Can anyone help me out here on how I should go about doing this?

 

Problem is that you have another server in the wurmlogin.db. Delete the server with the name "0".

Make sure you only have one server in there.

Share this post


Link to post
Share on other sites
2 hours ago, Sklo:D said:

 

Problem is that you have another server in the wurmlogin.db. Delete the server with the name "0".

Make sure you only have one server in there.

I've apparently got 4 total server ID's in there...

 

Had an issue with the server once upon a time denying old characters and forcing new character names in order to connect.

So I'm certain that's what caused this to start with.

 

My question now is, how do I go about properly fixing all of this mess without damaging data we're actually using?

Is deleting the lines for the ServerID's we're not using safe and enough?
How do I know what ID we are using?
Where can I make sure that we continue to use the proper ID for the server information we have? (To prevent this sort of thing from occurring again??)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this