Texture/tiles issue

Recommended Posts

 Hello dear Wurmians,


Some tiles aren't loading properly in my game , which makes the game pretty unplayable. I don't really know where this bus is coming from.

When I move around the world, the tiles will refresh and some that were unload will then correctly load, but some tiles that were previously correctly loaded will become unloaded


I tried to change a few things in the settings but nothing changes :


-Fresh Windows install

-Drivers are up-to-date

-Repaired the game through Steam

-Uninstalled and reinstalled the game

-Tried with default settings

-Tried to tweak around the settings (specifically tried with the modern and legacy renderer)


Here' are a few screenshots so you can see b y yourself.


List of my components :


MOBO: MSI B450 Gaming Plus Max

CPU: Ryzen 3700x

GPU: Radeon RX 5700

RAM: 16 Go DDR4 3200 MHz

SSD: 1 To

Share this post

Link to post
Share on other sites


Can you uploada copy of your client log? This is found in the wurm folder as console.playername.log 

Share this post

Link to post
Share on other sites

could be that your java is old/out dated.

One issue that jumps out is from like 6 years ago and I believe it has been fixed since then.


Although it does look like the java version in log is up to date.



Running the java application as Administrator, this giving the process permission to access the systemRoot parts of the registry, resolves the problem.


Edited by Cuddles

Share this post

Link to post
Share on other sites

I have installed the latest version of Java and this hasn't fixed the problem. Any further help would be much appreciated.




Share this post

Link to post
Share on other sites

Had a similar problem a year or so ago, don't recall the reason for it or how it was solved, but somehow I noticed dds-files didn't load, only png files. Oh, I think it had to do with a missing library, and installing that library fixed it. What I did was to extract graphics.jar, convert all dds-files to png, and then replace ".dds" with ".png" in all mapping-files, and then I wrote a program that edited the binary wom-files and replaced "dds" with "png", and then the textures would load. But as I said, it was all in vain, because once I got that library installed, the original graphics.jar would load again. Anyway, if you notice that it's only the png-files loading, that's one way to do it. I doubt it's the same solution with installing a library though, I'm on Linux.

Share this post

Link to post
Share on other sites

I see you are using AMD driver version 19.11.2. In this post tile problems have been reported using version 19.11.3.


Try reverting to an older version of the graphic drivers.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.