Samool

WSA: Wurm Online Launcher changes

Recommended Posts

It did it without asking me, i was looking at something else for a second and next thing i knew everything shut down

Share this post


Link to post
Share on other sites

 

2 hours ago, SmeJack said:

It did it without asking me, i was looking at something else for a second and next thing i knew everything shut down

 

It does asks you, but reboots your PC before you answer it. I was able to stop the shut down process before it completed and thats when I saw the box asking for confirmation. Seems it jumps the gun before you choose.

 

 

Share this post


Link to post
Share on other sites

Did install the next start without problems but when the game runs the key mapping is not right.

For example move forward is the 'W' key in my settings but when I press the 'W' I got Climbing On. The 'Z' key does move forward after some testing (while in the settings it stands on 'W')

Problem start proably with the azerty keyboard layout that is used in my country.

 

 

Share this post


Link to post
Share on other sites

Where I come from its not really asking if you don't wait for an answer ;)

Share this post


Link to post
Share on other sites

Hi do you want some milk

 

No thanks I'm lactose toler-

 

*milk being forced down throat

Share this post


Link to post
Share on other sites
Posted (edited)

this new setup has one annoying bug

 

when I minimize a specific client window the game will appear on my other monitor, gets annoying and old quite fast...

 

client doesn't remember postions of last time

 

running a 2k side monitor (Portrait) and a 4k main monitor (Landscape) if that helps.. the client generally likes to open like this:

 

41dd3a24098a74b0f4abdca80b2376de.png

 

white line indicates it's on my 4k monitor as well upon opening. (unable to fix this or get it working)

Edited by Niki

Share this post


Link to post
Share on other sites

As sad as I am that others have experienced the same problem as me, I'm rather happy that I'm not losing my marbles and it did happen exactly as I described.

Share this post


Link to post
Share on other sites

Alright so, I tried out the windows installer.

 

It forced a system reboot without asking (as in it sent the reboot command, and then asked me).  Might want to fix that one.

Share this post


Link to post
Share on other sites

I find the new launcher a bit annoying because when I try and start a client on my 2nd screen it always open on my main screen.

Before what ever screen I press play on the client it would open the game there now not so much :(

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

i just tried to install new client, seems to install ok, but when i try to start it up, another window pops up named c:\\windows\sytem32\ cmd.exe, inside that it says hit any key to continue, i do and nothing happens, give it the old three fingered salute and there is a process running, but nothing happens with wurm. 

doesn't seem to be any log files anywhere either

i have uninstalled and reinstalled a few times, only thing i haven't tried is uninstalling java and let it install it.

not sure what other information i can provide

 

windows 10 

java 8 version 211 (current i have checked it is 64 bit, stable version runs just fine)

i did change the default install to my d drive, path is the same

 

Edited by siimerowpha

Share this post


Link to post
Share on other sites

I should have posted here, but made a bug report first 'cus I'm dumb.

 

If you install the 32 bit version for Windows, it will add shortcuts to your desktop to wurmlauncher64.exe and not wurmlauncher32.exe so the shortcuts created by the installer to launch the launcher don't work. This is ONLY on the 32 bit version. 64 bit version works as intended.

Share this post


Link to post
Share on other sites

Yep, forced reboot closed apps for me. Thank goodness MS Office docs have a recovery feature. Saved a bit of mapping I was doing at the time.

Share this post


Link to post
Share on other sites
On 7/11/2019 at 5:41 PM, riceri said:

I am running Gentoo (Linux) and when i run the file it adds _old to the file name then nothing happens. So all it do is renaming it self :) WurmLauncher_old_old_old_old_old_old_old

Make sure the directory and the executable itself has read/write/executable permissions all set, I just tried it on a fresh install of Gentoo and it worked fine.

 

Apologies for the forced restart, it didn't happen during testing (and still doesn't happen on a fresh Windows install when I try it), but it should be fixed with a launcher update coming out soon, possibly today.

Share this post


Link to post
Share on other sites
On 7/14/2019 at 5:38 AM, siimerowpha said:

i just tried to install new client, seems to install ok, but when i try to start it up, another window pops up named c:\\windows\sytem32\ cmd.exe, inside that it says hit any key to continue, i do and nothing happens, give it the old three fingered salute and there is a process running, but nothing happens with wurm. 

doesn't seem to be any log files anywhere either

i have uninstalled and reinstalled a few times, only thing i haven't tried is uninstalling java and let it install it.

not sure what other information i can provide

 

windows 10 

java 8 version 211 (current i have checked it is 64 bit, stable version runs just fine)

i did change the default install to my d drive, path is the same

 

Can you list what files/directories are there in the directory the .exe has installed? You can get there by right-clicking the shortcut and selecting "Open file location".

 

16 hours ago, zethreal said:

I should have posted here, but made a bug report first 'cus I'm dumb.

 

If you install the 32 bit version for Windows, it will add shortcuts to your desktop to wurmlauncher64.exe and not wurmlauncher32.exe so the shortcuts created by the installer to launch the launcher don't work. This is ONLY on the 32 bit version. 64 bit version works as intended.

Will be fixed with the launcher update too.

Share this post


Link to post
Share on other sites

How do I access the new low memory client?

 

Currently running linux, executing the linux download installs the regular version of the client at version 4.1.67 but gives no option for the low memory client.

 

Clearing my cache and trying the jnlp from before http://wurmonline.com/client/wurmclient_lowmem.jnlp gives me the 4.0.94 version of the launcher.

 

The downloads page does not mention a new low memory client anywhere that I can see.

Share this post


Link to post
Share on other sites
19 minutes ago, Dinant said:

How do I access the new low memory client?

By running the launcher with ./WurmLauncher -lowmem

 

In time there will be a proper installer for linux which can create the different shortcuts as well.

Share this post


Link to post
Share on other sites
On 7/16/2019 at 8:19 AM, Samool said:

Can you list what files/directories are there in the directory the .exe has installed? You can get there by right-clicking the shortcut and selecting "Open file location".

 

 

win64(folder)

client_live.jar

unins000.dat

unins000.exe

wurmlauncher64.exe

 

 

thats all of them

the main c drive is an ssd that i would really like to just keep windows 10 installed on, i will try uninstalling and reinstalling to the c drive and see if things change

it installs and works correctly if i install to the c drive, looks like wurm doesn't like being installed anywhere but main drive

 

Edited by siimerowpha

Share this post


Link to post
Share on other sites

New installer out now, should not restart by itself anymore and has a couple other issues fixed.

1 hour ago, siimerowpha said:

the main c drive is an ssd that i would really like to just keep windows 10 installed on, i will try uninstalling and reinstalling to the c drive and see if things change

it installs and works correctly if i install to the c drive, looks like wurm doesn't like being installed anywhere but main drive

 

It's just about 200mb total the launcher will take so not too bad, but it works when I install it on any drive. Can you try again with the updated installer (download it from the website)? Might've fixed itself with some other fixes.

Share this post


Link to post
Share on other sites

I've been having frequent crashes when starting up Wurm using the new launcher. I'd say it crashes around 50% of the time, after clicking play, during the looading screen with the standard windows error message:

23c1ebc804ff1d8ce55a6d1077b00a05.png

 

Looking at the Windows event logs, it has this to say:

 

Faulting application name: WurmLauncher64.exe, version: 1.0.0.1, time stamp: 0x5d271145
Faulting module name: ntdll.dll, version: 10.0.17763.592, time stamp: 0x0f1b8afd
Exception code: 0xc0000374
Fault offset: 0x00000000000fb049

 

 

Not having problems starting any other programs, and haven't had this issue with Wurm before so I assume it's a problem with the new client. Any ideas?
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now