Jaz

[Preview][Linux]Keyboard layout not respected for keybinds

Recommended Posts

On Linux, the preview client does not respect the system keyboard layout for keybinds.

For example I have the "Examine" set to "Z" which is swapped with "Y" on my layout. 

In chat windows etc. the layout is fine but I need to use the "Y" key (which is the UK/US "Z") to get the "Examine" action instead of my "Z".

Share this post


Link to post
Share on other sites

It happens because keybinds on Preview are key based, not character based - basically it's just the display of the bind in the right-click menu and in the settings that's wrong, not the functionality, I'll see about fixing it.

Binding through console might be a bit tougher since the client is not aware what character corresponds to what key in your keyboard layout, will check if there's any viable fix for that - keep in mind the quickbind feature can often be quicker and easier than doing it by console.

Share this post


Link to post
Share on other sites

If I set a bind with a long press of Z, I get a Y in the Rclick menu - I need to press Z of course but that is really misleading. Might be much more confusing for all those layouts where the numbers are pressed by using shift or for example French layout where quite all the keys are moved around on the table.

Share this post


Link to post
Share on other sites

Fixed in today's update, haven't had a chance to test it on Linux though - let me know if it's good now.

Share this post


Link to post
Share on other sites

Hmm.. how do I download the new preview client for Linux? 

Share this post


Link to post
Share on other sites

Tried it - the long-press issue seems to be fixed: if I set a keybind to "Z" that way it shows correctly as such and the action is played correctly.

But setting keybinds in console is broken:

 

FQgNctT.png

 

Which means if I set "bind Z close" it will show up as "Y" in the context menu and I need to use Y there. 

Looks like the console setting is not taking account the actual keyboard layout but the English one.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Jaz said:

Which means if I set "bind Z close" it will show up as "Y" in the context menu and I need to use Y there. 

Looks like the console setting is not taking account the actual keyboard layout but the English one.

 

Seeing the same here.

Share this post


Link to post
Share on other sites

That'll remain the case for now, quickbinds and the settings are the recommended way to set keybinds - console shows raw text, it can't really detect keys from the characters, just the other way (if that makes sense)

Share this post


Link to post
Share on other sites

Was there a change how the keys are read? It works flawlessly with the stable client both in console window and quickbinds. There are keybinds that cannot be set with quickbind (for example Examine in my case as I prefer the Examine context menu options being hidden), and swapping/backing up keyfiles suffer from this issue as well.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Update: just checked the Z and Y keybind and if I set them in the settings-> keybind menu it is still swapped up. I see Z there and I need to press Y to achieve the keybind. So the issue is not that the console...

just for the record, the JNLP version is still fine: 4.0.95(031f4bc)

WurmLauncher version is swapped up: 4.1.71(ef02e8b)

 

 

Edited by Jaz

Share this post


Link to post
Share on other sites

Should be fixed now with the settings showing the appropriate keys. Console will still use the "default" key for a character (so in QWERTY US layout)

On 8/16/2019 at 1:02 AM, Jaz said:

Was there a change how the keys are read? It works flawlessly with the stable client both in console window and quickbinds. There are keybinds that cannot be set with quickbind (for example Examine in my case as I prefer the Examine context menu options being hidden), and swapping/backing up keyfiles suffer from this issue as well.

Yes, there was a ton of back-end changes with the switch to LWJGL3 with the new client. There'll be a better in-game settings window for keybinds in with the new UI, for now the quickbinds + current settings are the recommended ways to change bindings. You'll have to keep in mind the layout differences if you want to use the console.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.