Sign in to follow this  
Jukken

Server crossing

Recommended Posts

Getting error when trying to cross to other server,

This is the message I get (in chat) when I try:

"[09:56:00] An error was reported from the login server. Please try later or report this using /support if the problem persists."

 

Here is the message in the logfile on login server:

 

[09:54:48 AM] INFO com.wurmonline.communication.SocketServer: Accepted player connection: Socket[addr=/85.228.204.112,port=63070,localport=3724]
[09:54:49 AM] INFO com.wurmonline.server.steam.SteamHandler: Client was Authenticated
[09:54:49 AM] INFO com.wurmonline.server.LoginHandler: /85.228.204.112,Altor successfully logged on, id: 22880594.
[09:54:52 AM] INFO ModComm: Received client handshake from Altor, 1 channels, protocol version 1
[09:54:52 AM] INFO ModComm: Activating 1 channels for player Altor
[09:54:52 AM] INFO org.gotti.wurmunlimited.mods.httpserver.PackServer: Got request /serverpacks/map_ereb?prepend&force
[09:55:58 AM] INFO com.wurmonline.server.items.RecipesByPlayer: packing 0 known recipes!
[09:55:59 AM] INFO com.wurmonline.server.intra.PlayerTransfer: Failed copy to target server for Altor took 285 ms.

Share this post


Link to post
Share on other sites

make sure you have RMI enabled on both servers in wurm.ini and that all ports and passwords match between them.

Share this post


Link to post
Share on other sites

Never changed anything, been running for years....  but I'll check...

Share this post


Link to post
Share on other sites

These are the settings on the main (login) server.

I can't see any misstake I've made, but perhaps someone else can.

 

scr_e1.pngscr_e2.pngscr_e3.png

 

These are the settings on the other server:

 

scr_m1.pngscr_m2.pngscr_m3.png

Share this post


Link to post
Share on other sites

Need to know some information on your setup?

I see the IP adress are not LAN ones, Are you using a Server Hoster or your own home internet?

 

Share this post


Link to post
Share on other sites
9 hours ago, Jukken said:

Home.

No NAT.

 

Could be windows firewall

Share this post


Link to post
Share on other sites

Try a new alt and see if it works, this will prove it isn't any kind of player corruption

Share this post


Link to post
Share on other sites

You fixed you own problem last time:-

 

Share this post


Link to post
Share on other sites
22 hours ago, Sklo:D said:

 

Could be windows firewall

 

Disabled everything. ?

Share this post


Link to post
Share on other sites
On 6/1/2019 at 9:17 PM, Jukken said:

These are the settings on the main (login) server.

I can't see any misstake I've made, but perhaps someone else can.

 

scr_e1.pngscr_e2.pngscr_e3.png

 

These are the settings on the other server:

 

scr_m1.pngscr_m2.pngscr_m3.png

 

 

Oh how could I overlook that.

The internal IP address needs to be the IP address in the LAN. So if all servers running on one machine use 127.0.0.1 as server internal IP address. 

 

scr_e2.png

Edited by Sklo:D

Share this post


Link to post
Share on other sites
15 hours ago, Jukken said:

The are on two different physical machines.

 

Then take the LAN address as server internal address. LAN (private addresses) can have the following ranges:

The address 88.xx.xx.xx is not a LAN address as you can see, so server communication can't work.

Find the LAN address by typing ipconfig into CMD.

 

Post-19-Private-IP-addresses-and-subnets

Edited by Sklo:D

Share this post


Link to post
Share on other sites

This is no LAN adress, the servers are directly to the ISP. These is no local gateway, no NAT.

 

ipconfig2.png

Share this post


Link to post
Share on other sites

Are the RMI ports open between the two IP addresses?

Share this post


Link to post
Share on other sites
2 hours ago, Jukken said:

This is no LAN adress, the servers are directly to the ISP. These is no local gateway, no NAT.

 

ipconfig2.png

 

Well that explains things. I am not even sure if you can do RMI between public IPs, I guess you can but it can be dangerous if you don't use any firewall.

 

This is a big mess but I think I found the issue. On the server Majura in neighbours the internal port is 48110 for Ereb, but Ereb uses port 48111 as internal port. This should be the issue. But I am not sure if it is the only issue.

Share this post


Link to post
Share on other sites

Thanks Sklo. That was the issue.

Been messing around too much trying to get it to work...that was it.

 

As for the security, there is nothing but the wurm server on the machine...so if someone wants to mess it up, I'll just reinstall everything, including OS.

Share this post


Link to post
Share on other sites
1 hour ago, Jukken said:

Thanks Sklo. That was the issue.

Been messing around too much trying to get it to work...that was it.

 

As for the security, there is nothing but the wurm server on the machine...so if someone wants to mess it up, I'll just reinstall everything, including OS.

 

You don't want to be hacked, promise me. Your machine is usually used for hacking others if it is hacked and not for messing your game server up. And RMI opens a good door for remote code execution and such stuff. So be warned, add 2 firewall rules per machine for the RMI ports it is quite simple on Windows. Create an inbound rule on all machines which only allows your other servers to access the RMI ports.

Share this post


Link to post
Share on other sites

Yep agree with sklo proper firewall rules that only allow those RMI ports to be used by that other IP address ONLY. So nobody with any other IP can access it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this