Adambean

Shafts of white/black light gone since 1.9x?

Recommended Posts

I've just noticed that the white/black shafts of light from the Altar of the Three and Great Bone Altar no longer show up. Only noticed they're gone now as of 1.9x though.

 

Anyone not seeing those?

  • Like 1

Share this post


Link to post
Share on other sites

I can see both on the 1.9 WU server I am urrently on. 

 

Is this a much larger map than normal? On an 8k map they won't be visible till you are rather close.  

 

I am on an unmodded server. Could it be a mod interfering?

 

Sometimes I can only see the beams (on various servers) if I look at a certain distance or angle.  

 

It's also possible something in graphic settings is making them invisible for you.

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

Possibly a graphics setting then.  

 

maybe also try logging off two minutes then back in and see if that makes a difference.

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

It has to be some sort of client issue. This affects some players on my server, and others have no issue seeing the beacons. Myself, I cannot see them after removing all client mods, validating files, uninstalling, reinstalling. I gave up on the matter entirely. The bloom effect exists on the altars as though the beacons are active, so not dead altars. I figured it was just something with my graphics card since the specular mapping with 1.9, but no idea really. I have two other people who cannot see it on modern/legacy and then some that say only legacy they can see it.

  • Like 1

Share this post


Link to post
Share on other sites

Check especially COMPATABILTY  settings like GLSL,  VBO/FBO, make sure those are all set to  CORE.  

 

Check that drivers are NOT installed by Microsoft Update/Device Manager, which have poorer support for OpenGL, but rather go direct to the graphics card maker for the newest drivers they have for you:

 

I remember this issue coming up before but cannot recall the solution. It seemed like there was one though ...

Test that DPI scaling is turned off; that was causing conflicts for some people but it might have been for a completely  different issue.

By any chance are you all using Radeon cards, or Macs, or something?

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

I'm on Windows 10 with Nvidia GeForce GTX 970 all drivers handled by Nvidia and not Windows, I will check compatibility when I wake up. Nothing should have changed, but I suppose some things could have changed inadvertently.

Share this post


Link to post
Share on other sites

Dual monitors for me, 1920x1080 resolution on both.

Share this post


Link to post
Share on other sites

I periodically hear quirky things in Wurm with dual monitors. Does anyone else with this issue of not seeing the beams, also have dual monitors?

 

No idea why that would make any difference, just that "dual monitors" pops up sometimes in the tech help section. Might be more often though with lag/crash issues.

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

nVidia GTX 1060 with official drivers, 1x 1440p screen, no scaling, and all settings on core. 

 

Only difference so far is the game version. 

Share this post


Link to post
Share on other sites

are you using the modern or classic renderer? they don't show on modern for whatever reason

  • Like 1

Share this post


Link to post
Share on other sites

Yes, but I was using modern in 1.8 too, unless it never actually worked back then. 

Share this post


Link to post
Share on other sites
19 hours ago, Oblivionnreaver said:

are you using the modern or classic renderer? they don't show on modern for whatever reason

 

 

I have both the white & black ok on modern renderer, for whatever it is worth..  but yeah definitely see whether toggling that setting makes any change.  

 

Unclear why some of us can get it on Modern Renderer while others cannot. It might be some other setting in conjunction with Modern Renderer...?

 

 

 

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

Found this on the Steam forums:

 

confirming what xype said, FBO disabled (compat settings are on the launcher not in game) with the modern renderer shows the WL and BL
modern with FBO enabled blocks the beams

 

https://steamcommunity.com/app/366220

 

 

** NOTE: If I set VBO to extension,  and leave FBO on CORE, I get both the beams and the xray (mod) even when the game is set to Modern renderer.

Edited by Brash_Endeavors
  • Like 2

Share this post


Link to post
Share on other sites
29 minutes ago, Brash_Endeavors said:

Found this on the Steam forums:

 

confirming what xype said, FBO disabled (compat settings are on the launcher not in game) with the modern renderer shows the WL and BL
modern with FBO enabled blocks the beams

 

 

https://steamcommunity.com/app/366220

 

 

 

Will try tonight. I forget to check steam tbh.

Share this post


Link to post
Share on other sites

Would changing that degrade performance? I read somewhere that modern renderer only works when all compatibility options are on core.

 

Edit: Setting framebuffer objects to extension did fix this for me too, but it did force me back to the classic renderer. (Old water and slight performance loss.)

Edited by Adambean

Share this post


Link to post
Share on other sites

This issue appears to impact eagle spirits and drake spirits. Other than their outline they are now completely invisible!

 

FNSAP0I.png

Share this post


Link to post
Share on other sites

Yeah, you can only see them if you have this issue with VBO or FBO extension fix, or just use legacy client. Hopefully it will be fixed before the next 6 month from now update.

Share this post


Link to post
Share on other sites

Thanks, with the console logs we've been able to identify and correct both issues. Will be in the next update, but no ETA

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.