Sign in to follow this  
TeeeBOMB

[Bug] Horse is Stuck in Labor?

Recommended Posts

I got a female horse. I bred it at 12:21pm EST on 6Mar2019 on my deed (Cornersville) on Indy server.

 

This horse first time showed 'She will deliver in about 1 day' on 11Mar.

 

Today is 21 Mar, been 10 days and it still shows 'She will deliver in about 1 day.'

 

XScvGAZ.jpg

 

Not sure if this is a problem. I don't recall off hand any horse getting stuck this long on a particular day. My record from before was a horse (this same horse I think) got stuck at 'She will deliver in 0 days' for 3 days in a row.

 

Are there server horse population count code that will mess w/ pregnant horses?  I worry that this very late pregnancy is an indication that something may be going haywire.

 

Thanks your time,

 

TeeeBOMB

Share this post


Link to post
Share on other sites

Here is an earlier thread:

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, TeeeBOMB said:

I don't recall off hand any horse getting stuck this long on a particular day. My record from before was a horse (this same horse I think) got stuck at 'She will deliver in 0 days' for 3 days in a row.

 

 

I used to get this too, some years back, my examples are listed in Muse's link but as an example:

 

October 8: The Venerable fat Silverpie and the Aged fat Cactusraid get intimate. The Venerable fat Silverpie will probably give birth in a while!  

October 8: She will deliver in about 7.

October 12:  She will deliver in about 6.

October 14: She will deliver in about 6.

October 16: She will deliver in about 6.

October 18: She will deliver in about 5.

October 20: She will deliver in about 5.

October 22: She will deliver in about 4.

October 24:  She will deliver in about 3.

October 26: She will deliver in about 2.

October 28: She will deliver in about 1.

November 2: She will deliver in about 1.

November 5:  Venerable fat Silverpie gives birth to Young Walkingnanook!

 

I had some others but few others with nearly 30+ day pregnancies. I filed reports with GMs simply so they could monitor the issue but I can't recall anyone ever deciding the cause. It seemed to be pretty rare but sometimes hitting the same players & same mares multiple times. 

 

My original suspicion was that it occurred because I lived in a "remote" area with zero neighbors/passing traffic and I was not online as much as normal during that time (still logging in every day or two but not for 8-12 hours days ...)  I have had other times in WO / WU where it would seem my animals would "pause" if the region was inactive  -- for instance,  horses would never get fat even at very advanced ages & excessive feed. Except -- they would get fat at a far end of the deed that was semi close to another settlement. But never on the side with "extreme low traffic/player activity".  However, when Silverpie was having her issues, other mares would go through multiple pregnancies without issue in the same time it took Silverpie to deliver one foal. Someone else reported a similar issue with one particular mare.

 

Theory #2 was that these were all outdated venerable horses that had been Cared For for many years, and possibly had originally all been born during a "glitchy" time many years in the past, or that Caring was somehow throwing off their time-advancement internal clocks (perhaps caring just super slows down the aging or server-check-polling).

 

Is your horse by chance both venerable -and- Cared For?

Do you live in a remote area with  very low player activity? (Most of the day, nobody is logged in)

 

None of those might be related, I am just asking ... well, in case they are.

 

 

 

 

Edited by Brash_Endeavors
  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, Brash_Endeavors said:

My original suspicion was that it occurred because I lived in a "remote" area with zero neighbors/passing traffic

 

it would seem my animals would "pause" if the region was inactive

 

Except at a far end of the deed that was semi close to another settlement. But never on the side with "extreme low traffic/player activity".

 

Yes, I am certain that this is so.  I have heard of this some time ago and have since become convinced.  Even the decay of off-deed items seems halted; at a particular super-remote location that I maintain it is as if time does not exist.  At another location, in an old off-deed mine, there is still a mallet head laying on the ground where there once was a pile of them four years ago.

 

I currently have several diseased animals that I have kept isolated and have been grooming daily for over a week, but animals at a more trafficked location become cured of their disease without any action on my part. 

Share this post


Link to post
Share on other sites
4 hours ago, Meldichoir said:

a super-remote location where it is as if time does not exist

I want to elaborate a bit more on that:

 

I was working at this very secluded location when one of my horses and a captured unicorn became diseased.  At one point I had moved the horse into a cave where I left a pile of mixed grass for it, but it did not eat a single unit of the food for two weeks, so I decided to move it out of the cave and back onto enchanted grass.  Months later I made the venture back to civilization and parked my diseased horse on one of my deeds and spent the night there.  The horse was cured of its disease when I logged in that next day.  The unicorn is still at the remote location currently and has now been diseased for over a year, although it has not lost any body fat whatsoever.

Share this post


Link to post
Share on other sites

Of course this is something I can't reproduce, but I've added a bug to the list in case this makes any sense to the devs.  I've personally seen a  horse or two 'stall' for a day or two, but never an extended period of time.

 

Also, with Indy going back and forth from server to temp server back home and back to temp server, it could cause issues, but your breeding seems to have started after the last Indy switch.

 

Will follow here as this is the latest issue and link the old report here and put both on the ticket.

 

Adding all posts regarding this issue to see if we can get a reason:

 

https://forum.wurmonline.com/index.php?/topic/113915-bred-mare-is-advancing-on-delivery-super-fast/

https://forum.wurmonline.com/index.php?/topic/166010-pregnant-horses-behaving-weird/

Share this post


Link to post
Share on other sites

Update:

 

Mama finally gave birth.

[23:21:11] The young Lilypie has arrived.  << happened  on 25 Mar 2019 (EST).

 

So. Got intimate 6 Mar w/ the message 'She will deliver in 5 days'. Final delivery just over 19 RL days later (if my math is right).

 

We can keep this open for history reasons, or close is ok w/ me either way. But the bug has passed. Not sure how often this happens. Could be it's quite often sort of thing, just ppl don't usually notice.

 

Thanks for your time. ?

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this