platinumteef

[Bug] placing bug

Recommended Posts

if you're in a cave and are placing an item and the item runs into a wall while being placed it just bounces above ground instead of simply getting stuck against the wall

      x  o

x x x  o

o o o o

x = cave wall

o = open tile

 

the red o is where it was, the blue o is where i tried to place it, and it runs into the wall and bounces above every time

item was an altar

Share this post


Link to post
Share on other sites

BMgNSsj.gif    bsb-doom.gif   ULTOcej.gif

 

 

oh no! oh no oh no oh no oh no!!!!!

 

 

It seems that the "Place" command has some Arcane Magick Powers that need to be kept in check, particularly when used in multistory buildings! This stuff has been happening to me with a bulk bin, but also a crate, and it probably applies to anything that can be Placed. I will continue to use "bin" as a convenient shorthand and for the sake of visualization.

 

Here are some bizarre scenarios that have happened so far, in order of increasing metaphysical danger:

  1. I've been able to use "Place" to transfer the bin across a gap, onto a tile I would not otherwise be able to get to.
  2. Not strictly related to "Place", but while standing on stairs, I am often in situations where I cannot transfer bulk items from a bin at the bottom of the stairs to be a bin on top of the stairs, even though I can take items from both and transfer manually, because the stairs are "in the way".
  3. I've been able to use "Place" to transfer a bin from one story to another, while standing on stairs.
    • Behavior seems to change  erratically if you move up or down the stairs while the Place command is in mid-use.
    • Sometimes this goes horribly wrong and the bin does a Wogic Teleport.
  4. Sometimes the bin forgets where it is supposed to be.
    • I had moved a bin from a spot near a plain stone wall to another room of the building (on the 6th(?) floor) through a combination of pushing and placing. While in that room, after using it for a while, I tried to Place the bin on a floor nearby, I got the following message:
      [20:45:48] The plain stone wall is in the way. [20:45:48] An error occured while placing that item, please try again.
      There was no plain stone wall in the way, but it did then Wogic Teleport to the spot near the plain stone wall where it had been 15 minutes prior, which I suppose would have been in the way at the time!

 

Wogic Teleportation seems to result in any of the following:

  1. The bin goes up from the floor it was on to the floor you are on, in the case moving up/down stairs, not necessarily in the direction you want and possibly even behind a fence to a spot you can't access. Or vice versa, if it touches the upper floor portion of a stair tile or otherwise is moved across a lower floor.
  2. The bin disappears and goes someplace it was several minutes before (I have seen this in multiple circumstances).
  3. The bin drops to the ground floor of the building.

Share this post


Link to post
Share on other sites

This sounds similar to some things I've experienced in buildings, where other strange things can happen if something goes through someplace weird on the way from one valid location to another via Place:

 

 

Edited by Ostentatio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now