Jikuu

Disconnects

Recommended Posts

I seem to be getting a lot of disconnects with this message in console every time. Was wondering what it was and whether anything can be done?

 

Spoiler

Game loop broken due to exception
java.io.IOException: An established connection was aborted by the software in your host machine
    at sun.nio.ch.SocketDispatcher.write0(Native Method)
    at sun.nio.ch.SocketDispatcher.write(Unknown Source)
    at sun.nio.ch.IOUtil.writeFromNativeBuffer(Unknown Source)
    at sun.nio.ch.IOUtil.write(Unknown Source)
    at sun.nio.ch.SocketChannelImpl.write(Unknown Source)
    at class.GijpRtOb4T.FZOk5L6Gfy(SourceFile:662)
    at class.GijpRtOb4T.XwhlvVTrl(SourceFile:542)
    at class.ZM4cSqt3bl.mMV5oPkCW(SourceFile:253)
    at com.wurmonline.client.WurmClientBase.wl8dyvdgaq(SourceFile:1529)
    at com.wurmonline.client.WurmClientBase.fgtPPuD8uC(SourceFile:7344)
    at com.wurmonline.client.WurmClientBase.run(SourceFile:38299)
    at java.lang.Thread.run(Unknown Source)
Startup Phase - Disconnected, trying to reconnect...
Disabling Nagles
Disabling Nagles

 

Share this post


Link to post
Share on other sites

It's a pretty common error that has been around for years, I think I have gotten it a few times over the years too, I don't know that any solution was found.

 

In googling around, I found Minecraft users often get this same error,  and at one point Notch (who also wrote some of the original Wurm code)  posted  that it might have originated from some of the code he wrote for Minecraft and he would try to fix it. That was back in 2009 and the same error has been  popping up sporadically every year since then, so i would not hold your breath as it seems there is no easy solution. (I don't think it was actually anything Notch wrote for either game,as it actually comes up in some other software too, I only linked to the Minecraft examples as solutions Minecraft users discover often help in Wurm, too -- and they found no solution).

 

Numerous attempts by people to adjust their antivirus or firewall all had no effect.  Sometimes there was an issue with multiple copies ofthe process running in task manager, and it is possible that Win7 users had the issue more often but that could also be coincidental.  

 

A check for the issue specifically on the wurmonline forum, came back with 93 results. . So you are not alone.  In one case, Wurm devs fixed a bit of code that gates were causing that created this same error message (suddenly and for a lot of people). 

 

Maybe try resetting the modem/router (unplug from wall, count to 10, plug back in again)  and restarting the computer in case it helps,but it is also possible that it is nothing you can "fix" on your end.  Wurm devs would probably need a pattern of reproducible errors to fix i t if it were something in Wurm code, but it might also just be a general Windows/ISP connectivity issue too. 

 

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

Thanks for the response @Brash_Endeavors

 

I've done a lot of the fixes that I can but nothing has really ever changed (reboots, reinstalls, disabling stuff, shutting down extra clients)

 

It's only been recently that it's started happening and ends up like 10 - 20 disconnects a day.

 

But at the end of the day sounds like nothing can be done, I'll just bear with it.

 

~Jikuu

 

Share this post


Link to post
Share on other sites

Packet loss? try to ping your wurm server when this happens... see if you drop packets...

 

Only way to fix that is to contact your ISP.. they'll figure it.(again: if it's packet loss)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now