An existing connection was forcibly closed by the remote host

Recommended Posts

Still looking for some suggestions as to why I get the above error when I attempt to connect to a server I created (see below). To date I've tried everything I can find in forums and wikis, including manually opening up all the ports that Steam and the game require (both TCP & UDP) to no avail. Regardless of what I have done so far, the server I create connects to Steam, but during the authentication process on the game splash screen authentication fails and gives an error. Thanks.


To repeat: I CAN boot the game up when I connect to WAN servers (that others have created). I only get this authentication problem when I am trying to play the game on a LAN server.


Long story short: I installed the game and the Steam Wurm server tool and configured as instructed by all the forums, tutorials, YouTube vids and wikis. The game loads fine and I can easily connect to someone else's server and create a character. But that does not interest me at present. I want my OWN server that I can be on alone or with the friend who gifted me the game. (Playing on a private servers is, after all, the point of Wurm Unlimited, yes?)


When I start the server it says "Server connected to Steam" (in the DOS window) so I then run the game interface, find my server on the LAN tab, and click CONNECT. I get the game splash screen and some initialization messages, then (every time) it starts the authentication process then stops at:


Network error: <An existing connection was forcibly closed by the remote host>


then it says it will try again in 180 seconds. Repeatedly.


Seems to me this a STEAM problem, not a game problem, but of course there is nowhere to report it because STEAM support is just an endless loop of "go ask the game developers."


Any clue as to why this is happening would be appreciated, the game looks very interesting. Thanks.

Share this post

Link to post
Share on other sites

@bigsteve -- Say what?

The game (and Steam) give you the opportunity to create a local server to play offline or locally alone or with invited players.  I create the server and it connects to Steam successfully (no errors in the DOS Cmd window).  Then I choose the LAN server I created on the list in the game interface and it starts to load the game (I get the splash screen) ... it starts the Steam authentication process and craps out and gives the error I mentioned. Makes no sense to me, since the server is successfully connected to Steam per the message on the startup window, but there you go.


If I do NOT try to run the game on my LAN, but instead choose one of the public servers from the WAN list, the game authenticates fine and boots up and opens to the character creation screen.  But I don't want to play the game on someone else's server, I want one that is local and under MY control.  So far, no workee, and it doesn't look like it's going to either, since I've tried every suggestion I've seen to date to no avail, including deleting and re-installing everything, as well as manually opening up all the ports the wikis say both Steam and Wurm need to run.  Which is a shame because it was a gift and I would like to give it a try, but only in the LAN version.

Edited by Caliburnius

Share this post

Link to post
Share on other sites

As I said, post the server and client logs,  so we can troubleshoot your issue.

Share this post

Link to post
Share on other sites

Hi there,
 Can you tell me what version you're running? As the above poster asked, can you post server and client logs? Thanks.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now