Sign in to follow this  
Followers 0
Adelric

Dedicated Server (only) pull downs crashes GUI

8 posts in this topic

I have steam and Wurm unlimited installed on 2 computers.

 

Computer 1  is an older desktop i5 8GB NVIDIA Geforce GTX550Ti 1GB Windows 10 Pro 64bit, used to be an old work machine but I have wiped it and  just used primarily for gaming and do not have any Java SDKs installed nor is Java in the path environment variable.

I have absolutely no problems in either dedicated or none, server modes.

 

On computer 2 is a newer Laptop I7 12GB  Geforce GTX960M 2GB, Windows 10 Home 64Bit, I have jdk1.8.0_65, jre1.8.0_144 and jre1.8.0_151 installed and C:\ProgramData\Oracle\Java\JavaPath is in the PATH environment variable

If I run server through GUI by selecting Manage Local server without "Use dedicated server" checked I have no issues but when I check  "Use dedicated server" I cannot change any of the setting via any pull down menus without the GUI crashing.

 

The laptop I use for work and development and just use it as the Wurm server when not working, so I have to keep the JDK's installed and can't change the environment too much.

 

Any suggestions on how to resolve this is appreciated.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Which log files are you referring?

I wipe the install and no logs are being updated under wurm dedicated server, the only files being edited are in the Adventure\sqlite folder but none appear to be log files; I even did a search by modified date of the whole steam folder and the files under the sqlite folder are the only ones changed during launch.

 

 

Here is the Console output...

 

Spoiler

 

Oct 27, 2017 9:14:15 AM com.wurmonline.server.gui.WurmServerGuiMain main
INFO: WurmServerGuiMain starting
Oct 27, 2017 9:14:16 AM com.wurmonline.server.Constants load
INFO: Loading configuration file at C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited Dedicated Server\.\Adventure\wurm.ini
Meshsize=11
Oct 27, 2017 9:14:16 AM com.wurmonline.server.Constants load
INFO: Loading configuration file at C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited Dedicated Server\.\Adventure\wurm.ini
Meshsize=11
Oct 27, 2017 9:14:16 AM com.wurmonline.server.DbConnector closeAll
INFO: Starting to close all Database Connections.
Oct 27, 2017 9:14:16 AM com.wurmonline.server.DbConnector closeAll
INFO: Finished closing all Database Connections.
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.util.VersionPrinter info
INFO: Flyway 4.0.3 by Boxfuse
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Adventure/sqlite/wurmcreatures.db (SQLite 3.0)
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Adventure/sqlite/wurmdeities.db (SQLite 3.0)
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Adventure/sqlite/wurmeconomy.db (SQLite 3.0)
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Adventure/sqlite/wurmitems.db (SQLite 3.0)
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Adventure/sqlite/wurmlogin.db (SQLite 3.0)
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Adventure/sqlite/wurmlogs.db (SQLite 3.0)
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Adventure/sqlite/wurmplayers.db (SQLite 3.0)
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Adventure/sqlite/wurmtemplates.db (SQLite 3.0)
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Adventure/sqlite/wurmzones.db (SQLite 3.0)
Oct 27, 2017 9:14:16 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Loading servers
Oct 27, 2017 9:14:16 AM com.wurmonline.server.Servers loadAllServers
INFO: Loading all servers.
Oct 27, 2017 9:14:16 AM com.wurmonline.server.Servers loadAllServers
INFO: Loading Dadio's Adventure Server - 11455
Oct 27, 2017 9:14:16 AM com.wurmonline.server.Servers loadAllServers
INFO: Using database entry for time 5967900
Oct 27, 2017 9:14:16 AM com.wurmonline.server.zones.TilePoller calcRest
INFO: Current polltile=817365, rest=0 pollmodifier=56515, pollround=2
Oct 27, 2017 9:14:16 AM com.wurmonline.server.zones.TilePoller calcRest
INFO: tiles=4194304, mask=-1 ticksperday=3456000, Nthick=1, rest=0, manypertick=true
Oct 27, 2017 9:14:16 AM com.wurmonline.server.Servers loadAllServers
INFO: Loaded 1 servers from the database
Oct 27, 2017 9:14:16 AM com.wurmonline.server.ServerProperties checkIfCreateTable
INFO: Created properties table in the database

 


 

 

For comparison here is the none dedicated console output...

 

Spoiler

Logs found: 0
Env var SteamAppId set to 0
C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmServerLauncher
Runtime path: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmServerLauncher\..\runtime\bin\server\jvm.dll
Working Directory: C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmServerLauncher
Number of options: 8
Create java VM!
Oct 27, 2017 9:16:18 AM com.wurmonline.server.gui.WurmServerGuiMain main
INFO: WurmServerGuiMain starting
Oct 27, 2017 9:16:19 AM com.wurmonline.server.Constants load
INFO: Loading configuration file at C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmServerLauncher\.\Creative\wurm.ini
Meshsize=11
Oct 27, 2017 9:16:19 AM com.wurmonline.server.Constants load
INFO: Loading configuration file at C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmServerLauncher\.\Creative\wurm.ini
Meshsize=11
Oct 27, 2017 9:16:19 AM com.wurmonline.server.DbConnector closeAll
INFO: Starting to close all Database Connections.
Oct 27, 2017 9:16:19 AM com.wurmonline.server.DbConnector closeAll
INFO: Finished closing all Database Connections.
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.util.VersionPrinter info
INFO: Flyway 4.0.3 by Boxfuse
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Creative/sqlite/wurmcreatures.db (SQLite 3.0)
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Creative/sqlite/wurmdeities.db (SQLite 3.0)
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Creative/sqlite/wurmeconomy.db (SQLite 3.0)
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Creative/sqlite/wurmitems.db (SQLite 3.0)
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Creative/sqlite/wurmlogin.db (SQLite 3.0)
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Creative/sqlite/wurmlogs.db (SQLite 3.0)
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Creative/sqlite/wurmplayers.db (SQLite 3.0)
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Creative/sqlite/wurmtemplates.db (SQLite 3.0)
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.DbSupportFactory info
INFO: Database: jdbc:sqlite:Creative/sqlite/wurmzones.db (SQLite 3.0)
Oct 27, 2017 9:16:19 AM org.flywaydb.core.internal.dbsupport.sqlite.SQLiteDbSupport info
INFO: SQLite does not support setting the schema. Default schema NOT changed to main
Loading servers
Oct 27, 2017 9:16:19 AM com.wurmonline.server.Servers loadAllServers
INFO: Loading all servers.
Oct 27, 2017 9:16:19 AM com.wurmonline.server.Servers loadAllServers
INFO: Loading New Creative Server - 4685
Oct 27, 2017 9:16:19 AM com.wurmonline.server.Servers loadAllServers
INFO: Using database entry for time 6276900
Oct 27, 2017 9:16:19 AM com.wurmonline.server.zones.TilePoller calcRest
INFO: Current polltile=1639252, rest=0 pollmodifier=25385, pollround=1
Oct 27, 2017 9:16:19 AM com.wurmonline.server.zones.TilePoller calcRest
INFO: tiles=4194304, mask=-1 ticksperday=3456000, Nthick=1, rest=0, manypertick=true
Oct 27, 2017 9:16:19 AM com.wurmonline.server.Servers loadAllServers
INFO: Loaded 1 servers from the database
Oct 27, 2017 9:16:19 AM com.wurmonline.server.ServerProperties checkIfCreateTable
INFO: Created properties table in the database

 

Share this post


Link to post
Share on other sites

I did some playing around and one thing I did on the none dedicated when I first installed was I deleted the Adventure then had to run update on Creative, I did the same thing for dedicated and the problem went away but the Adventure is now not available as it is deleted.

 

Also, I have another install of dedicated that I did with steamcmd and have been running a server on for a while now under C:\wurmserver\, it has the same problem but I can run it if I do not try to access the drop down menus and change everything using DB browser for SQLite.

 

It appears there is something wrong with the default Adventure, possibly the database maybe, or the installed files?

On a fresh install of Wurm and Wurm dedicated, the update button is grayed out for Adventure, but if I delete the default Adventure the Creative automatically is selected and then the update button is available; I tested if I could use the drop downs before I clicked update and the lockup happens until I click update the issue goes away, then the update button is also grayed out after.

 

Any ideas on how I can fix the Adventure server that I have been running for a bit now?

 

Edit...

 

To make sure everything is the same, I completely removed Wurm from laptop and desktop, including deleting the folders and started over again.

 

The desktop works fine without having to delete the Adventure Game, the laptop still has same problem.

On the laptop I cannot use any of the pull downs in the client or server setting what so ever like changing the Graphics resolution for example.

Edited by Adelric

Share this post


Link to post
Share on other sites

I did more testing by completely deleting Wurm Unlimited and WUDS again, same problem on none dedicated and dedicated with the pull downs freezing the server launcher, can't change settings in the client either without the client crashing.

 

Steps without dedicated server checked as it appears the problem is identical for either on the Laptop:

1. I cut and pasted the Adventure folder from the WurmServerLauncher folder to the desktop , relaunched Manage Local Server, the Adventure is gone and only Creative shows up, but all the pull downs work in the server launcher now, the client settings pull downs still crash the client.

 

2. I pasted the Adventure folder back into the WurmServerLauncher folder, the Adventure appears back in Select game folder to use pull down but all the pull downs are broken again; the client is still broken in regards to setting pull downs.

 

3. Moved the Adventure folder again, this time launching the server and playing on Creative, tried to change settings and game crashed when trying to change via pull downs, note you have to close down the server too as steam thinks Wurm is still running and you cannot relaunch the client until then. I tried the

JvmParam2=-Dglass.accessible.force=false

fix, but no change; I tried with JvMParam1 also because there was not a JvMParam1 in the ini file.

 

 

On the desktop I have none of these problems and the game, servers, etc work fine, the only two immediate differences I can think of are:

1. I have not installed the Java SDK on the desktop and when you run java -version you get program not found; on the laptop it points to the latest version I have installed which is 1.8.0_151

2. Desktop is Windows 10 pro, laptop is Windows 10 Home.

 

I have also tried to point to the Java version installed with WU by changing the LaunchConfig.ini too:

[Runtime]
OverrideJavaRegEntry=true
JavaPath=C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\runtime\bin\server
[Memory]
InitialHeap=512m
MaxHeapSize=2048m
[VMParams]
JvmParam0=-XX:+AggressiveOpts
JvmParam1=-Dglass.accessible.force=false

 

I am going to assume the Adventure pull down crash is related to the client setting pull down crash but at this point I am at a loss on how to fix it, the server runs and I can configure it with the DB browser but I prefer the GUI as it is a bit easier to navigate.

 

BTW just for s and giggles I copied the Adventure folder from the C:\wurmserver\ that I had been running for a bit to the desktop and it runs just fine, pull downs and everything work, so it is definitely something going on with the laptop but no clue as to what. 

Share this post


Link to post
Share on other sites
On 27.10.2017 at 2:10 PM, Adelric said:

On computer 2 is a newer Laptop I7 12GB  Geforce GTX960M 2GB, Windows 10 Home 64Bit, I have jdk1.8.0_65, jre1.8.0_144 and jre1.8.0_151 installed and C:\ProgramData\Oracle\Java\JavaPath is in the PATH environment variable

If I run server through GUI by selecting Manage Local server without "Use dedicated server" checked I have no issues but when I check  "Use dedicated server" I cannot change any of the setting via any pull down menus without the GUI crashing.

 

Ah well, I think I had this problem once too. I didn't read that you have a GTX M version, which means there is very likely a second Intel HD GPU in your Laptop too, which runs the default applications. I know it sounds strange, but I can remember that this pull down crash was solved by running the dedicated server with GTX instead of the Intel HD graphics card. There seems to be a bug where the intel HD graphics card is causing a crash on pull down.

 

Pretty sure if you run the dedicated server with the Nvidia card you will be fine, this would also explain why this only happens with the dedicated server but not with the non standalone server.

Share this post


Link to post
Share on other sites
On 10/28/2017 at 9:37 AM, Sklo:D said:

 

Ah well, I think I had this problem once too. I didn't read that you have a GTX M version, which means there is very likely a second Intel HD GPU in your Laptop too, which runs the default applications. I know it sounds strange, but I can remember that this pull down crash was solved by running the dedicated server with GTX instead of the Intel HD graphics card. There seems to be a bug where the intel HD graphics card is causing a crash on pull down.

 

Pretty sure if you run the dedicated server with the Nvidia card you will be fine, this would also explain why this only happens with the dedicated server but not with the non standalone server.

 

Yeah, I am aware of the  dual video processor issue, happens a lot for games not on the Geforce Experience list even if GE is not installed, and just to make sure I switched everything, dedicated, none dedicated and game client, to use the NVIDIA High Performance Processor and I still get the same result.

 

I want to make clear though, on the laptop the none dedicated server is the only place I can edit the pull downs and only after I delete the Adventure folder and click  "Update Game" on the Creative; I cannot use the pull downs in the game client GUI or the dedicated server GUI and the LaunchConfig.ini's are identical as shown above, however, I am not sure if the same result happens when I delete the Adventure folder on Dedicated as I do not want to lose the world I have been playing on and I don't think testing that would be relevant as if I can get the game client fixed I believe it will fix the server issue as well.

 

I can run the server on the desktop machine and play on the laptop as long as I do not try and change the settings in the game client when on the laptop; long ago, in 2011, I had the pull down issue on a desktop machine when playing Wurm Online and I cannot remember how I fix it and it very well could be the same fix.

 

I can edit the server thru the GUI on the desktop machine then copy the folder over to the laptop and run the dedicated server there, while playing on the desktop, after I change the IP and change the port forwarding, of course.

 

I have the server running fine now but would I like to solve the pull down issue just for sanity sake and in case anyone else is having the same issue.

.

 

Share this post


Link to post
Share on other sites
On 29.10.2017 at 10:17 PM, Adelric said:

 

Yeah, I am aware of the  dual video processor issue, happens a lot for games not on the Geforce Experience list even if GE is not installed, and just to make sure I switched everything, dedicated, none dedicated and game client, to use the NVIDIA High Performance Processor and I still get the same result.

 

I want to make clear though, on the laptop the none dedicated server is the only place I can edit the pull downs and only after I delete the Adventure folder and click  "Update Game" on the Creative; I cannot use the pull downs in the game client GUI or the dedicated server GUI and the LaunchConfig.ini's are identical as shown above, however, I am not sure if the same result happens when I delete the Adventure folder on Dedicated as I do not want to lose the world I have been playing on and I don't think testing that would be relevant as if I can get the game client fixed I believe it will fix the server issue as well.

 

I can run the server on the desktop machine and play on the laptop as long as I do not try and change the settings in the game client when on the laptop; long ago, in 2011, I had the pull down issue on a desktop machine when playing Wurm Online and I cannot remember how I fix it and it very well could be the same fix.

 

I can edit the server thru the GUI on the desktop machine then copy the folder over to the laptop and run the dedicated server there, while playing on the desktop, after I change the IP and change the port forwarding, of course.

 

I have the server running fine now but would I like to solve the pull down issue just for sanity sake and in case anyone else is having the same issue.

.

 

 

The issue only appears if you use the Intel HDD on the dedicated server instead of the geforce card. It is quite obvious that the setting is not correct yet. Enable the Nvidia card for the dedicated server and you will be good. It is the same application between the dedicated and the normal server, there is NO code difference, so it can only be your fault.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0