Sign in to follow this  
bdew

1.5 Beta!

Recommended Posts

Beta is up on steam!

 

Patch notes - http://steamcommunity.com/games/366220/announcements/detail/1452832937077649100

 

Fixed server modlauncher - https://www.dropbox.com/s/2ioqvamhozlmouc/modlauncher.jar?dl=0

 

Ago has an official update for the modlauncher - https://github.com/ago1024/WurmServerModLauncher/releases

 

If you need a place to test my test server is up too

 

image.png

 

Added: Most mods seem to be working, the only one i noticed broken so far is live hud map...

Edited by bdew
  • Like 4

Share this post


Link to post
Share on other sites
39 minutes ago, bdew said:

Added: Most mods seem to be working, the only one i noticed broken so far is live hud map...

And WurmESP is broken. The humanity!!!!

Share this post


Link to post
Share on other sites
55 minutes ago, Sindusk said:

And WurmESP is broken. The humanity!!!!

 

Oh-noes-everybody-panic.gif

 

  • Like 1

Share this post


Link to post
Share on other sites

These are just the names of the property files I had to disable. The mod names may or may not match the properties files.

 

server: bagofholdingconstruction, moonmetalminingmod, movetocenter (deprecated?), prospectmod, scriptrunner
client: livemap, toolbelt

I don't really play any more but noticed that Steam updated it so I thought I would check to see what might have broken.

 

Heh, helps if I run patcher.bat first eh? Crossed out the ones that ran after actually patching it.

 

Edited by Audrel

Share this post


Link to post
Share on other sites

toolbelt works for me... make sure you have the latest version and if it still gives you problems post a log please.

  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, bdew said:

toolbelt works for me... make sure you have the latest version and if it still gives you problems post a log please.

 

Yup. I didn't update it. It works fine. :-) I have not played Wurm in any flavor in a couple of months, so it's not surprising that I missed something.

Share this post


Link to post
Share on other sites

I noticed that the Bulk Container Unit and Crate Rack (the two things I really want from this release) have no models :\

Share this post


Link to post
Share on other sites
6 hours ago, vardoj said:

I noticed that the Bulk Container Unit and Crate Rack (the two things I really want from this release) have no models :\

 

The graphics are there.  Did this using WinRar, I believe 7zip does the job too for this.

 

In the packs folder of your Wurm client sits graphics.jar.  Open it with winrar or 7zip.

 

((Lazy version at the end which also fixes addy and glimmer veins' graphics))

 

*for devs*

In the graphics.jar are a bunch of folders, many of them with repeated folders and some repeated graphics in the /graphics folder in there, leads to some confusion including this one.

 

Extract mappings.txt  (if you can't find the lines mentioned below, in the .jar, open the graphics folder and get the mappings.txt from in THERE, lost track of which one I was using for a moment there).

 

Go to (ctrl+f in notepad at least)

 

model.container.rack.crate.empty        = models/Crates/crateRack_empty.wom
model.container.rack.crate.full            = models/Crates/crateRack_full.wom
model.container.rack.crate.unfinished        = models/Racks/shelfUnfinished.wom

 

and replace with

 

model.container.rack.crate.empty        = graphics/models/Crates/crateRack_empty.wom
model.container.rack.crate.full            = graphics/models/Crates/crateRack_full.wom
model.container.rack.crate.unfinished        = graphics/models/Racks/shelfUnfinished.wom

 

In that same file, go to 

 

model.container.rack.bsb.full                = structures/Hoppers/bsbRack_full.wom
model.container.rack.bsb.empty                = structures/Hoppers/bsbRack_empty.wom
model.container.rack.bsb.unfinished            = structures/Hoppers/bsbRack_unf.wom

 

model.container.bulk.unit                = structures/Hoppers/bsbUnit.wom
model.container.bulk.unit.empty                = structures/Hoppers/bsbUnit_empty.wom
model.container.bulk.unit.unfinished            = structures/Hoppers/bsbUnit_unf.wom

 

 

and replace with

 

model.container.rack.bsb.full                = graphics/structures/Hoppers/bsbRack_full.wom
model.container.rack.bsb.empty                = graphics/structures/Hoppers/bsbRack_empty.wom
model.container.rack.bsb.unfinished            = graphics/structures/Hoppers/bsbRack_unf.wom

 

model.container.bulk.unit                = graphics/structures/Hoppers/bsbUnit.wom
model.container.bulk.unit.empty                = graphics/structures/Hoppers/bsbUnit_empty.wom
model.container.bulk.unit.unfinished            = graphics/structures/Hoppers/bsbUnit_unf.wom

 

Once done, you save, and replace the mappings.txt in the graphics.jar with the new one *in the main directory, not in /graphics that mappings.txt does nothing.

---------------------------------------------

Easy mode!!!!!!! 

Download 

https://ufile.io/6luwh

 

Go to your WU folder, packs folder, open graphics.jar with WinRar/7zip.  For caution's sake, extract mappings.txt from the main directory in there.  Back it up somewhere.

 

Then drag that mappings.txt file you downloaded into that main directory of the graphics.jar.

 

Bonus:  

That linked file includes the fix referenced in this thread:

 

 

NOTE: IF YOU'VE ADDED ANY GRAPHICS' MODS TO YOUR CLIENT THIS MAY VERY WELL WRECK IT, IN WHICH CASE I RECOMMEND USING "HARD" MODE DESCRIBED ABOVE.  I ain't added graphic mods to my client so not sure how it goes but why risk it eh.

Edited by Mordraug
Thanks for making me doublecheck, Budda
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Mordraug said:

...

model.container.rack.crate.empty        = graphics/models/Crates/crateRack_empty.wom

 

and replace with

 

model.container.rack.crate.empty.birchwood        = graphics/models/Crates/crateRack_empty.wom
model.container.rack.crate.empty.cedarwood        = graphics/models/Crates/crateRack_empty.wom
model.container.rack.crate.empty.firwood        = graphics/models/Crates/crateRack_empty.wom
model.container.rack.crate.empty.pinewood        = graphics/models/Crates/crateRack_empty.wom

...

 

The way the mappings work is if there is no mapping for the given model (or whatever else), it drops the last section of the mapping (so in this case the wood type), and checks again. Your additions shouldn't be necessary, as when it looks for "model.container.rack.crate.empty.birchwood" and finds nothing, it will drop back to "model.container.rack.crate.empty" and use that model.

 

Just so I understand correct, without your changes what do the racks in game show as?

Share this post


Link to post
Share on other sites
46 minutes ago, Budda said:

 

The way the mappings work is if there is no mapping for the given model (or whatever else), it drops the last section of the mapping (so in this case the wood type), and checks again. Your additions shouldn't be necessary, as when it looks for "model.container.rack.crate.empty.birchwood" and finds nothing, it will drop back to "model.container.rack.crate.empty" and use that model.

 

Just so I understand correct, without your changes what do the racks in game show as?

 

Aaaaah I got mixed up.  mappings.txt in /graphics does nothing, musta gotten mixed up while testing.  Gonna restore it to "factory version", more details in a moment.

 

There we go, edited the post above thanks for that pointer.

 

Seeing a loooot of repeated files and folders in that graphics.jar inside the /graphics folder, but they're inconsistent, the main directory and what's inside that folder.  I'd recommend that the art folks do some cleaning up of that file to remove duplicates and consolidate the mappings.txt.   The two versions in the .jar are also somewhat inconsistent. (Or is that a beta branch thing?  Hadn't really delved until now).

Edited by Mordraug

Share this post


Link to post
Share on other sites
3 hours ago, Budda said:

Just so I understand correct, without your changes what do the racks in game show as?

 

As a pottery jar.

 

9lE4pGS.png

 

I think you got something messed up in the build process for graphics.jar

 

The jar has it's old (1.4) content at the root, then another copy of EVERYTHING + new 1.5 stuff in a "graphics" subfolder inside the jar

Edited by bdew
  • Like 2

Share this post


Link to post
Share on other sites

with the new rendering engine are we going to be seeing example wooden bins that show their actual timber color or are they going to stay the same color of bland?? ie same colors.

Share this post


Link to post
Share on other sites
4 hours ago, ozmods said:

with the new rendering engine are we going to be seeing example wooden bins that show their actual timber color or are they going to stay the same color of bland?? ie same colors.

Short term, same colour regardless of wood type

Long term, plans are to reintroduce wood type shaders 

  • Like 3

Share this post


Link to post
Share on other sites
15 hours ago, bdew said:

 

As a pottery jar.

 

9lE4pGS.png

 

I think you got something messed up in the build process for graphics.jar

 

The jar has it's old (1.4) content at the root, then another copy of EVERYTHING + new 1.5 stuff in a "graphics" subfolder inside the jar

 

And how... 1.4 download = 594mega.... 1.5 is 1.3gig

Share this post


Link to post
Share on other sites
12 hours ago, Retrograde said:

Short term, same colour regardless of wood type

Long term, plans are to reintroduce wood type shaders 

thanks mate for that. i'm loving new update, I haven't played wurm in a while because I thought you guys had given up on us LOL. but glad to see you haven't. have to say though the whole shadow thing is taking a little getting used to, when you turn it on in settings it really changes everything about the game, just one question though what is it, with all those butterflies lol, they're everywhere

Share this post


Link to post
Share on other sites
20 hours ago, Retrograde said:

Short term, same colour regardless of wood type

Long term, plans are to reintroduce wood type shaders 

One emote to describe my reaction to this.

 

\o/ or maybe one word w00t

Share this post


Link to post
Share on other sites

Not sure if its 1.5 or a mod but myself and at least one of my players has noticed a bug where occasionally you lose the ability to Take/Move items, and switching your active item to anything else seems to clear the issue.  I've never had that occur until I switched us to 1.5

Share this post


Link to post
Share on other sites

I am wondering how the Archeology skill will work for new servers that do not have any old abandoned deeds.

 

Will there be any special items that can be found on them then?

 

I would assume that the pieces that make up the statues would be available, but not certain how other things would be implemented.

Share this post


Link to post
Share on other sites

Archeology is not in 1.5. They just released as coming to WO so we have months for that update.

Share this post


Link to post
Share on other sites

It is late and I must be too sleepy to find it, but where do you get the 1.5 Beta (server and client)? Any trick to upgrading an existing server to the Beta code?

Share this post


Link to post
Share on other sites

Swap steam branch from opt out to beta branch

 

The beta build has been updated to 1.5.0.1 to include the fixes to graphics and the highway systm

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Jerone0601, I did not think of that part.

 

so I asked over on the main thread for the Archelogy patch to see if they have any ideas on it.

Share this post


Link to post
Share on other sites
2 hours ago, Retrograde said:

Swap steam branch from opt out to beta branch

 

The beta build has been updated to 1.5.0.1 to include the fixes to graphics and the highway systm

Thank you! Made it to the client update and local server, but can't figure out how to get the dedicated server to update to 1.5. It must be something silly I'm overlooking. Appreciate the help. 

Share this post


Link to post
Share on other sites
3 hours ago, Retrograde said:

Swap steam branch from opt out to beta branch

 

The beta build has been updated to 1.5.0.1 to include the fixes to graphics and the highway systm

@Retrograde- Is the live release still scheduled for today then, or is this new patch going to postpone that for further testing?

I ask because Mondays is our normal weekly maintenance day, and wondering how to handle downtime today.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Wurmhole said:

Thank you! Made it to the client update and local server, but can't figure out how to get the dedicated server to update to 1.5. It must be something silly I'm overlooking. Appreciate the help. 

Right click on the game in steam and choose properties. Go to beta tab and opt in. Or follow this video

https://steamcommunity.com/sharedfiles/filedetails/?id=380122528

 

Edited by Governor

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this