Eject

Server Lags

35 posts in this topic

Hello friends

 

Do you know which part of wurm make these lags? What can i do against it:ing it to the lag count, which is now: 216

Spoiler

01:22:21 PM] INFO com.wurmonline.server.Server: Lag detected at Zones.pollnextzones (0.5): 1.644 seconds
[01:22:21 PM] INFO com.wurmonline.server.Server: Elapsed time (1645ms) for this loop was more than 1 second so adding it to the lag count, which is now: 100
[01:23:22 PM] INFO com.wurmonline.server.Server: Lag detected at Zones.pollnextzones (0.5): 18.579 seconds
[01:23:22 PM] INFO com.wurmonline.server.Server: Elapsed time (18583ms) for this loop was more than 1 second so adding it to the lag count, which is now: 118
[01:23:41 PM] INFO com.wurmonline.server.Server: Lag detected at Zones.pollnextzones (0.5): 19.502 seconds
[01:23:41 PM] INFO com.wurmonline.server.Server: Elapsed time (19503ms) for this loop was more than 1 second so adding it to the lag count, which is now: 137
[01:24:02 PM] INFO com.wurmonline.server.Server: Lag detected at Zones.pollnextzones (0.5): 20.566 seconds
[01:24:02 PM] INFO com.wurmonline.server.Server: Elapsed time (20566ms) for this loop was more than 1 second so adding it to the lag count, which is now: 157
[01:24:02 PM] INFO com.wurmonline.server.steam.SteamHandler: Client was  NOT Authenticated
[01:24:21 PM] INFO com.wurmonline.server.Server: Lag detected at Zones.pollnextzones (0.5): 19.552 seconds
[01:24:21 PM] INFO com.wurmonline.communication.SocketServer: Accepted player connection: Socket[addr=/83.11.171.140,port=61360,localport=15000]
[01:24:21 PM] INFO com.wurmonline.server.creatures.Communicator: Subcommand for reallyHandle_CMD_REQUEST_SELECT=3
[01:24:21 PM] INFO com.wurmonline.server.players.Player: Darknos lost link 60 secstologout.
[01:24:21 PM] INFO com.wurmonline.server.Server: Elapsed time (19559ms) for this loop was more than 1 second so adding it to the lag count, which is now: 176
[01:24:41 PM] INFO com.wurmonline.server.Server: Lag detected at Zones.pollnextzones (0.5): 19.997 seconds
[01:24:42 PM] INFO com.wurmonline.server.Server: Elapsed time (20071ms) for this loop was more than 1 second so adding it to the lag count, which is now: 196
[01:24:42 PM] INFO com.wurmonline.server.steam.SteamHandler: Client was Authenticated
[01:25:02 PM] INFO com.wurmonline.server.Server: Lag detected at Zones.pollnextzones (0.5): 20.38 seconds
[01:25:02 PM] INFO com.wurmonline.server.Server: Elapsed time (20380ms) for this loop was more than 1 second so add

 

Share this post


Link to post
Share on other sites

sorry, the remove format was not available at this time

Share this post


Link to post
Share on other sites

Lag detected at Zones.pollnextzones (0.5): 20.566 seconds

 

This lag usually happens if you put like 1k items into one single fire place. Normally there are coordinates included mentioning the zone the problem is in.

1 person likes this

Share this post


Link to post
Share on other sites

Don't see it too often, but I've honestly never seen anything in our logs about a location or Zone ID, etc. Any thoughts?

Edited by LifesaverM
spelling

Share this post


Link to post
Share on other sites

Now i had the same problem again, no user was draging 100s or 1000 items atm, i dont know how i can find the reason :(

Share this post


Link to post
Share on other sites

Most likely a zone that has 1000's of items on the floor, Tilepoller has  to calculate decay for everyone.

As for locating the offending zone. Ill look though Ages of Urath file/logs to see if there was a mod the help out....

Edited by bigsteve
1 person likes this

Share this post


Link to post
Share on other sites

Thank you very much Steve :)

Share this post


Link to post
Share on other sites

Sorry i looked in the mods folder and could not see a mod that helped with logging.

Not saying the isnt, but the servers developer could of bunbled it with other mods he wrote.

 

 

 

 

Share this post


Link to post
Share on other sites

I had some major lag on my server aswell. Was not able to resolve it. Running off ram-drive solved the issue.

Share this post


Link to post
Share on other sites

OOOHHHHh

I just remembered, Did CodeClub fix the Fog spider Spawning issue?????

that could be the cause if it was not fixed!!!

Edited by bigsteve

Share this post


Link to post
Share on other sites

Fog spiders will still create server lag issues in 1.4. Polling is handled mostly by a login server, clustering a login server reduced polling lag a lot for me. My login server is used just for character creation with a portal to the other servers.

Share this post


Link to post
Share on other sites

i believe i had a mod that solved the fogspider issue, but i dont know if it still works at this version. Next is 1.4.0.1 was released in july but the problems are very young.

 

Eject

Share this post


Link to post
Share on other sites

The fog spiders rarely cause us lag but do sometimes bloat the memory usage on rare occasion. However, its not the bulk of the issue.

I'm not running on SSD drives not practical or cost effective for our situation (however they are a good choice if you are renting a server instance for sure) but they are very high end server drives. I've monitored a number of drive metrics when this happens and its not the drives causing the problem for us at least. (This is an area of enterprise server administration I'm an expert at).

 

There really needs to be a better way to pin the issue down. For us we hardly ever saw this issue until a month ago but we have seen a major influx of players so naturally there is more stuff everywhere. We police public areas but I can't run around to everyone's deed and investigate.

 

I have thought about going with a login server once we added another map but we aren't quite at the threshold of needing a 2nd map yet so I hesitate to go that route just yet. The lag when it happens last less than a minute so its not that bad in reality but it's happening way more often then it used to. So naturally I'm concerned if I can't research it further it will become a major problem at some point.

Share this post


Link to post
Share on other sites
On 30.9.2017 at 9:54 AM, Eject said:

i believe i had a mod that solved the fogspider issue, but i dont know if it still works at this version. Next is 1.4.0.1 was released in july but the problems are very young.

 

Eject

 

Do you have any NPCs which can be abused to spam items? Like a beginner axe, sword or something like that?

Share this post


Link to post
Share on other sites

yes Sklo:D i have a trainingscamp with 6 npc they ould give new players a weapon for testing, and there are also 4 npc they spawn a choosen creature.

but this camp isnt used often.

 

Eject

Share this post


Link to post
Share on other sites
8 minutes ago, Eject said:

yes Sklo:D i have a trainingscamp with 6 npc they ould give new players a weapon for testing, and there are also 4 npc they spawn a choosen creature.

but this camp isnt used often.

 

Eject

 

This is most likely highly abuseable. Someone could create a few thousand items in a few minutes, this could cause lag spikes in zone pollers.

1 person likes this

Share this post


Link to post
Share on other sites
19 hours ago, Sklo:D said:

 

Do you have any NPCs which can be abused to spam items? Like a beginner axe, sword or something like that?

 

In our case we do not.

Share this post


Link to post
Share on other sites

Any other suggestions?

Share this post


Link to post
Share on other sites

Yesterday we had again a 2 minute lag, with the same text in the logilfe. this problem was not npc related because i was standing at the place where the nps´s are and there was no other player in the near.

 

Eject

Edited by Eject

Share this post


Link to post
Share on other sites

I had a mega lag the other day, but I found that the problem was I had too many fallen trees laying around, when I packed em up, and moved them to storage, the lag stopped, could it be that you have too many people standing around or objects or something, just a thought.

Share this post


Link to post
Share on other sites

We have around 40 players but they are splitte on 3 maps, i added now more ram and will wait what happens.

 

Eject

Share this post


Link to post
Share on other sites

I doubt more ram will help.

Ages of Urath had 2 maps and peek times 50, average 30.

When the 3rd map was add, lag spike incredibly  so much the 3rd map was retired.

I think you are suffering from thread thrashing.

Sadly i do not have access to Ages of Urath log in server file any more, the copy of it i downloaded only the 2nd Laoks map folder survived. So i can advise  on how the .ini was set-up.

Share this post


Link to post
Share on other sites

Check your database if there are some incredible amounts of items somewhere on the world.

 

Also consider to move your login server to a small world nobody plays on as we did on Sklotopolis, lag is a lot better since the move.

Share this post


Link to post
Share on other sites

Indeed its a must, for multimap clusters with a high population.

Am am sure that if Razor had know that having the login server with players using it was the  caused of all the lag,

and had a dedicated login server Ages of Urath could of lasted alot longer.

Share this post


Link to post
Share on other sites

At the moment, the most players are at the loginserver (round 50% of all online players), because we got a lot new players and the loginserver is the easiest for new players.

But yeah, since yesterday i got no reply that there was a lag, maybe the little bit mor ram helps.

 

Eject

 

@steve, i remember there was a setting in the wurm.ini where you can give more ram to the server, i believe 2048 is the standard, at one neighbour server i have changed this to 4096MB....complete ram here is 6GB

Edited by Eject

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now