Sign in to follow this  
Followers 0
dalamarkanan

Wurm Client doesn't load

15 posts in this topic

I'm a new player, but the client never loads i do the following:
- run wurmclient.jnlp as downloaded from the website
- app downloads (java window)
- a small splash appears with the logo
- a small gray spalsh screen appear and stay there forever.
- the app becomes unresponsive: "Wurm Online [Stable] (not responding)"

I've tried already to downgrade the java vm to 131, install, uninstall, reboot, etc ... any other idea ? I've tried to start it with the java console open ... the console hangs too :(


Video:
https://drive.google.com/open?id=0B6NoyiUf2Gz7SUFCc1dCa0lEdzg


Java Console
GKvl2vH.png


 

Edited by dalamarkanan
typo, added video

Share this post


Link to post
Share on other sites

I found this post which seems similar

specifically this is what worked

Quote

I went to the 'General' tab and into the network settings and changed it to direct connection rather than browser settings. I remembered Chrome doesn't support java so maybe that's why, I'm not sure though.

 

Share this post


Link to post
Share on other sites

Hello.  Apologies for jumping in here, but I too have the exact same issue.  I haven't played in months. I deleted WO a while ago, then kinda missed it.  I finally decided to get back in and nothing appears to work now.  I've tried the same things as Dalamarkanan above with no luck.

 

I've tried several other potential fixes mentioned throughout this forum but to no avail.

 

MBP 2011, OS X Sierra 10.12.6

Java 8 Update 144

 

Thanks for any advice you guys can give!

 

Edit: Just noticed this... Curiously, the game still launches and works (rather poorly) on my 2007 iMac, also with java 8u144. The logo has changed from the WO logo to the generic applications icon with "Stable" added to the name. 

 

Edited by FJC

Share this post


Link to post
Share on other sites

The same issue. 

MacBook Pro (15-inch, 2017)

OS X Sierra 10.12.6

Java 8 Update 144

Share this post


Link to post
Share on other sites

I am also having this issue.  Has anyone found a solution?

 

MacBook Pro (15-inch 2017)

OS X Sierra 10.12

Java 8 Update 151

Share this post


Link to post
Share on other sites

Same here.  I am having the same issue.  I tried to uninstall, re-install, used 2 versions of java, reset security,... Nothing, same white rectangular box appear every time I try to run Wurm..  Any suggestion?

 

Share this post


Link to post
Share on other sites

Gerlion:  Any luck on the issue? I have been trying to solve the problem with different methods, with no avail?  :-(

Share this post


Link to post
Share on other sites

Rhinox, I have also tried many different methods.  So far no love from the client.  

Share this post


Link to post
Share on other sites

Anyone got any solution yet? Pls offer some suggestions to make it run....

Share this post


Link to post
Share on other sites

I have also tried the Low Memory version but failed to launch again.  Here is the report:

 

<?xml version="1.0" encoding="utf-8"?>
<jnlp
        spec="1.0+"
        codebase="http://www.wurmonline.com/client/"
        href="wurmclient_lowmem.jnlp">
    <information>
                    <title>Wurm Online [Stable (Low Memory)]</title>
                <vendor>CodeClub AB</vendor>
        <homepage href="http://www.wurmonline.com" />
        <description>Wurm Online Client</description>
        <icon href="wurm_icon_128.png" width="128" height="128" />
        <icon href="wurm_icon_64.png" width="64" height="64" />
        <icon href="wurm_icon_32.png" width="32" height="32" />
        <icon href="wurm_icon_16.png" width="16" height="16" />
        <icon kind="splash" href="splash.gif" />
        <shortcut online="true">
            <desktop />
            <menu submenu="Wurm Online" />
        </shortcut>
    </information>
    <update check="timeout" policy="always" />
    <security>
        <all-permissions />
    </security>
    <resources>
        <j2se
                href="http://java.sun.com/products/autodl/j2se"
                version="1.8+"
                            java-vm-args="-XX:+UseG1GC -XX:MaxGCPauseMillis=8 -XX:+UseStringDeduplication"
                                        initial-heap-size="512m"
                                        max-heap-size="1024m"
                    />
        <property name="sun.java2d.noddraw" value="true" />
        <property name="org.lwjgl.input.Mouse.allowNegativeMouseCoords" value="true" />
            
    <property name="jnlp.versionEnabled" value="true" />
    <jar href="libraries-stable_lowmem/WurmClient-small.jar" version="4.0.12" main="true"/>
    <jar href="libraries-stable_lowmem/httpclient.jar" version="4.5.3"/>
    <jar href="libraries-stable_lowmem/httpcore.jar" version="4.4.6"/>
    <jar href="libraries-stable_lowmem/commons-logging.jar" version="1.2"/>
    <jar href="libraries-stable_lowmem/commons-codec.jar" version="1.9"/>
    <jar href="libraries-stable_lowmem/pngdecoder.jar" version="1.0"/>
    <jar href="libraries-stable_lowmem/irclib.jar" version="1.10"/>
    <jar href="libraries-stable_lowmem/lwjgl_util.jar" version="2.9.1"/>
    <jar href="libraries-stable_lowmem/lwjgl.jar" version="2.9.1"/>
    <jar href="libraries-stable_lowmem/jinput.jar" version="2.0.5"/>
    <jar href="libraries-stable_lowmem/jutils.jar" version="1.0.0"/>
    <jar href="libraries-stable_lowmem/jorbis.jar" version="0.0.17"/>
    <jar href="libraries-stable_lowmem/vecmath.jar" version="1.5.2"/>
    <jar href="libraries-stable_lowmem/jbullet.jar" version="1.0.0"/>
    <jar href="libraries-stable_lowmem/JZipUpdate.jar" version="0.9.1"/>
    <jar href="libraries-stable_lowmem/joxsi.jar" version="1.0.0"/>
    <jar href="libraries-stable_lowmem/jme-collada-binding.jar" version="1.0.0"/>
    <jar href="libraries-stable_lowmem/jsquish.jar" version="2.0.0"/>
    <jar href="libraries-stable_lowmem/slick-util.jar" version="b208"/>
    <jar href="libraries-stable_lowmem/jogg.jar" version="0.0.7"/>

    </resources>
    <resources os="Win" arch="x86"><!-- Windows 32-bit java -->
        <nativelib href="libraries-stable_lowmem/lwjgl-platform-natives-windows.jar" version="2.9.1"/>
        <nativelib href="libraries-stable_lowmem/jinput-platform-natives-windows.jar" version="2.0.5"/>
    </resources>
    <resources os="Win" arch="amd64"><!-- Windows 64-bit java -->
        <nativelib href="libraries-stable_lowmem/lwjgl-platform-natives-windows.jar" version="2.9.1"/>
        <nativelib href="libraries-stable_lowmem/jinput-platform-natives-windows.jar" version="2.0.5"/>
    </resources>
    <resources os="Mac" arch="ppc"><!-- PowerPC Mac -->
        <nativelib href="libraries-stable_lowmem/lwjgl-platform-natives-osx.jar" version="2.9.1"/>
        <nativelib href="libraries-stable_lowmem/jinput-platform-natives-osx.jar" version="2.0.5"/>
    </resources>
    <resources os="Mac" arch="i386"><!-- Intel Mac 32-bit java -->
        <nativelib href="libraries-stable_lowmem/lwjgl-platform-natives-osx.jar" version="2.9.1"/>
        <nativelib href="libraries-stable_lowmem/jinput-platform-natives-osx.jar" version="2.0.5"/>
    </resources>
    <resources os="Mac" arch="x86_64"><!-- Intel Mac 64-bit java -->
        <nativelib href="libraries-stable_lowmem/lwjgl-platform-natives-osx.jar" version="2.9.1"/>
        <nativelib href="libraries-stable_lowmem/jinput-platform-natives-osx.jar" version="2.0.5"/>
    </resources>
    <resources os="Linux" arch="i386"><!-- Linux 32-bit Sun java -->
        <nativelib href="libraries-stable_lowmem/lwjgl-platform-natives-linux.jar" version="2.9.1"/>
        <nativelib href="libraries-stable_lowmem/jinput-platform-natives-linux.jar" version="2.0.5"/>
    </resources>
    <resources os="Linux" arch="x86"><!-- UNKNOWN -->
        <nativelib href="libraries-stable_lowmem/lwjgl-platform-natives-linux.jar" version="2.9.1"/>
        <nativelib href="libraries-stable_lowmem/jinput-platform-natives-linux.jar" version="2.0.5"/>
    </resources>
    <resources os="Linux" arch="amd64"><!-- Linux 64-bit Sun java -->
        <nativelib href="libraries-stable_lowmem/lwjgl-platform-natives-linux.jar" version="2.9.1"/>
        <nativelib href="libraries-stable_lowmem/jinput-platform-natives-linux.jar" version="2.0.5"/>
    </resources>
    <resources os="Linux" arch="x86_64"><!-- UNKNOWN -->
        <nativelib href="libraries-stable_lowmem/lwjgl-platform-natives-linux.jar" version="2.9.1"/>
        <nativelib href="libraries-stable_lowmem/jinput-platform-natives-linux.jar" version="2.0.5"/>
    </resources>
    <application-desc main-class="com.wurmonline.client.launcherfx.WurmMain"  name="Wurm Online" />
</jnlp>

Share this post


Link to post
Share on other sites

trying to run from terminal with additional info shows that there is exception:

 

$ javaws ./wurmclient.jnlp -verbose

Exception in thread "main" java.lang.NoClassDefFoundError: Could not initialize class java.lang.ProcessEnvironment

at java.lang.System.getenv(System.java:897)

at java.awt.GraphicsEnvironment.lambda$getHeadlessProperty$0(GraphicsEnvironment.java:178)

at java.security.AccessController.doPrivileged(Native Method)

at java.awt.GraphicsEnvironment.getHeadlessProperty(GraphicsEnvironment.java:164)

at java.awt.GraphicsEnvironment.isHeadless(GraphicsEnvironment.java:141)

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)

at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1824)

at java.lang.Runtime.load0(Runtime.java:809)

at java.lang.System.load(System.java:1086)

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)

at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1845)

at java.lang.Runtime.loadLibrary0(Runtime.java:870)

at java.lang.System.loadLibrary(System.java:1122)

at java.awt.Toolkit$3.run(Toolkit.java:1636)

at java.awt.Toolkit$3.run(Toolkit.java:1634)

at java.security.AccessController.doPrivileged(Native Method)

at java.awt.Toolkit.loadLibraries(Toolkit.java:1633)

at java.awt.Toolkit.<clinit>(Toolkit.java:1668)

at com.sun.javaws.ui.SplashScreen.hide(Unknown Source)

at com.sun.javaws.ui.LaunchErrorDialog.show(Unknown Source)

at com.sun.javaws.Main.main(Unknown Source)

 

Share this post


Link to post
Share on other sites

II'm having the same issue on my Macbook Pro, running OS 10.13.1. Up to date Java. I open the client, the little splash rectangle shows, then it goes away and the app is nonresponsive. I got the same error message in Java console — that bit about "allowNegativeMouseCoordinates." Tried unplugging my USB mouse and restarting but no luck. Low mem client doesn't help at all. Gonna mess around with mouse stuff maybe, see if there's some weird Mac mouse thing going on. 

Share this post


Link to post
Share on other sites

For Mac Pro users having troubling in running the Wurm application with up to date Java, where the app is non responsive, I think the developer will not look into the comments here.  Just a waste of time.

 

My recommendation is to go to the Wurm Online Official facebook account and complain over there.  I even asked that if someone paid and suffered these issues, can he/she get refund. I tried and at least someone responded to me over the facebook chat messenger and said they will ask the technician to look into it.   This is their response:

10006293_798149270204143_675149765404738
"Awesome! I will get in contact with our dev team about the issue, see what they can find and will let you know"
 

 Unfortunately, I did this 1 week ago and there is no response yet.

 

Good luck everyone.

1 person likes this

Share this post


Link to post
Share on other sites

Client crashes for me several seconds after launching it on macOS High Sierra with the following error message:

 

java.lang.ClassNotFoundException: org.lwjgl.openal.OpenALException
    at jdk.deploy@9.0.1/com.sun.deploy.security.DeployURLClassLoader.findClass(Unknown Source)
    at jdk.javaws@9.0.1/com.sun.jnlp.JNLPClassLoader.findClass(Unknown Source)
    at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
    at jdk.javaws@9.0.1/com.sun.jnlp.JNLPClassLoader.loadClass(Unknown Source)
    at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
    at com.wurmonline.client.launcherfx.WurmMain.start(SourceFile:205)
    at javafx.graphics/com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$9(Unknown Source)
    at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runAndWait$11(Unknown Source)
    at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$9(Unknown Source)
    at java.base/java.security.AccessController.doPrivileged(Native Method)
    at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$10(Unknown Source)
    at javafx.graphics/com.sun.glass.ui.InvokeLaterDispatcher$Future.run(Unknown Source)
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0