Sign in to follow this  
dalamarkanan

[Fixed] Wurm Client doesn't load

Recommended Posts

If you are missing the main game files, there used to be a way to manually download the files (or at least the sound/graphics/etc packs at least, which were the ones people used to have problems with ) from Wurmpedia to a folder on your hard drive,not sure that would make any difference but maybe worth a try,also maybe in gamesettings.txt there is a way to disable experimental and PMK files which gave a lot of people issues and prevented them from running the game

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

I'm having the same problems on my Mac, the client itself won't load. I tried everything from reinstalling, to different versions, to even tinkering with the security settings. Only thing left is to throw the Mac out the window.

Share this post


Link to post
Share on other sites

I'm having the same problems on my Mac, the client itself won't load.The window will not open

Share this post


Link to post
Share on other sites

I'm not sure how it works on a Mac, but on PC when I've had similar issues the fix for experimental files worked. Also there's an issue I've had before where I had unsigned certificates. There's a fix around for that as well forcing them to download again to be signed. That's a Java issue and often it's Java and not the game itself preventing you from playing. 

 

Share this post


Link to post
Share on other sites

An error occurred after the program was started,I'm using the Macos system

 

java.lang.ClassNotFoundException: org.lwjgl.openal.OpenALException
    at jdk.deploy@9.0.1/com.sun.deploy.security.DeployURLClassLoader.findClass(Unknown Source)
    at jdk.javaws@9.0.1/com.sun.jnlp.JNLPClassLoader.findClass(Unknown Source)
    at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
    at jdk.javaws@9.0.1/com.sun.jnlp.JNLPClassLoader.loadClass(Unknown Source)
    at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
    at com.wurmonline.client.launcherfx.WurmMain.start(SourceFile:205)
    at javafx.graphics/com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$9(Unknown Source)
    at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runAndWait$11(Unknown Source)
    at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$9(Unknown Source)
    at java.base/java.security.AccessController.doPrivileged(Native Method)
    at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$10(Unknown Source)
    at javafx.graphics/com.sun.glass.ui.InvokeLaterDispatcher$Future.run(Unknown Source)

 

Share this post


Link to post
Share on other sites

@diaorui- looks as if you are using Java 9, there is a note elsewhere that Wurm Online does not support Java 9. The Mac download for Java 8 is on the page that Samool links (or see https://java.com/en/download/manual.jsp for the english version).

 

I think the "Insecure property: (org.lwjgl.input.Mouse.allowNegativeMouseCoords, true) specified in unsigned jnlp file will not be set." line is very probably not the problem, I also see that message and wurm runs (27" Late 2103 iMac).

 

Trying to think of any settings that I might have changed in the past... The only thing I can currently think of is...

 

In 'Java Control Panel' - Security tab - I have "Enable Java content for browser and Web Start applications" ticked, and security level set to Very High. I also appear to have added the Code Club AB certificate to the trusted certificates, think that is just from telling the system to remember that it is trusted rather than prompt each time I run Wurm.

 

 

 

Share this post


Link to post
Share on other sites

We're aware of these issues, and have been working on them, but it's a hard one to narrow down. 

 

One issue we've been facing is replicating it, so if you're experiencing these issues, and you are fairly knowledgeable of your system, please contact me and we'll try to organise some one on one time to see if we can address the issue.

 

 

Share this post


Link to post
Share on other sites
7 hours ago, Retrograde said:

so if you're experiencing these issues, and you are fairly knowledgeable of your system, please contact me and we'll try to organise some one on one time to see if we can address the issue.

 

 

I am not an IT-person but glad to help if my system is of any value for narrowing the issue down

Share this post


Link to post
Share on other sites

Just to add unhelpful 2 cents here.  I’m unable to play Wurm for 11 days while I’m on work travel because my new work laptop is a brand new MacBook Air and Wurm won’t load.  Like everyone else, it stops running when I get to the little Wurm Online box before the login screen.

Share this post


Link to post
Share on other sites

Does everyone who is having issues running Wurm has High Sierra OS?

Since High Sierra release Macs have different file system, maybe that is the issue?

Share this post


Link to post
Share on other sites
10 hours ago, Karidwen said:

Since High Sierra release Macs have different file system, maybe that is the issue?

That is probably not the issue - I have High Sierra on a iMac and am not having the issue reported in this thread.

 

I think it is more likely to be connected with the GPU - a quick glance through would suggest that those with problems have Intel GPUs. See https://support.apple.com/en-gb/HT202823 which has Mac model and GPU listed on a single page...

Edited by Wulfmaer

Share this post


Link to post
Share on other sites
10 hours ago, Wulfmaer said:

That is probably not the issue - I have High Sierra on a iMac and am not having the issue reported in this thread.

 

I think it is more likely to be connected with the GPU - a quick glance through would suggest that those with problems have Intel GPUs. See https://support.apple.com/en-gb/HT202823 which has Mac model and GPU listed on a single page...

 

Confirmed for me... Intel-Chipset on the GPU and not able to run the client. Maybe that brings the devs into the right direction...

Share this post


Link to post
Share on other sites

In the past, one change that allowed PC/Windows people with certain intel graphics  to run, was disabling  GLSL and changing screen resolution to windows resizeable 800x600 (you can expand to fill the screen after it loads.)  Other people with intel graphics ran just fine,, I am not sure whether it was a driver issue or a chipset model issue..  In the cases where that worked, PC users were able to make those two changes directly  in the launcher, but the affected Mac users cannot access the launcher, that might be related to the new client. Maybe there is something that can be edited in the gamesettings.txt file. I don't know the file location on Macs, but on PCs it is found at \Wurm\configs\default. 

 

The lines to change are:

 

glsl_enabled=0     

display_settings=false\:false\:0\:800\:600\:32\:-1\:false\:true

 

This disables fancy GLSL shaders that intel grapohics support poorly, and resets the resolution to resizeable 800x600 which you then manually extend to fill the screen once ingame. 

Use a plain text editor (in windows notepad.exe, apparently in a mac you use TextEdit BUT you need to go to menu > FORMAT > Plain Text  then search for the words GLSL or DISPLAY until you find the right line to edit.  SAVE file when done, as PLAIN TEXT

Probably best to make a copy backup of the file before changing anything.  Disabling GLSL might cause other ingame issues (shifting terrain/stretched NPC models) but non-fatal issues

 

Odds of it helping -- maybe 10%  

 

 

_________

 

 

It could also be an issue with JAVA as macs in the past have had their OS disable JAVA. Or maybe it forced it to Java 9.  I dunno much about Macs sorry :/

This is supposedly how to confirm which version of JAVA is runnong on a Mac (NOTE: WURM DOES NOT SUPPORT JAVA 9 - You might want auto-updates disabled. ) 

 

Which version is installed?

If you have a modern Oracle version of Java, you can tell from the command line by typing
java -version
in Terminal. Currently, this should produce a response such as
java version "9.0.1"
Java(TM) SE Runtime Environment (build 9.0.1+11)
Java HotSpot(TM) 64-Bit Server VM (build 9.0.1+11, mixed mode)

If you merely get an error, indicating that the command was not found, this implies that you don’t have any version of Java installed.

 

 

 

According to the first post in this thread, this should not be the issue as their error logs showed they had the correct JAVA version. 

 

 

 

 

 

I am not optimistic any of this will help, just something to try. 

 

 

 

 

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

You could probably play trough virtual-machine and random linux installed on it.... virtualbox's free, I'm almost sure that there might have been some free 'player' for vmware virtual pcs(trial maybe to get a vm going), in other words maybe it's possible to play on virtual pc(because of the video emulation) while devs figure the issue. 

Wont be a pretty solution, but it's some solution for the impatient.

 

Crazy idea, but could help some ????

Share this post


Link to post
Share on other sites

Just wondering if the devs have any update yet? 

It has been four weeks by now that I was not able to play Wurm which is quite an issue for me as my deeds coffers are continuously reduced without me being able to play... luckily I did not have any prem time running anymore when the issue started to occure...

Share this post


Link to post
Share on other sites
On 1/5/2018 at 7:36 PM, Brash_Endeavors said:

I am not familiar with Macs, hopefully this could work similar. On Windows, you can disable sound without launching the game,by opening with a plain text editor  the file named gamesettings.txt  located in  \Wurm\configs\default

Uh... I sort of DELETED my Wurm directory in an attempt to get Wurm to work...

Share this post


Link to post
Share on other sites

For Mac users having trouble with Wurm, try to put pressure to Wurm by sending them messages from the FB Messenger.  I have done that for 4 months, and although the problem has not been solved, at least they responded.   

 

I have tried 3 Mac for the past 7 months (Mac Air, MacBook Pro and iMac) with High Sierra OS, unfortunately no response from the Application and I need to Force Quitted the Application.  I have tried numerous methods, using low memory client, upgrading Java, downgrading Java, Wifi connections, 4G connection, VPN connection,..

 

Btw, I can play with PC.  I have a PC at home and office, both works perfectly.

 

I think the developer need to solve this for Mac users.

Share this post


Link to post
Share on other sites
On 3.2.2018 at 4:06 PM, Rhinox said:

For Mac users having trouble with Wurm, try to put pressure to Wurm by sending them messages from the FB Messenger.  I have done that for 4 months, and although the problem has not been solved, at least they responded.   

 

To me, they responded within 24 hours but unfortunately still no solution... not sure if the qty of players having this issue is too low but still very inconvenient as the deed is still there, losing money each day which is lost as I cannot do anything with that time...

I hope there will be some sort of refund or similar...

Share this post


Link to post
Share on other sites

From Facebook in regards to Valrei International 52:

Quote

Wurm Online Official This update is likely to include a fix to that, we've identified a potential issue that we'll be adjusting with the launch of the preview client. We'll be reaching out to some affected by this to see if it does address it

 

  • Like 1

Share this post


Link to post
Share on other sites

Tried again today: Downloaded the latest Java. Deleted the Old version, Reinstalled the Java.  Downloaded the wurm client.jnlp, and executed it again.  DID NOT WORK!  Very frustrating.  Error Message: Application Not Responding.

 

Share this post


Link to post
Share on other sites

Same for me... no positive result after the latest update...

Share this post


Link to post
Share on other sites

Any update? I have the same issue on my MacBook Pro 13"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this