Locath

Meal and Pizza generator

Recommended Posts

Locath, any chance of including breakfasts? I can get much longer affinities from breakfasts than meals (and pottery bowls can easily hold multiple cabbages/pumpkins), and you can also include multiple meats.

Share this post


Link to post
Share on other sites

@Roccandil: I have very little time on my hands with the ingame project but once I add the things I have planned for the generator, I might add other dish types as well. I need to have the core functionality done first though.

  • Like 2

Share this post


Link to post
Share on other sites
On 4/30/2018 at 0:57 PM, Locath said:

@Anarres: Spot on, missing vegetable is the issue. While unlikely, it could happen as per the comment under the grids on the website:

 

I wonder what kind of dish would it produce if you added the oil? :-)

 

Ah, oki, thanks, I didn't notice that.

 

I tried again the above and ended up with meatballs :)

 

  • Like 1

Share this post


Link to post
Share on other sites

would it be possible to make duplicate ingredients a dropdown selection or maybe a checkbox next to number of ingredients?  i want no nuts and no duplicates but 50 buttons will be silly

Share this post


Link to post
Share on other sites

@MrGARY: I swear I will try to find the time to redo the thing once I finish digging the tunnel I'm working on, I'm hoping to have it open for sailing in 2 weeks. Then I will add the ingredient exclusion by group and by specific ingredient.

Share this post


Link to post
Share on other sites

Let's try an archaeology pizza and I shall name you Archie

 

  • Like 1

Share this post


Link to post
Share on other sites

I love this tool!

 

@Locath Would you be willing/able to provide a service layer for recipe generation, like a WebAPI other developers could call from their applications via REST? 

Share this post


Link to post
Share on other sites

Archie pizzas were great.  Now leatherworking

Share this post


Link to post
Share on other sites

Is it possible that the meal generator is not working anymore? It does not seem to correlate with my account at all.

Share this post


Link to post
Share on other sites

@FranktheTank: I will test it after work, in about 10h. There were a few big updates released in game recently so there is a chance that something has changed. I don't cook so I'm not up to speed with those things.

In the meantime, if someone else could test and reply with results it would be appreciated.

Share this post


Link to post
Share on other sites

@FranktheTank: Tested just now, worked fine. Did it work for that account before? Is it perhaps an old account with bugged affinities?

Share this post


Link to post
Share on other sites
4 hours ago, Locath said:

@FranktheTank: Tested just now, worked fine. Did it work for that account before? Is it perhaps an old account with bugged affinities?

It worked fine a couple of days ago, what do you mean by bugged affinities?

Edited by FranktheTank

Share this post


Link to post
Share on other sites

It's because of pea pods.  When you right click a pea pod to "pick seeds" you get a pea.  The pea, when chopped, counts as +58, whereas the pea pod is 46.  Now, a pea (seed) is giving +46 like the pea pod, so it shot half my recipes to hell.

Share this post


Link to post
Share on other sites

Sigh, This kills over 33 meals for me. It wouldn't be so bad but I do 15 ingredients without any foraged or botanized items . Sometimes it generates what I want fast and other times lets say it can take a while. Checkbox for no foraged or botanized items would be awesome or they could put the value back to what it was.

Share this post


Link to post
Share on other sites
6 hours ago, Wargasm said:

It's because of pea pods.  When you right click a pea pod to "pick seeds" you get a pea.  The pea, when chopped, counts as +58, whereas the pea pod is 46.  Now, a pea (seed) is giving +46 like the pea pod, so it shot half my recipes to hell.

 

Updated the modifiers according to Wargasm's findings. Please test.

 

Share this post


Link to post
Share on other sites

From tests preformed by allies, one person gets the skill offset by 10, another person by 12 on recipes using pea. Disabled it for now, seems to be working fine again.

Share this post


Link to post
Share on other sites

You got a great and very useful tool here. Thanks so much for all the work you put into this.

 

But ...

 

I am having issues w/ some recipes. If you have time, can you look over recipes that are not working for me, tell me what I am doing incorrectly?

 

Posted below are screenies which  include your Food Generator suggestion, and my ingredients, which I cooked the Baking Stone shown, and in a normal Oven. Also listed is the affinity my meal gave me on completion. The numerical differences between the affinities, appear to be consist at +116. Sometimes your Food Generator works fine, other times (seems random to me so far) it goes off by +116, on getting the correct food affinity.

 

(the affinity for me, to use w/ your Food Generator, is Longsword)

 

bMGoSq7.jpg

 

oRCR971.jpg

 

8NU385Z.jpg

 

Thanks so much your Food Generator. Sorry I can not seem to get it to work correctly. I appreciate any time you got to help me out.

 

Peace.

 

TeeeBOMB

 

(I'm in game just about every single day in case you want to PM me in game, but I'll also review this thread periodically too)

 

Actually, if anyone here can see and tell me what I'm doing wrong will be great service. I can not find what I'm doing wrong.

Edited by TeeeBOMB
more words

Share this post


Link to post
Share on other sites

TeeeBOMB, maybe your character is bugged - there is a meal checker, https://trewq.pl/wurm/mealcheck/ , that should help test if you are affected by this problem. If you are there is an option on the profile to fix this problem - but this is a one way switch and can't be turned off.

Share this post


Link to post
Share on other sites

@TeeeBOMB: This is your main toon you are creating those meals for? Not an alt, using Longsword as the test meal result?

Try closing all the tabs except one, I only learned enough ASP to build this for public use so there is a chance that it's doing something weird in the background.

Try generating a small meal and see if that works fine.

Failing all that, we can do some more testing over the weekend.

Share this post


Link to post
Share on other sites
2 hours ago, Wulfmaer said:

TeeeBOMB, maybe your character is bugged

 

Hey thanks that link to check if my character is bugged! Very handy. I passed the two horse meal test with flying colors, "Not bugged!" I got Archery for the 5 oat one, and fighting for the 11 oat one. Good idea, thanks.

 

56 minutes ago, Locath said:

This is your main toon you are creating those meals for?

 

Good question Locath. Yes, these pizza's are for my main toon. I will say, I used your Food Generator a bunch of times, this +116 error is a more recent thing, was just wondering if one ingredient was bugged or some update changed something. I do not get this error on all my efforts. Just it happens often enough to be very disheartening, lol. After all that prep work making a large scale full house pizza.

 

The only problem I ever had with your Food Generator before this, was my dumb error. I had entered the incorrect starting affinity. For me this affinity should be longsword. I did double check this recently by making a test meal. And I double checked to make certain I had your Food Generator set up for Longsword. I added the screenies for proof, lol.

 

Usually when I'm cooking I have many many windows open. FSBs, Oven, Backpack, back and forth to the BSB for fat and bladders, sometimes several others. Would be hard to tell at which point to close all the windows. I guess when u drop it into the oven?

 

I hate to harass you on this. Well, since you have not mentioned any 'known' issues been recently cropping up, I am almost certain it may be some knucklehead thing I am doing on the user side. I'll do more experimenting to see if I can discover any new information on this. I did think for a while the ingredient 'roach' was glitched. But that theory flew out the window more recently with other meals (the 3rd screenie above shows up +116 off, with no roach in it).

 

I did look but have not found any single ingredient that adds +116 to a pizza. I'll post here if I discover any new information on my personal problems over here using your Food Generator.

Share this post


Link to post
Share on other sites

I'm having issues with one particular affinity for an alt.

 

Test meal was MIND.

Looking for FIGHTING

10 ingredient meal worked fine.

Tried 3 different recipes for pizza (all 19 ingredient).

None of them ended up as fighting - all of them ended up the same Mind Logic instead of Fighting.

 

Did a pizza for another alt whose test meal was PAVING.

Looked for fighting.

Pizza correctly made with FIGHTING.

 

Both characters are not bugged and have new affinity turned on.

Share this post


Link to post
Share on other sites

@Alectrys: Since I made no changes in code, it seems that another ingredient was changed (like peas before) or toons get "bugged" again. Can you try making a meal and see if that works for the toon which was getting ML instead of Fighting?

Share this post


Link to post
Share on other sites

Locath,

 

I did make a meal for that character and it DID come out as fighting.  Then I decided to make a pizza for her too.  

 

The meal was fine (10 ingredients)  The 3 pizzas were not.

 

The 3 pizzas came  out as Fighting for a character that had Armour Smithing as the Test Meal.

The 3 pizzas came out as Milling for a character that had Paving as the Test Meal.

 

Hope that helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now