Capi

[Bug] Character displacement on boat after server crossing

Recommended Posts

I crossed borders on a knarr and on the new server I got placed lower than I should. 

Disembarking and embarking again did not fix it.

Relogging did fix it.

 

Bugged view:

Spoiler

5zRnqDD.jpg

 

 

Normal view (after relog)

Spoiler

UqvFHwy.jpg

 

Share this post


Link to post
Share on other sites

I was able to reproduce this on the stable client as well in some instances.  Added to the bug list.  Thanks for the report and the images.

 

Also noted that a disembark and embark again fixed the issue for me.

Share this post


Link to post
Share on other sites

Happened to me as well, but I have no way yet to easily reproduce it. There was a passenger and it was a sailing boat. Embarking again did not fix it for me.

Share this post


Link to post
Share on other sites

It happens often to me, it is like you disembarked the boat, but disembarking and embarking will fix this each time for me. Seems more prone to happen when making multiple border hops.

Share this post


Link to post
Share on other sites

I always encounter this.. well, make that 90%. Got used to it by now :)

 

Edited by Yaga

Share this post


Link to post
Share on other sites

Happens to me too about 80% of the time while sailing between servers.  Only way to resolve is to right click boat to disembark then embark again.

Share this post


Link to post
Share on other sites

Just went from Xan to Deli and didn't get bug this time.  \o/

Share this post


Link to post
Share on other sites

Server corner was my issue.

Edited by nicedreams

Share this post


Link to post
Share on other sites

Been doing a lot 10+ server crossings within past few hours and my only issue having this has been when I cross to Xan.  I've crossed most all other servers and Xan is the only one consistently where I have to disembark and embark again.

Share this post


Link to post
Share on other sites

If you don't reconnect you will have a bugged position on other mounts too, here is a how it looks when riding a horse

wil64Ic.jpg

Share this post


Link to post
Share on other sites

After crossing a server border (whether by swimming or by being in a boat does not seem to matter), if I then embark on a boat I am very low in it and can barely see over the side of it.

wurm.20181028.1538.png?width=1247&heightwurm.20181028.1538_1.png?width=1247&heig

 

It's probably not the most obvious from the screenshots, but it is actually a pretty big issue. Very hard to navigate like this.

 

The problem is fixed upon restarting the game... until the next border crossing.

This has been happening only very recently. I discovered it today and did not have this issue two days ago.

Share this post


Link to post
Share on other sites

Clarification:  The visual displacement issue and the issue of actually getting kicked out of the boat and watching it sail away without you are being followed on the same bug number, which is why I linked the two posts.

 

Unfortunately there are a few boat crossing issues still being tracked, so feel free to report them here and I'll funnel them into the proper bug number.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now