Sign in to follow this  
DiWorm

Need help with cluster (different networks)

Recommended Posts

Hello there..

 

Trying to connect server in cluster in different networks, like this:

 

SRV1 <-> ROUTER1 <-> ROUTER2 <-> SRV2

 

Anyone can write detailed guide how to do this (where-and-what-we-need-to-write-in-configs)?

 

Coz we get some ######:

 

	[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: serverId:1 kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: didi kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: serverId:1 kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: didi kingdom id 2 exists=true 
[11:51:38 PM] WARNING com.wurmonline.server.LoginServerWebConnection: Failed to send command Exception creating connection to: 192.168.1.2; nested exception is: 
java.net.BindException: Address already in use: connect 
[11:51:39 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: serverId:1 kingdom id 3 exists=true 
[11:51:39 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: didi kingdom id 3 exists=true 
[11:51:40 PM] WARNING com.wurmonline.server.LoginServerWebConnection: Failed to send command Exception creating connection to: 192.168.1.2; nested exception is: 
java.net.BindException: Address already in use: connect 
[11:51:40 PM] WARNING com.wurmonline.server.LoginServerWebConnection: Failed to send command Exception creating connection to: 192.168.1.2; nested exception is: 
java.net.BindException: Address already in use: connect	[11:52:54 PM] INFO com.wurmonline.communication.SocketServer: Accepted player connection: Socket[addr=/192.168.1.1,port=57309,localport=3724] 
[11:52:55 PM] INFO com.wurmonline.server.steam.SteamHandler: Client was Authenticated 
Client was Authenticated 
[11:52:55 PM] INFO com.wurmonline.server.LoginHandler: /192.168.1.1, Diworm redirected from 1 to server ID: 2 
[11:52:55 PM] INFO com.wurmonline.server.steam.SteamHandler: Client was NOT Authenticated 
Client was NOT Authenticated

Edited by DiWorm

Share this post


Link to post
Share on other sites

Perhaps run through a VPN?

Never tried though.

Share this post


Link to post
Share on other sites

Servers connected, but in logs going super-flood like this and server id:2 (non-login) have huge lags via this flood:

[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: didi kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: serverId:1 kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: didi kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: serverId:1 kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: didi kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: serverId:1 kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: didi kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: serverId:1 kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: didi kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: serverId:1 kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: didi kingdom id 2 exists=true 
[11:51:38 PM] INFO com.wurmonline.server.webinterface.WebInterfaceImpl: serverId:1 kingdom id 2 exists=true 
Edited by DiWorm

Share this post


Link to post
Share on other sites

If you hook them up on the same network (no routing), there is no problem?

Share this post


Link to post
Share on other sites
12 minutes ago, Jukken said:

If you hook them up on the same network (no routing), there is no problem?

Yep, problem only with different networks

Share this post


Link to post
Share on other sites

I would try using a VPN if you must have routers.

Share this post


Link to post
Share on other sites
10 minutes ago, Jukken said:

I would try using a VPN if you must have routers.

I think all should be work when we find why login server spam to 2nd.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this