Sign in to follow this  
DevBlog

WSA: DNS connectivity issues

Recommended Posts

That's odd, to me.  I have both win 7 and 10 machines and it works on each of them.  You are putting the line "148.251.21.205    jenn001.game.wurmonline.com" with no #, correct? There needs to be at least one space between the ip and jenn..... could use a tab as well.

Share this post


Link to post
Share on other sites
Just now, Morhedron said:

That's odd, to me.  I have both win 7 and 10 machines and it works on each of them.  You are putting the line "148.251.21.205    jenn001.game.wurmonline.com" with no #, correct? There needs to be at least one space between the ip and jenn..... could use a tab as well.

 

yeah I did...

Share this post


Link to post
Share on other sites

The only thing I can think of is that I have the "Professional" versions, not the "Home" versions.  I do know MS dumbed down the "Home" networking protocols......

Share this post


Link to post
Share on other sites

Me, too... (Win10 Professional)

 

And I even tried the wanted syntax <network name>  <network number>     [aliases...]:

 

jenn001.game.wurmonline.com 148.251.21.205

 

Nothing works... Maybe I have to change the system language to english or whatever - MS is sometimes very special...

Or are there any settings to enable this file otherwise it does not look there?

Edited by deKeep
a post between

Share this post


Link to post
Share on other sites
3 hours ago, Odynn said:

On Windows :

Look for the folder : C:\Windows\System32\Drivers\etc\

in it there is a file named hosts

Copy/Paste it on your desktop.

Open it with notepad and add the line 148.251.21.205 jenn001.game.wurmonline.com at the end of the file.

Save the changes.

Copy/Paste it back in the C:\Windows\System32\Drivers\etc\ folder.

 

Once the DNS are fixed, remove the added line from the hosts file the same way you did (or before following the whole procedure, make a backup copy).

 

Nota, you do not change the IP adress, you let your computer know where the login server is (basicly what a DNS do).

Crash after crash after crash :P

Share this post


Link to post
Share on other sites

Do we have a time frame of when this will be fixed so we all can play again.

Share this post


Link to post
Share on other sites

This works, since it removes you going to files and changing stuff. just go into CMD as admin and copy/paste : echo 148.251.21.205 jenn001.game.wurmonline.com >> c:\windows\System32\drivers\etc\hosts 

 

 

--quoted from finnn

Share this post


Link to post
Share on other sites

just have to run the console as admin first, permissions are going to "bark at you back".. if you aren't admin or run the console as such :) 

Share this post


Link to post
Share on other sites

Windows 10 requires you to copy the file to desktop or another location, modify the copy after disabling read only, then put read only back on it and copy it back. it's because the etc folder is also read only. despite admin having privileges.  So, i keep a copy on my desktop now. it will prompt to replace and then ask for continue on privileges.

 

  • Like 1

Share this post


Link to post
Share on other sites

Is there any DNS-server how knows this game actually? I guess it is the simplest way to change the DNS for the moment...

Share this post


Link to post
Share on other sites

Just from reading this, I'm going to recommend you to not turn off the "read only" flag for your hosts file.  This is how Malware can change your hosts/DNS info and force you to Malware sites.  The file is "read only" on purpose to prevent viruses/malware from making changes to the file.  This is also why you must do this as an administrator (being part of the local administrator group is not the same thing) by right clicking on Notepad and choosing "Run as Administrator".

 

This is very serious!

If you cleared the "read only" flag from your hosts file, please check it and make sure it is "read only" so you don't screw yourself in the future from some kind of weak malware that can hi-jack your hosts file.

Edited by nicedreams
  • Like 1

Share this post


Link to post
Share on other sites

Which is why i said to set it back to read only before copying. Yes, I know being administrator is not the same as administrator's group but if you go into advanced settings you'll find that your account has full admin rights otherwise it would not allow you to overwrite the file to begin with.

Any time you change permissions on a file for the purpose of editing, you should set those permissions/flags back to the way they were when you found them.

 

Edited by KageTenshi

Share this post


Link to post
Share on other sites

For sure I saw that and not downing anyone at all, but there's a lot going around about the "making it not read only" so making sure people understand to not leave it in that state and to make sure it's read only again. :)

 

When I was younger (I'm not that old) I used to play with my hosts file and forgot to make it read only and then got hit with malware.  This was my own computer and my own mess up.  So since I remembered that I put the reply. :)

 

In the future the "Run notepad as Administrator" is a better way.  Then you don't need to copy the hosts file to the desktop or do anything else.  Just modify the file in place where it is and you're done.

 

Edited by nicedreams

Share this post


Link to post
Share on other sites

As an administrator, I used to blacklist sites we didnt want users going to by adding them to the hosts file and directing them to localhost :P

 

Edited by KageTenshi

Share this post


Link to post
Share on other sites

I dont have a host file

c:\windows\System32\drivers\etc\hosts

Share this post


Link to post
Share on other sites

If it's windows, there should be 5 files inside that etc folder. You may need to modify settings to see system files. are you logged into the computer on an account with administrative rights?

 

Share this post


Link to post
Share on other sites
1 minute ago, Evarya said:

I dont have a host file

c:\windows\System32\drivers\etc\hosts

you do.. could be hidden, your explorer might be set to not show it, which doesn't mean that you do not have it 

 

in windows search or run field/line.. paste this

Quote

notepad c:\windows\system32\drivers\etc\hosts

it will open the file for you, with notepad(which doesn't meant that you'll be able to edit it, if the file's read-only), look up for fixing that

 

Share this post


Link to post
Share on other sites

Well, i should be, it my personal laptop ive had for about 5 years

Share this post


Link to post
Share on other sites
2 minutes ago, Finnn said:

you do.. could be hidden, your explorer might be set to not show it, which doesn't mean that you do not have it 

 

in windows search or run field/line.. paste this

it will open the file for you, with notepad(which doesn't meant that you'll be able to edit it, if the file's read-only), look up for fixing that

 

 

The fix is opening Notepad as Administrator by right clicking the notepad icon and clicking "Run as administrator".

 

Or can search for "cmd" and then right click that and "Run as administrator" and then paste the:  notepad c:\windows\system32\drivers\etc\hosts   which will open notepad as administrator since command prompt is admin.

 

Just having fun with this on the tech side now. :)

Edited by nicedreams

Share this post


Link to post
Share on other sites
1 minute ago, nicedreams said:

 

The fix is opening Notepad as Administrator by right clicking the notepad icon and clicking "Run as administrator".

That doesn't always work. That was my first approach last night. It refused to let me save it because of folder permissions.  It seems Windows 10 is throwing all kinds of 'you can't do it quite that way' issues. So much simpler in linux/unix. Anyway, they 'should' try it that way first. The thing about opening CMD as administrator is most people just do Windows-R to open a run window which does not open it as administrator. They need to go to cortana, find command prompt and right click that and open as administrator to use that. 

 

Share this post


Link to post
Share on other sites
Just now, KageTenshi said:

That doesn't always work. That was my first approach last night. It refused to let me save it because of folder permissions.  It seems Windows 10 is throwing all kinds of 'you can't do it quite that way' issues. So much simpler in linux/unix. Anyway, they 'should' try it that way first. The thing about opening CMD as administrator is most people just do Windows-R to open a run window which does not open it as administrator. They need to go to cortana, find command prompt and right click that and open as administrator to use that. 

 

 

I wish everyone used WIN+R   lol  Love it.  Sucks every time I try to walk someone over the phone how to press WIN+R on their keyboard.

Share this post


Link to post
Share on other sites

Yeah, i dont seem to have admin rights and cant save

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this