Sign in to follow this  
ausimus

AusMods (Consolidated List) New WhiteListing Mod

Recommended Posts

Very nice, thank you ausimus :)

 

Eject

Edited by Eject

Share this post


Link to post
Share on other sites

Hello Ausimus

 

I have a little problem with the Auto alerts

I see the pollseconds is for 3 hours, but the mod spams my (and my players) event window each second with the names of mayors :

 

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Sparta mayor Graubart has not logged in for 108 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Gut Warwick mayor Jowanny has not logged in for 99 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Madland mayor Madangel has not logged in for 506 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Gorath mayor Quinthar has not logged in for 164 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Gorath North mayor Nazgarth has not logged in for 641 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Nanuka mayor Nanuka has not logged in for 123 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Gorath West mayor Talarus has not logged in for 443 days.

[06:17:58 AM] SEVERE org.gotti.wurmunlimited.modloader.server.Listeners: ServerPollListener handler for mod Initiator failed

java.lang.NullPointerException

 

This is my config:

 

# Will throw out an alert when deed mayor has not logged in in a specified amount of days, default 30.
useDeedAlert = true
# Interval in seconds between alerts, 3 hours default.
DA_pollSeconds = 10800
# Max days a mayor has not logged in before alert is thrown.
MaxDays = 90
# Will auto disband when alert is shown, handy for deed pruning.
# This will throw an error serverSide, error is harmless, method still works as intended.
# Use with care.
autoDisband = false

# Use?
useAlert0 = true
# Interval in seconds between alerts.
Seconds0 = 3600

 

Eject

 

add: i am sure, there must be more deeds in the list ^^

Edited by Eject

Share this post


Link to post
Share on other sites
On 9/25/2017 at 1:23 AM, Eject said:

Hello Ausimus

 

I have a little problem with the Auto alerts

I see the pollseconds is for 3 hours, but the mod spams my (and my players) event window each second with the names of mayors :

 

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Sparta mayor Graubart has not logged in for 108 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Gut Warwick mayor Jowanny has not logged in for 99 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Madland mayor Madangel has not logged in for 506 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Gorath mayor Quinthar has not logged in for 164 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Gorath North mayor Nazgarth has not logged in for 641 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Nanuka mayor Nanuka has not logged in for 123 days.

[06:17:58 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Gorath West mayor Talarus has not logged in for 443 days.

[06:17:58 AM] SEVERE org.gotti.wurmunlimited.modloader.server.Listeners: ServerPollListener handler for mod Initiator failed

java.lang.NullPointerException

 

This is my config:

 

# Will throw out an alert when deed mayor has not logged in in a specified amount of days, default 30.
useDeedAlert = true
# Interval in seconds between alerts, 3 hours default.
DA_pollSeconds = 10800
# Max days a mayor has not logged in before alert is thrown.
MaxDays = 90
# Will auto disband when alert is shown, handy for deed pruning.
# This will throw an error serverSide, error is harmless, method still works as intended.
# Use with care.
autoDisband = false

# Use?
useAlert0 = true
# Interval in seconds between alerts.
Seconds0 = 3600

 

Eject

 

add: i am sure, there must be more deeds in the list ^^

I'll take a look at it, I most likely borked something iirc correctly I had this issue on my server, was an issue with the mod searching for starter deeds, which was fixed and I most likely didn't bring the fix over.

  • Like 1

Share this post


Link to post
Share on other sites

Update: New mod Poll Spawner

 

Poll Spawner

This WU server side mod allows the server to randomly spawn items (currently only Rift Items) around the map.
They will not spawn on deed, below water, mine entrances, rock, lava, or on slopes > 20.

Mostly anything can be configured with it, if i missed a wanted configuration post it here and ill add it to the next version.

https://github.com/ausimus/WU-PollSpawner/releases/latest

  • Like 2

Share this post


Link to post
Share on other sites

If you could spawn rift mobs too, that would be very funny. I asked my players because this new mod, and they would like it. we will play with it this weekend =)

 

Eject

Share this post


Link to post
Share on other sites
3 hours ago, Eject said:

If you could spawn rift mobs too, that would be very funny. I asked my players because this new mod, and they would like it. we will play with it this weekend =)

 

Eject

Yea, I can that in the next version.

  • Like 1

Share this post


Link to post
Share on other sites

When I install this mod I get the following error and the server won't start.  If I disable it then the server doesn't produce any errors and starts just fine.

 

Spoiler

[

[03:55:25 AM] SEVERE org.gotti.wurmunlimited.serverlauncher.DelegatedLauncher: java.lang.RuntimeException: com.wurmonline.server.behaviours.Actions class is frozen
java.lang.RuntimeException: java.lang.RuntimeException: com.wurmonline.server.behaviours.Actions class is frozen
    at net.bdew.wurm.timerfix.TimerFix.init(TimerFix.java:336)
    at org.gotti.wurmunlimited.modloader.ModLoaderShared.lambda$loadModsFromModDir$5(ModLoaderShared.java:159)
    at java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:184)
    at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:175)
    at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1374)
    at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)
    at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471)
    at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151)
    at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174)
    at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
    at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:418)
    at org.gotti.wurmunlimited.modloader.ModLoaderShared.loadModsFromModDir(ModLoaderShared.java:157)
    at org.gotti.wurmunlimited.serverlauncher.DelegatedLauncher.main(DelegatedLauncher.java:18)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at javassist.Loader.run(Loader.java:288)
    at org.gotti.wurmunlimited.serverlauncher.ServerLauncher.main(ServerLauncher.java:33)
Caused by: java.lang.RuntimeException: com.wurmonline.server.behaviours.Actions class is frozen
    at javassist.CtClassType.checkModify(CtClassType.java:294)
    at javassist.CtBehavior.instrument(CtBehavior.java:710)
    at net.bdew.wurm.timerfix.TimerFix.init(TimerFix.java:216)
    ... 18 more

 

Share this post


Link to post
Share on other sites
4 hours ago, Asperis said:

When I install this mod I get the following error and the server won't start.  If I disable it then the server doesn't produce any errors and starts just fine.

 

  Reveal hidden contents

[

[03:55:25 AM] SEVERE org.gotti.wurmunlimited.serverlauncher.DelegatedLauncher: java.lang.RuntimeException: com.wurmonline.server.behaviours.Actions class is frozen
java.lang.RuntimeException: java.lang.RuntimeException: com.wurmonline.server.behaviours.Actions class is frozen
    at net.bdew.wurm.timerfix.TimerFix.init(TimerFix.java:336)
    at org.gotti.wurmunlimited.modloader.ModLoaderShared.lambda$loadModsFromModDir$5(ModLoaderShared.java:159)
    at java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:184)
    at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:175)
    at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1374)
    at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)
    at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471)
    at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151)
    at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174)
    at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
    at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:418)
    at org.gotti.wurmunlimited.modloader.ModLoaderShared.loadModsFromModDir(ModLoaderShared.java:157)
    at org.gotti.wurmunlimited.serverlauncher.DelegatedLauncher.main(DelegatedLauncher.java:18)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at javassist.Loader.run(Loader.java:288)
    at org.gotti.wurmunlimited.serverlauncher.ServerLauncher.main(ServerLauncher.java:33)
Caused by: java.lang.RuntimeException: com.wurmonline.server.behaviours.Actions class is frozen
    at javassist.CtClassType.checkModify(CtClassType.java:294)
    at javassist.CtBehavior.instrument(CtBehavior.java:710)
    at net.bdew.wurm.timerfix.TimerFix.init(TimerFix.java:216)
    ... 18 more

 

Fixing now, as well as some other issues.

  • Like 1

Share this post


Link to post
Share on other sites

Updated Poll Spawner:

Added all Rift Creatures to be able to spawn, these share the item spawn settings for amount spawned.

Added Purge Items, and Creatures action to allow for removal of creatures and Items that are spawned with Poll Spawner, activate a Ebony Wand as power 5 and right click it to see the actions.

Fixed an issue that was causing the mod to not load if other action manipulation mods were present.

Fixed some errors I made in the count checks for Item spawning.

 

https://github.com/ausimus/WU-PollSpawner/releases/latest

  • Like 3

Share this post


Link to post
Share on other sites
14 hours ago, ausimus said:

Updated Poll Spawner:

Added all Rift Creatures to be able to spawn, these share the item spawn settings for amount spawned.

Added Purge Items, and Creatures action to allow for removal of creatures and Items that are spawned with Poll Spawner, activate a Ebony Wand as power 5 and right click it to see the actions.

Fixed an issue that was causing the mod to not load if other action manipulation mods were present.

Fixed some errors I made in the count checks for Item spawning.

 

https://github.com/ausimus/WU-PollSpawner/releases/latest

You are very awesome :)

Thank you for this fast reaction!!

 

Eject

 

add: 

I have an idea, i hope you love it like me ^^ maybe you can realise it anytime :)

 

What do you think about if you can setup different riftgroups (creatures and/or items) and can spawn the groups with your wand righclicking on a tile --->spawn riftgroup1,2,3... in a given area like 10 tiles 20 tiles....

 

This would be awesome if you like to use this mod just for Riftevents, or maybe you can than also spawn mobs that you just see in pvp servers. Oh now i have so much ideas for different events, if this would work :) or maybe a new mod ^^

 

Eject

Edited by Eject

Share this post


Link to post
Share on other sites

I need more testing on it but on a 8k map poll spawner mod is a nightmare for lag. My 2k cluster maps have no issues but just a note to be wary if using on a large map. Going to investigate and tweak to see if I can get it under control because I do like how it's implemented. Just noting it for some that may not fully test on a large map before implementation. 

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, Jerone0601 said:

I need more testing on it but on a 8k map poll spawner mod is a nightmare for lag. My 2k cluster maps have no issues but just a note to be wary if using on a large map. Going to investigate and tweak to see if I can get it under control because I do like how it's implemented. Just noting it for some that may not fully test on a large map before implementation. 

Try increasing the poll time its default is 5 seconds.

Share this post


Link to post
Share on other sites

Hello Ausimus

Have you fixed the Autoalerts problem? (because mayor and deedname spawning in event)

 

Happy wurming

Eject

Share this post


Link to post
Share on other sites

Riftspawn:

Ausimus, deleting the spawned mobs dont work, the server is hanging in the "Refreshing" think, deleting the items works wonderful

 

Eject

Share this post


Link to post
Share on other sites
4 minutes ago, Eject said:

Riftspawn:

Ausimus, deleting the spawned mobs dont work, the server is hanging in the "Refreshing" think, deleting the items works wonderful

 

Eject

Yea deleting the creatures is super laggy and only intended as a last ditch thing in case of messed up config, and can take a long time to do depending on the map size and creature count. it checks all creatures and deletes the ones specified in the for loop.

Edit: also working on the issue with autoAlerts

  • Like 1

Share this post


Link to post
Share on other sites

ok i understand Ausimus 

 

and thanks for your work :)

 

Eject

Share this post


Link to post
Share on other sites

Hi I just started using the auto alerts mod you have.  I see when the server starts up that it sends a server wide message once.  But it never repeats after that.  From the server logs:

 

[10:51:57 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Visit our Steam group @ http://steamcommunity.com/groups/dawgswu
[10:51:57 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Join us on Discord @ https://discord.gg/g4XKH4w
[10:51:57 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Join us on TeamSpeak @ ts.dawgsclan.com
[10:51:57 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: View our live map (updated hourly) @ http://www.dawgsclan.com/wurm/

 

 And here are properties file settings:

 

classname = org.ausimus.wurmunlimited.mods.autoalert.Initiator
classpath = AutoAlerts.jar
sharedClassLoader = true

# Transmit to twitter?
transmitTwitter = false

# Will throw out an alert when deed mayor has not logged in in a specified amount of days, default 30.
useDeedAlert = false
# Interval in seconds between alerts, 3 hours default.
DA_pollSeconds = 10800
# Max days a mayor has not logged in before alert is thrown.
MaxDays = 30
# Will auto disband when alert is shown, handy for deed pruning.
# This will throw an error serverSide, error is harmless, method still works as intended.
# Use with care.
autoDisband = false

# Use?
useAlert0 = true
# Interval in seconds between alerts.
Seconds0 = 1800
# The Alert put this into one line, no shift entering or you will will prolly break some ######, the server will wrap the text.
Alert0 = Visit our Steam group @ http://steamcommunity.com/groups/dawgswu

useAlert01 = true
Seconds01 = 1800
Alert01 = Join us on Discord @ https://discord.gg/g4XKH4w

useAlert02 = true
Seconds02 = 1800
Alert02 = Join us on TeamSpeak @ ts.dawgsclan.com

useAlert03 = true
Seconds03 = 1800
Alert03 = View our live map (updated hourly) @ http://www.dawgsclan.com/wurm/

 

Share this post


Link to post
Share on other sites
9 hours ago, mwdennis said:

Hi I just started using the auto alerts mod you have.  I see when the server starts up that it sends a server wide message once.  But it never repeats after that.  From the server logs:

 


[10:51:57 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Visit our Steam group @ http://steamcommunity.com/groups/dawgswu
[10:51:57 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Join us on Discord @ https://discord.gg/g4XKH4w
[10:51:57 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: Join us on TeamSpeak @ ts.dawgsclan.com
[10:51:57 AM] INFO com.wurmonline.server.MessageServer: Broadcasting Serverwide Alert: View our live map (updated hourly) @ http://www.dawgsclan.com/wurm/

 

 And here are properties file settings:

 


classname = org.ausimus.wurmunlimited.mods.autoalert.Initiator
classpath = AutoAlerts.jar
sharedClassLoader = true

# Transmit to twitter?
transmitTwitter = false

# Will throw out an alert when deed mayor has not logged in in a specified amount of days, default 30.
useDeedAlert = false
# Interval in seconds between alerts, 3 hours default.
DA_pollSeconds = 10800
# Max days a mayor has not logged in before alert is thrown.
MaxDays = 30
# Will auto disband when alert is shown, handy for deed pruning.
# This will throw an error serverSide, error is harmless, method still works as intended.
# Use with care.
autoDisband = false

# Use?
useAlert0 = true
# Interval in seconds between alerts.
Seconds0 = 1800
# The Alert put this into one line, no shift entering or you will will prolly break some ######, the server will wrap the text.
Alert0 = Visit our Steam group @ http://steamcommunity.com/groups/dawgswu

useAlert01 = true
Seconds01 = 1800
Alert01 = Join us on Discord @ https://discord.gg/g4XKH4w

useAlert02 = true
Seconds02 = 1800
Alert02 = Join us on TeamSpeak @ ts.dawgsclan.com

useAlert03 = true
Seconds03 = 1800
Alert03 = View our live map (updated hourly) @ http://www.dawgsclan.com/wurm/

 

this happens on my server also. 

Share this post


Link to post
Share on other sites
14 hours ago, Batta said:

@mwdennis I have found that my alerts repeat only if I set the seconds to 900 max. 

Oh wow....so you can only do a max of 15 minutes? ugh....i guess if that's all.  Maybe the OP/dev can fix this in a future release.

Share this post


Link to post
Share on other sites

I have a variety of alerts all the way up to 10000 and they all work.

Share this post


Link to post
Share on other sites
15 hours ago, LifesaverM said:

I have a variety of alerts all the way up to 10000 and they all work.

 

Great....so what exactly am I doing wrong then.....The logs show it loading the mod and doing an initial alert, but none of them repeat.

  • Like 1

Share this post


Link to post
Share on other sites

Try disabling the deed alert system in the properties and see if that helps, i do believe i screwed that up and haven't had time to fix it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this