Sign in to follow this  
Corsan

Lag, Lag, Freeze, Disconnect. Xan Server down?

Recommended Posts

Logged in today and have been getting some pretty regular lag on Xanadu. The 'I'm driving forward but my cart horses are facing sideways' kind of lag. Decided not to go anywhere and was sitting on my deed milling cereals and then went to make them into dough and bake them...and shortly after I started baking up the batches of bread...the game locked up/froze. I thought maybe it was lag, so I went and read a page in the background...came back, and it was still locked up. I logged out...and now I'm trying to login and getting "An existing connection was forcibly closed by the remote host" numerous times. It won't let me login at all now. Did the server crash or is this just me?

Share this post


Link to post
Share on other sites

Same happened to me..lag....crash..can not connect.

Share this post


Link to post
Share on other sites

Same. Lag has been increasingly bad over the past few days. Played briefly this afternoon and now unable to log in at all. This is getting quite old.

Share this post


Link to post
Share on other sites

Very frustrating!!!

Share this post


Link to post
Share on other sites

Someone triped on a cord and unpluged the server ?

Share this post


Link to post
Share on other sites

I locked up in a "refreshing" phase for 10 minutes until I closed the client down.

Now I can't log back in.

Share this post


Link to post
Share on other sites

Same here, first was looong lag, disconnect and got this : "An existing connection was forcibly closed by the remote host"

Now I am getting : Connection denied ( the server currently unavailable, please try  later ) :(

Anyone knows how long it will be and what is the problem now?

Share this post


Link to post
Share on other sites

Undoubtedly they are rebooting the server...for XAN, despite their claims, that means 30-45 mins as it reboots...Every other server...fast.  oh well.

Share this post


Link to post
Share on other sites

Hope Xan is up sooner than later. I've got new villagers who joined in to check on

Share this post


Link to post
Share on other sites

Seems to be back up now. Hopefully the restart fixed it for awhile. :\

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this