Sign in to follow this  
bdew

Looks like 1.3 (open) beta is here

Recommended Posts

indeed it is, and when I saw there are 570 recipes I nearly died of shock lol,

 

huge thanks to the devs for opening up all those recipes..

 

just a quick note, delete the crop fix mod or it will crash the server modloader.

  • Like 2

Share this post


Link to post
Share on other sites

It crashes with the modloader for now, so it's either mods or 1.3 beta until the mods are fixed.  Steam "un-betas" the client and server if you just opt out in the game's preferences so no immediate traumas for now.

Edited by Mordraug

Share this post


Link to post
Share on other sites

no it's the crop fix, remove that and it's sweet as.

  • Like 1

Share this post


Link to post
Share on other sites

Yes the crop fix mini-mod is unneeded now and will cause issues if it's installed. Remove it.

Share this post


Link to post
Share on other sites
42 minutes ago, bdew said:

Yes the crop fix mini-mod is unneeded now and will cause issues if it's installed. Remove it.

 

Got too much on my plate lately (pun intended) to have kept track... Unneeded as in crops won't go to weeds past ripe, or gotta wait a while for that to work again? 

Share this post


Link to post
Share on other sites

There was a bug with crop tile polling in the alpha, and a mod was introduced to fix that.

 

Now it's been addressed officially in the beta, the mod is conflicting and causing issues.

 

Removing the mod from the server mod launcher will mean the official code handles it as it should, and all is well.

  • Like 1

Share this post


Link to post
Share on other sites

Oh I know that, it's running sweet now by the way.  Was just wondering if I don't harvest for too long if they still turn to weeds, or if "decorative" fully grown unharvested fields can still be left going indefinitely.

 

So glad I've barely touched my map, had been waiting for 1.3 so I can plan fields and cooking facilities and such ^_^

 

Massive kudoes to those at CC and the modders for the results so far =D

Edited by Mordraug

Share this post


Link to post
Share on other sites
20 minutes ago, Mordraug said:

Was just wondering if I don't harvest for too long if they still turn to weeds, or if "decorative" fully grown unharvested fields can still be left going indefinitely.

 

Not sure what you mean by decorative... but if you want crop tiles to not decay to weeds you need cropmod (that comes with the server mod loader).

 

The issue above is unrelated, the alpha had crop growing tiles broken entirely - they wouldn't progress at all and stay at one stage forever - and i made a small mod that fixed it (cropfix). Since that was fixed in the beta version, the mod is no longer needed and will cause a crash if installed. If you had installed it for the alpha, remove it when upgrading to the beta.

Edited by bdew

Share this post


Link to post
Share on other sites

Huh..... killing cropmod is what fixed it for me, didn't even have the cropfix one.

 

tl;dr since there must be others who hadn't needed to update their mods in aaaaaaaaaaaaaages and thus may be running more ancient versions:

 

If updating to 1.3 crashes on launch, remove CropFIX if you had it, if crashing persists kill CropMOD too, re-download the mod launcher and install it.  

Didn't have to do anything to the other mods I have in any case. (betterdig, creatureagemod, creaturesonwater, harvesthelper, movemod, spellmod, or timerfix.... NOTE: I haven't tested their FUNCTIONALITY, but they aren't crashing my updated server).

Edited by Mordraug
*grumbles and heads off to replant some fields*

Share this post


Link to post
Share on other sites

To be clear... did you re-enable cropmod after updating the modlauncher or was it still causing a problem?

 

If it doesn't work after the update - please post the error log.

Share this post


Link to post
Share on other sites

Oh after updating, it all runs sweet =D

 

Spellmod's working too for sure, creatures on water too.  Seasons mod may need updating, it works but doesn't show the new stuffs.   I'll report that stuff  on the mods' threads as I test them in any case.  Too busy atm foraging for new stuff, planting the new fields, and wild growthing stuff =P

 

(Note, only upgraded Cropmod, the rest I haven't even touched from before 1.3).

Edited by Mordraug

Share this post


Link to post
Share on other sites

Ty for releasing the full recipe list, as I was not wanting to attempt to recreate the current WO list.

  • Like 4

Share this post


Link to post
Share on other sites

thanks  to devs adding the recipes in \o/ I am gonna be GOOD for at least .. umm ..  SEVEN WEEKS!

 

 

 

*writes a Post-It note to herself and slaps it on her monitor:   BE NICE -- AT LEAST TILL APRIL 16!   NO SNARK!*

 

 

 

Edited by Brash_Endeavors
  • Like 2

Share this post


Link to post
Share on other sites

We seem to be having a problem getting things going, we made  a post on the tech forums a few minutes ago.

 

 

Valiance and Kaylie.

Share this post


Link to post
Share on other sites

I am no good on server issues but i noticed it said "Server not available" -- are you still able to create new characters right now? Is the server setup to be a login server?  is it possible when you copied over the server, you needed to change a few things to make old database IDs work on new server ID as a unique but concurrently running server? Most of the "updated" servers are simply running new version on old version, but your difference is you are trying to run the same database on two different servers that each need unique IDs. Or maybe not, as i said I am no good with servers. Lots of others here who are superb on server issues though so wait for on of them :) 

 

If it were me, i would probably start PMing some of the admins of the  "public servers" who currently are running 1.3 mirrored test servers (Sklo is, Mythmoor might have been another I saw, and bdew's Otherlands). See who is up and working concurrently with both old version AND new version servers,  and ask them if they have ideas, some of them may not be watching WO forums, but they should get a forum PM forwarded to them and most are pretty nice about helping 

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

Mmm...well when we make a new char, it can log in no problem, log it out and in no worries at all, but as soon as we make him a GM with the Game Panel, we try to log him in and get this error. 

We would think this would not be a database ID error ? But we honestly have no idea about server issue's...we will see if anyone else had any insight.

 

Thanks for answering Brash :) And you still could be right, we have no idea :(

 

Valiance and Kaylie.

 

Share this post


Link to post
Share on other sites

I've posted in the other thread, but that indeed could be an ID mismatch.

 

The server stores the last server your character was on in the database. Your ID probably changed when you made the copy but the characters table wasn't updated. If your hoster provides a management panel for that stuff you should probably talk to them as it might be messing things up.

Share this post


Link to post
Share on other sites

i'm not able to make a 3 tile tunnel, anyone else getting this or am I doing something wrong lol, tells me i'm too close to another tunnel

Share this post


Link to post
Share on other sites

there will be another error above it.

 

Make sure the bottom border is flat BEFORE mining in. The auto flatten feature is only for the first tunnel

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Retrograde said:

there will be another error above it.

 

Make sure the bottom border is flat BEFORE mining in. The auto flatten feature is only for the first tunnel

 

yup I see it now, thanks doesn't really matter, as I only use mines now to get materials I need for my monster deeds lol

Share this post


Link to post
Share on other sites

Does this mean that it's now available to everyone?  If so, how do we get this update, when using a server host?  We are on Citadel Servers, and the only option I can see is "Steam Update." Tried that, but we are still not seeing a new version number on the server list when we log in. Or is that not how it works?

Edited by Batta

Share this post


Link to post
Share on other sites

yes it is now available to everyone, you may have to contact your server host to ask about getting switched over, as i do not know how Citadel handles this.  Anyone who wants to play on the beta server will also need to go to their Steam library > Wurm > Properties > Beta and opt in so that they have the beta client

 

If you are running a server that other people are playing on, and intending to switch all of their gameplay over to the beta, I would consult with the community first and make sure they are aware, else one day they will simply not be able to log in, not understand why, and probably have very very very bad feelings about it.  Most public servers run a separate beta branch on a separate server so that their community members have an option to try the beta, but can also just continue to play the regular client on the standard server. 

 

With any beta, there is also a risk of something going boom and losing a lot of data so be prepared to deal with that too. Make sure you have backups and know how to revert to them in an emergency. 

 

 

 

 

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this