Vyolette

Bug reports!

Recommended Posts

Posted (edited)

i think is because it Freedom.. needs to be set of in an area with no kingdom influence..

 

 

Edited by bigsteve

Share this post


Link to post
Share on other sites
On 1/2/2019 at 3:31 AM, bigsteve said:

i think is because it Freedom.. needs to be set of in an area with no kingdom influence..

 

 

Hmm.  Do you know if there's any way for me to create a no-kingdom zone on a Freedom server?

Share this post


Link to post
Share on other sites
On 1/2/2019 at 12:36 PM, Batta said:

 

This is still not working on our server - is it still awaiting a fix, or is it just something we're doing wrong?  I planted it more than 500 tiles from any land at all, it heated up, then nothing.  I got a message:

 

The server is entirely Freedom.

 

You need to be more than 200 tiles away from server border to plant it. Also area of 61x61 tiles around the wand can't be on deed, in perimeter, above sea level or contain any bridges.

Share this post


Link to post
Share on other sites
On 1/2/2019 at 1:31 PM, bigsteve said:

i think is because it Freedom.. needs to be set of in an area with no kingdom influence..

 

This is wrong, you can use them on freedom server. Only limitation is that all tiles in range have to be either of the same kingdom as the user or no kingdom at all - which will always be true on a freedom home server.

Share this post


Link to post
Share on other sites
5 hours ago, bdew said:

 

This is wrong, you can use them on freedom server. Only limitation is that all tiles in range have to be either of the same kingdom as the user or no kingdom at all - which will always be true on a freedom home server.

Good to know. I wonder why it doesn't work for me then?  The whole server is Freedom, and I tried it way out in the northern ocean where there was no land within visual range.

Share this post


Link to post
Share on other sites
15 hours ago, Batta said:

Good to know. I wonder why it doesn't work for me then?  The whole server is Freedom, and I tried it way out in the northern ocean where there was no land within visual range.

 

Did you read my other post? Were you less than 200 tiles from server border by chance? :P

 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, bdew said:

 

Did you read my other post? Were you less than 200 tiles from server border by chance? :P

 

Oops, I missed that one!  Off to try again.  Thanks

 

EDIT:  It worked!  

Edited by Batta

Share this post


Link to post
Share on other sites
I am having a problem using keys with locked containers. It's probably easiest to go straight to the example...
 
-> I am on a PVE server where stealing is not allowed
-> I have a deed with pickup permission turned OFF ...
-> on it I have a building with may enter / pickup / load / unload permissions turned ON ...
-> inside I have a crate rack secured to the ground and fitted with a small padlock ...

If I manage the container (crate rack) and add a non-citizen player with may-open permission.  He can open the container and transfer items out of it.  Everything in that instance works as you would expect it to.

However, If I DO NOT set the container permissions and give the player the key instead, he can only look inside the container, any attempt to remove an item gets a 'no stealing' notice.

If that player uses the key to place items into the container .. he can remove only the items he placed inside.
 
I did the same tests with a large chest as well and got the same results
I also logged out the deed owner (owner of the items in the containers) to eliminate any proximity ownership.
----------
It would appear that the code for removing an item from a container is not doing a check for a matching key when evaluating permissions.  

From the wiki: www.wurmpedia.com/index.php/Permissions
"Keys are entirely optional, with the choice to create copies remaining for situations where you may not wish to use the permission system."
 
When I read that it sounds like they 'may-open' permission and the use of a key should have the same functionality

I would consider this a bug if the function of the key is supposed to be an alternative to setting permissions, and (in the case of the key) viewing without interacting seems to be a mostly useless function.
Edited by Minion_II
fixed formatting

Share this post


Link to post
Share on other sites

In the Journal, some entries are not showing as completed because the character is passed that point in progression.  Can this be fixed to see it retroactively?

 

Examples include:

- Become a Priest

- Reach 20 Channeling

- Reach 50 Channeling

- Join a Meditation Path

- Become a Follower of a Deity

 

 

Share this post


Link to post
Share on other sites

They work fine for me 

Share this post


Link to post
Share on other sites
20 hours ago, Wreck said:

In the Journal, some entries are not showing as completed because the character is passed that point in progression.  Can this be fixed to see it retroactively?

 

Examples include:

- Become a Priest

- Reach 20 Channeling

- Reach 50 Channeling

- Join a Meditation Path

- Become a Follower of a Deity

 

 

Your server needs to update to 1.9.1.6

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Retrograde said:

Your server needs to update to 1.9.1.6

 

There is no 1.9.1.6 yet... We are on the latest version available atm, 1.9.1.5. In fact the journal stuff is broken if you already achieved that before the update.

Edited by Sklo:D

Share this post


Link to post
Share on other sites
On 4/11/2019 at 9:43 AM, Retrograde said:

Your server needs to update to 1.9.1.6

 

1.9.1.6 only fixes the achievement date SNAFU, that's the only change. Nothing to do with this.

 

On 4/11/2019 at 11:34 AM, Sklo:D said:

 

There is no 1.9.1.6 yet... We are on the latest version available atm, 1.9.1.5. In fact the journal stuff is broken if you already achieved that before the update.

 

1.9.1.6 came out a few hours after .5, keenan just forgot to change the number in server.jar lol, but if you look common.jar has the right .6 version.

 

Regarding goals not completing if you already became a priest etc. - this should happen in Player.checkJournalAchievements which is called (through a few other methods) from LoginHandler.loadPlayer

 

If it's not working on your server i'd start checking if that method is ever called and if not - why not.

Share this post


Link to post
Share on other sites

Hello,

 

As of the 1.9.1.6 update, the sea serpent no longer swims.  Instead it sinks to rest on the floor of the ocean/lake.  After I noticed it on our modded server, I also tested on a fresh unmodded adventure world.

Thanks,

 

Emmagrace and Vrystoria

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/13/2019 at 4:41 AM, EmmaGrace said:

As of the 1.9.1.6 update, the sea serpent no longer swims.  Instead it sinks to rest on the floor of the ocean/lake.

Yes, we are finding this on our server, too.

 

8B0C5255BBA07DC37491F1295900C40F4EBCF989

Edited by Batta

Share this post


Link to post
Share on other sites

What has happened to the Rite Spells?  is there a way to activate them.  When we noticed them missing we tried on a fresh adventure server.  Here is a screenshot of the Vynora Spell list.  But all of the Rite spells are missing form all of the lists.

 

Vynora Priest

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/13/2019 at 9:41 PM, EmmaGrace said:

Hello,

 

As of the 1.9.1.6 update, the sea serpent no longer swims.  Instead it sinks to rest on the floor of the ocean/lake.  After I noticed it on our modded server, I also tested on a fresh unmodded adventure world.

Thanks,

 

Emmagrace and Vrystoria

 

the creatures have been lowered in the water, sharks no longer have fin stick out. The sea serpent is sitting really really really low in water, if the ground is low enough (really deep) the sea serpent will move as normal. The model needs to be moved up so its not trying to drag so low in the water.

 

 

 

Edited by Cuddles

Share this post


Link to post
Share on other sites
On 4/19/2019 at 9:53 AM, EmmaGrace said:

What has happened to the Rite Spells?  is there a way to activate them.  When we noticed them missing we tried on a fresh adventure server.  Here is a screenshot of the Vynora Spell list.  But all of the Rite spells are missing form all of the lists.

 

Vynora Priest

 

Rite spells will only appear when the deity can grant them, and the requirement for that has changed. it used to be 1000 * (number of active followers) and in 1.9 that changed to a flat 100k favor for that deity.

Share this post


Link to post
Share on other sites

Did something change with the usage of strawberries in the last few updates (since WU 1.8.0.3)?  I used to be able to use strawberries as a fruit option in cooking meals.  Now any time a strawberry is added the lore result says that the ingredients do not make anything.

Share this post


Link to post
Share on other sites

seems fine to me. pottery bowl, 1 meat, 1 strawberry.  

[10:06:39] The ingredients in the pottery bowl would make a snake casserole when cooked.

Maybe the recipe you are doing has changed?  unlikely but possible.

Share this post


Link to post
Share on other sites
3 hours ago, Cuddles said:

seems fine to me. pottery bowl, 1 meat, 1 strawberry.  

[10:06:39] The ingredients in the pottery bowl would make a snake casserole when cooked.

Maybe the recipe you are doing has changed?  unlikely but possible.

Apparently, it is the frying pan that is preventing the use of strawberries.  Just tried it with the pottery bowl and it worked.  Have strawberries never worked with the frying pan?  Or could something have gotten messed up between updating the game and learning how to add server side mods?

 

Share this post


Link to post
Share on other sites

the recipes are very specific about what works in what. I don't recall when the cooking system changed but before then you could cook meals in pretty much anything. After cooking system change its very specific.

Also server admins can make their own recipes and do pretty much what ever they want as long as the item is classed as food.

Share this post


Link to post
Share on other sites

I'm playing single-player on an offline Adventure server, hadn't played in quite a while but came back 2 days ago. Anyway, when I used to play I had no trouble equipping my branded horses, but since I  came back regardless of permissions on the horse or deed it says that I'm "not allowed to do that"... Any ideas what is going on?

Share this post


Link to post
Share on other sites

i did notice seeing the "not allowed to do that" when I am to far away from interacting with something, maybe try moving closer to the horsie?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now