Sindusk

[RELEASED] (Client) Cave Vision

Recommended Posts

I guess I've probably held onto this privately for a bit too long, considering how relatively harmless it is. Here you go.

Before

Spoiler

rhSsdAM.png

After

Spoiler

dQRybZS.jpg

For use with Ago's Client Modloader.

Download (Google Drive)

Edited by Sindusk

Share this post


Link to post
Share on other sites

Does it just flatten the walls without reinforcements then? Does it do anything else as well?

Share this post


Link to post
Share on other sites

Flatten walls is a game setting, called cave wall detail.

Share this post


Link to post
Share on other sites

@ Tryst Like Bigsteve said flat walls is a setting in the launcher menu, the lowest setting on cave details.

This mod only changes the light inside a cave so it is not so dark.

Share this post


Link to post
Share on other sites

So this renders the need for lamps null and void? Almost like a cave with flourescent lighting. Not sure it feels cavey enough for me, but a nice fix to the hard-to-control cave lighting issue.

Share this post


Link to post
Share on other sites

Can you make a mod to make the whole game (inside and outside caves) darker at night? I used to be able to mod the client in gamesettings.txt or in some .jar file years ago but don't remember how anymore and have come back to Wurm (Unlimited, not Online) after a couple years to see how it's progressed.

 

Edit: nevermind; I think all I did was lower gamma a bit in my display settings and it gets plenty dark at night yet still bright during day.

Edited by Eep

Share this post


Link to post
Share on other sites
On 11/30/2016 at 8:54 AM, Marlon said:

So this renders the need for lamps null and void? Almost like a cave with flourescent lighting. Not sure it feels cavey enough for me, but a nice fix to the hard-to-control cave lighting issue.

 

You can configure the cave brightness, so it should be possible to make things visible while maintaining a cavey atmosphere.  :-)

The default setting of 1 is full daylight, I believe.

Edited by Batta

Share this post


Link to post
Share on other sites

Just installed this mod.  It works and turns everything very bright. 

 

However, I'd like to lower the brightness.  When I've changed the brightness in the properties, there is no effect in game.  I have tried 0.5, 0.25, 0.0, and even 10.0, but they all look identical to the default 1.0 value.

 

Is there something I'm missing?

 

Here's the properties file I last tried:



classname=org.gotti.wurmonline.clientmods.cavevision.CaveVision
classpath=cavevision.jar
brightness=0.25

Edited by Gorwst
Included properties file.

Share this post


Link to post
Share on other sites

This mod is not working for me since the 1.9 update. This is the first time it's ever been down.  Is it working for anyone else?

Share this post


Link to post
Share on other sites

It wont work for me either, caves are dark no matter what i do. Reinstalling, changing the lighting value, nothing changes anything.

Share this post


Link to post
Share on other sites

i'm using it and it works fine, what problem are you having?

Share this post


Link to post
Share on other sites
1 minute ago, bdew said:

i'm using it and it works fine, what problem are you having?

It's just as if it's not there at all.  Caves are dark.  My other client side mods are working, though.

 

Share this post


Link to post
Share on other sites

The only reference to Cavevision in my client log is this, but no errors or warnings:

 

Quote

    Line 4: [11:39:33 PM] INFO org.gotti.wurmunlimited.modloader.ModLoaderShared: Reading mods\cavevision.properties
    Line 24: [11:39:33 PM] INFO org.gotti.wurmunlimited.modloader.ModInstanceBuilder: Classpath: [mods\cavevision\cavevision.jar]
    Line 24: [11:39:33 PM] INFO org.gotti.wurmunlimited.modloader.ModInstanceBuilder: Classpath: [mods\cavevision\cavevision.jar]
    Line 47: [11:39:33 PM] INFO org.gotti.wurmunlimited.modloader.ModLoaderShared: Loading org.gotti.wurmonline.clientmods.cavevision.CaveVision as cavevision (unversioned)
    Line 47: [11:39:33 PM] INFO org.gotti.wurmunlimited.modloader.ModLoaderShared: Loading org.gotti.wurmonline.clientmods.cavevision.CaveVision as cavevision (unversioned)

 

Share this post


Link to post
Share on other sites
6 hours ago, bdew said:

i'm using it and it works fine, what problem are you having?

 

As for what problems im having, in the original post, im still in the before picture after reinstalling cavevision. I can see no error messages, but the same one as Batta has in her post above me.

what i have tried so far is, removing all mods and only run with cave vision, run with what i used before 1.9.x, run without any mods at all, changed value in the .properties to a couple of different and the inside of a mine is pitch dark in all instances :( and im at the wits end to what to do. i redownloaded it from the link in op and still the same.

Share this post


Link to post
Share on other sites
5 hours ago, Skarra said:

i redownloaded it from the link in op and still the same

I was just about to try this, too.  I can't imagine what has broken it.  

Next, I'm going to try disabling my other client mods one by one and see if that fixes a possible mod conflict.

 

Share this post


Link to post
Share on other sites
Posted (edited)

I disabled all my client mods except cavevision, and the problem remains.

I also tried downloading a fresh copy of the client modlauncher and its associated files. 

I'm remembering to patch.  

No error messages.  It says the mod is there.

 

Edited by Batta

Share this post


Link to post
Share on other sites

Hmm that's weird. i don't see anything relevant that changed in 1.9 and i tried playing with various settings to see if it's maybe not working with some of them, but it seems to work for me regardless of any changes.

Share this post


Link to post
Share on other sites
Posted (edited)

yeah it seems weird, but i cant figure it out..it's dark as heck (well exactlly like the first screenshot) no matter what i do 😕 gonna see if theres a difference if i change to the other renderer (as in not modern, but i used that one all the time so shouldnt do anything but hey doesnt hurt trying)

 

*edit*

Switched to legacy renderer and the mod works in that mode 😕 so gonna try and go back to modern again

 

*edit 2*

Switching back to modern renderer made the caves dark again :(

Edited by Skarra
results from test 1 and 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now