Sign in to follow this  
boogabee

Not picking up Servers port changes

Recommended Posts

I'm trying to add another Wurm Unlmited instance running on the same host as my primary instance. I've went through the documented steps and hacked my way through them as most of them are aimed at people using the GUI.

 

The problem I am experiencing is that I can still bring up my main instance just fine but my new server seems to be trying to capture the ports that the main instance is using, even though they have been changed in my servers table for that server.  The error I'm getting is

 

[01:12:46 AM] INFO com.wurmonline.server.epic.Hota: Loaded 0 HOTA helpers. It took 0.068983 millis.
[01:12:46 AM] INFO com.wurmonline.communication.SocketServer: Creating Wurm SocketServer on /127.0.0.1:48010
[01:12:46 AM] INFO com.wurmonline.server.Server: Shutting down the server - reason: Problem running the server - Address already in use
[01:12:46 AM] INFO com.wurmonline.server.Server: Shutting down the server - cause:

java.net.BindException: Address already in use
 

Which makes sense because the previous instance already has those ports captured

 

 netstat -tulpn | grep Wurm
tcp        0      0 127.0.0.1:7220          0.0.0.0:*               LISTEN      26032/WurmServerLau
tcp        0      0 0.0.0.0:7221            0.0.0.0:*               LISTEN      26032/WurmServerLau
tcp        0      0 127.0.0.1:48010         0.0.0.0:*               LISTEN      26032/WurmServerLau
tcp        0      0 192.168.2.254:3724      0.0.0.0:*               LISTEN      26032/WurmServerLau
udp        0      0 0.0.0.0:27016           0.0.0.0:*                           26032/WurmServerLau
udp        0      0 0.0.0.0:8766            0.0.0.0:*                           26032/WurmServerLau
 

For my server I have the following info

sqlite> select * from servers;
               SERVER = 2
                 NAME = Thera
      SPAWNPOINTJENNX = 200
      SPAWNPOINTJENNY = 200
       SPAWNPOINTMOLX = 
       SPAWNPOINTMOLY = 
       SPAWNPOINTLIBX = 
       SPAWNPOINTLIBY = 
           HOMESERVER = 1
   INTRASERVERADDRESS = 127.0.0.1
      INTRASERVERPORT = 48011
  INTRASERVERPASSWORD = xxxxxxxx
           EXTERNALIP = 192.168.2.254
         EXTERNALPORT = 3725
          LOGINSERVER = 
              KINGDOM = 4
          ENTRYSERVER = 
            ISPAYMENT = 
                  PVP = 
              TWITKEY =
           TWITSECRET =
              TWITAPP =
        TWITAPPSECRET =
         CHAMPTWITKEY =
      CHAMPTWITSECRET =
         CHAMPTWITAPP =
   CHAMPTWITAPPSECRET =
                LOCAL = 
               ISTEST = 
      LASTRESETCHAMPS = 1464222722935
              RMIPORT = 7222
     REGISTRATIONPORT = 7223
           MOVEDARTIS = 1442559567892
       SKILLDAYSWITCH = 1464225286942
      SKILLWEEKSWITCH = 1464225286942
         NEXTEPICPOLL = 1464226317318
        FATIGUESWITCH = 1464222717132
             NEXTHOTA = 
            WORLDTIME = 54900
             TILEREST = 463284
             POLLTILE = 4121688
              POLLMOD = 25385
            POLLROUND = 1
        SPAWNEDUNIQUE = 
          CAHELPGROUP = -1
            CHALLENGE = 
         CHALLENGEEND = 
     CHALLENGESTARTED = 
           MAXPLAYERS = 200
         MAXCREATURES = 10000
PERCENT_AGG_CREATURES = 10.0
           TREEGROWTH = 
        SKILLGAINRATE = 10.0
          ACTIONTIMER = 10.0
            HOTADELAY = 2160
         RANDOMSPAWNS = 1
      SKILLBASICSTART = 20.0
SKILLBODYCONTROLSTART = 25.0
  SKILLMINDLOGICSTART = 25.0
   SKILLFIGHTINGSTART = 10.0
    SKILLOVERALLSTART = 1.0
                 EPIC = 
                CRMOD = 3.0
              STEAMPW = xxxxxx
               UPKEEP = 
              MAXDEED = 
            FREEDEEDS = 1
            TRADERMAX = 500000
           TRADERINIT = 10000
            TUNNELING = 51
             BREEDING = 5
          FIELDGROWTH = 3600000
           KINGSMONEY = 1000000
                 MOTD = Note to Self: 1. Survive, 2. Create!
              MAPNAME = New


I'll note I also have the info for my primary server in that table too, as I assume it needs to be there in order to make the neighbour server link

 

 

Share this post


Link to post
Share on other sites

Your LOCAL field doesn't seem to be set - that's what sets which entry is used for ports and such. 

It should be 1 for the record that defines the server itself, 0 for all other entries.

Share this post


Link to post
Share on other sites

That did the trick, thanks. A simple end to many hours of fiddling with different settings.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this