Sign in to follow this  
LennyHarvey85

Graphics Bug - New laptop - Floor rendering

Recommended Posts

Hey, 

 

Got a new laptop and when running Wurm I get a graphical error with the floor. From a distance it looks like packed dirt, as I approach it changes to a marble slab (it should always be a marble slab) like its only drawing it as I get nearer. This is within say 5 tiles distance not miles. It is an onboard card but my other laptop, a much lower spec runs Wurm without graphical issue. 

 

Any ideas?

Share this post


Link to post
Share on other sites

Is the onboard card Intel or Radeon/NVidia? The type of terrain distortion you mention is pretty common with Intel graphics especially on Win8/10. Win7 drivers seem to have improved but the newer windows have not yet caught up (if the old laptop happened to be Win7). If it is a laptop with "switchable graphics" (nvidia/radeon PLUS Intel), there is an easy fix in the graphic control panell, just tll me which you have.

 

If it is ONLY intel, then the terrain distortion will go away if you toggle back on the GLSL shaders in Compatability tab, however you may well end up with crashes and/or distorted NPCs and animals instead of terrain. The distortion tradoff usually seems to be one or the other so see which annoys you more.  Also try going direct to INTEL for drivers as laptop makers very commonly run old driver builds that do not fare will with OpenGL gaming. Since Win7 drivers used to do this too, there is a decent chance at some point the Win8/10 drivers might catch up in handling OpenGL features. Most early drivers likely focused on directX issues. So far as I heard, the newest intel drivers also have this issue but it could change at some stage (especially if you do NOT get distorted NPCs with GLSL switched ON)

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

Ah ok, then go to NVidia COntrol Panel, 3D Settings Global, and look for a setting that says "always use High Performance Card".. I will go look for an mage.

 

Also the desktop shortcut, you might be able to right click and select "use High Performance graphics"

 

look for this:

 

650x279xrun-with-graphics-processor-opti

 

 

if wurm does not give that option, open NVidia Control Panel and look for this:

 

OOfnr.png

 

 

Global settings means however it will use NVidia for EVERYTHING which means it uses battery faster. There is a way to tell it to use NVidia for JAVA but in WO, it is an issue becuase java path changes every update, so we tended to suggest people just use the GLOBAL setting. 

 

This may not be an issue however with WU/Steam, I am just not 100 percent sure of the correct path to select. It might be  \steam\steamapps\common\Wurm Unlimited\WurmLauncher\WurmLauncher.EXE  using "program settings" instead of GLOBAL. Since WI does not have an EXE you had to instead point at javaws.exe or jplauncher2.exe or soemthing like that. I ssume since this is WU tech section, you are only needing it for WU.

 

 

Edited by Brash_Endeavors
  • Like 1

Share this post


Link to post
Share on other sites

If that does not fix it, I might poke around and see if other people had an issue similar to this nvidia user (if you think it is the same issue, he has a video).  ** also, are you by chance using  a digital flat panel monitor with the laptop? As I found one person with issues there.

 

 

Edited by Brash_Endeavors

Share this post


Link to post
Share on other sites

Just curious if the powers that be might want to sticky this info.  It's something quite a few people are running / will run into.

Can't imagine explaining it better than Brash did.  Pointing people to this thread for help would sure be easier if they could find it ;)

 

Just a thought.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this