Sign in to follow this  
joedobo

[RELEASED]Season Configure Mod

Recommended Posts

This client mod for Ago's client Modloader will let you configure what season is display for just your client.

 

Required:
Ago's WurmServerModLauncher. https://github.com/ago1024/WurmClientModLauncher/releases

 

:Install:

* It should almost always work. I've yet had to update this because it broke. I did recently put it on GitHub.

* Get a archive release for the mod here: https://github.com/Joedobo27/SeasonConfigureMod/releases
* Get one of the archive releases and unpack it into the WU client folder folder. The folder path should look something like this:

~\Steam\SteamApps\common\Wurm Unlimited\WurmLauncher

 

The seasonal length divisions are based in theory on the cosine wave math which the client uses to fluctuate temperatures and cycle seasons. I haven't done actual empirical testing. Let me know if it doesn't seem right.

 

 

Here's the configure file:

Quote

classname=com.jase2z.WUmod.SeasonConfigureMod
classpath=seasonconfiguremod.jar

# Any one of these set to true will result in the temperature options not getting used.
# Setting more then one to true will use whichever option comes first, top to bottom.
# false : default setting. This makes the mod use the temperature cosine wave to determine season.
# true : Sets the season to always be that type. 
summerAlways=false
fallAlways=false
winterAlways=false
springAlways=false


# Google sheet calculator to see how these numbers produce season length
# (I couldn't figure out how to make a simultaneous equation so you could just use percentages):
# https://docs.google.com/spreadsheets/d/1vrrMnf5xaFuys7rqVf0znnIDZDR3clUzSAk8Ts28iqc/edit?usp=sharing
# Fall and Spring durations will always be about equal.

# This is the average temperature throughout the Wurm Year. Think of it as the average value a cosine waves oscillates around.
# 9.0 is client default default. 
averageTemperature=9.0

# This is the range of temperatures occurring throughout the year. It's derived from a cosine wave.
# 24.0 is client default. Valid for values >= 0.
summerWinterDeltaT=24.0


# A few examples of (Avg, Delta) combination:
# 1. About all equal length seasons is:  (4,18). This gives W26%, Sp24%, Su26%, F24%
# 2. Client default: (9, 24). This gives W14%, Sp20%, Su46%, F20%
# 3. (4, 12) and this gives Sp50%, F50%.
# 4. (-2,20) and this gives W50%, Sp26%, F24%.
# 5. (17, 18) and this gives Sp10%, Su78%, F12%.
# 6. (-5, 8) and this gives W78%, Sp12%, F10%.

 

Edited by joedobo

Share this post


Link to post
Share on other sites

This is cool. Using it now in default mode.

 

Any idea what I would need to generate around 1 day of winter and still have the other seasons?

  • Like 1

Share this post


Link to post
Share on other sites

Was the google docs tool useful? With that you can test out what happens with different average and delta values.

 

 

I really wanted to make it so folks could just put percentages, for example: Sp10%,Su40%,Fa10%,Wi40%, but I couldn't come up with an algorithm to try all possible combinations and choose the one which best fits.  At first I tried to set up a OpenOffice tool to test things. I tried both a linear and non-linear solver tools and they didn't find solutions. Although, i'm not familiar with the tool and was probably using it wrong.

It seemed strange to me as only about 50 options for average matter and maybe 40 or delta. 40 * 50 is 2,000 possible combinations and see which one produces the least variations from the players Ideal values. 

Edited by joedobo
  • Like 1

Share this post


Link to post
Share on other sites

Must admit - didn't notice the google doc until you pointed it out. It was interesting to use.

 

Can decimals be used when providing numbers (ie. 9.99,14 for example).

  • Like 1

Share this post


Link to post
Share on other sites

Decimals are okay. The values in the client are floats. The only potential bad thing, i belive anyway, is the negative Delta. I put code in the mod to change the delta to 0 if some happens to try a negative for this value.

  • Like 1

Share this post


Link to post
Share on other sites

I am trying 9.99, 24. This gives me 2% winter while still having the other seasons as well. Will see how it goes.

 

Thanks for creating this new client mod!

 

~Nappy

Share this post


Link to post
Share on other sites

Been using this mod all day and loving it!

 

While doing so another idea for this mod or another one occurred to me.

 

A buddy who plays Wurm late at night often finds that because of the way that Wurm time is split up equally into 8 parts he ends up almost always spending a good portion of his playtime in Wurm night when he would really prefer to spend it in daytime instead.

 

Is there a way to make a mod that turns off nightfall or allows a way to modify the current 3 hour cycle?

  • Like 2

Share this post


Link to post
Share on other sites
On 12/11/2015 at 7:24 PM, Nappy said:

Been using this mod all day and loving it!

 

While doing so another idea for this mod or another one occurred to me.

 

A buddy who plays Wurm late at night often finds that because of the way that Wurm time is split up equally into 8 parts he ends up almost always spending a good portion of his playtime in Wurm night when he would really prefer to spend it in daytime instead.

 

Is there a way to make a mod that turns off nightfall or allows a way to modify the current 3 hour cycle?

ah yes this would be fantastic! i would want this as well.

Share this post


Link to post
Share on other sites

I tried out the google spread sheet and enterd -20 in the avg. temperature window which means 100% winter which i would love so much.

But i now have 2 problems.

 

1. i downloaded "seasonsconfiguremod" and after unzipping i  found 4 class-files in the "com"-file. All i tried to open but whith word or editor i only have salad of signs, how can i open the files properly(which one needs to be changed ?) and edit the avg. temp. ?

 

2. what to do then with the edited file ?

 

A little guide would help the newbies and the stupid. Please.

 

 

Edited by Sizan

Share this post


Link to post
Share on other sites

@Sizan Assuming you have downloaded and installed Ago's client modloader you simply place the archive in the mod folder and do "extract here". You should just see a file "seasonconfiguremod.disabled" and a folder "seasonconfiguremod" which contains "seasonconfiguremod.jar". 

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, joedobo said:

@Sizan Assuming you have downloaded and installed Ago's client modloader you simply place the archive in the mod folder and do "extract here". You should just see a file "seasonconfiguremod.disabled" and a folder "seasonconfiguremod" which contains "seasonconfiguremod.jar". 

 

Ahh..well no i haven't so i tried it actually.

Well my problem is, that nothing works anyhow. I just want winter all time. I downloaded the ago client modloader from here: http://forum.wurmonline.com/index.php?/topic/134945-alpha-client-mod-loader/

 

is it the right one ? Unzipped it and now again..i have some folders, all zipped also, and when i look into them they all contain the same files. there were 2 launcher-files also(one zipped one not) and started them. nothing happened.

 

I dont know how all people get along with this but i do not. i even do not get this mod loader running(if its the right one ?). Can you give me a link with  the right loader ? cause google showed nothing i could do with.

 

 

Another question is: can i use this Ago Mod Launcher when playing on the shard of someone else also ? And can i change the season in my client to winter in that case ?

Edited by Sizan

Share this post


Link to post
Share on other sites

Sizan:

1. I put a link to Ago's client modloader in the OP. And you will have to read and follow the instructions provided to install it. Ago did a good job of explaining the install process.

 

2. Client modloader is just for your client. Yes you can install it, play on someone else's server and configure your seasons however.

 

3: I tested the -20 avg temp and winterAlways=true which both caused my season to switch to Winter.

  • Like 1

Share this post


Link to post
Share on other sites

Ok, point 1 worked.

But installing the mod is still a problem. I downlaoded the file seasonsmod.7z into the mod-folder of my launcher and directly renamed it to seasonsmod.enabled, that right ?

 

But what now ? Where can i find the configure-file to change avg temp and winterAlways ?

 

Edit: i read above i have to put the seasonsmod.7z into the mod-file and unzip it there, what i did now. But a seasonsmod.disabled is nowhere there. I found in some sub-folders of com 4 files:

 

SeasonConfigureMod$1$1

SeasonConfigureMod$1

SeasonConfigureMod

SeasonCopy

 

and all 4 files are .class-files

 

Edited by Sizan

Share this post


Link to post
Share on other sites

Look inside the seasonconfiguremod.properties file - the configuration options are there.

 

BTW - I suspect your seasonmod.enabled file should be called seasonconfiguremod.properties and it should be located in the /mods folder of your wurmlauncher folder.

 

Inside the mods folder you should also have a folder called seasonconfiguremod and it should contain  a single jar file called seasonconfiguremod.jar

 

 Within the seasonconfiguremod.properties file look for the following section:

 

summerAlways=false
fallAlways=false
winterAlways=false
springAlways=false

 

If you want it to always be winter then change winterAlways=true and save the file. Restart your wurm client.

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, Nappy said:

Look inside the seasonconfiguremod.properties file - the configuration options are there.

 

BTW - I suspect your seasonmod.enabled file should be called seasonconfiguremod.properties and it should be located in the /mods folder of your wurmlauncher folder.

 

Inside the mods folder you should also have a folder called seasonconfiguremod and it should contain  a single jar file called seasonconfiguremod.jar

 

 Within the seasonconfiguremod.properties file look for the following section:

 

summerAlways=false
fallAlways=false
winterAlways=false
springAlways=false

 

If you want it to always be winter then change winterAlways=true and save the file. Restart your wurm client.

 

I edited my message above meanwile. Unfortunatelly in the mod-folder after download of the mod-loader there were only:

 

connectionfix.disabled

custommap.disabled

serverpacks.disabled

 

 

 

Edited by Sizan

Share this post


Link to post
Share on other sites

ok, so you have the latest client modloader this is good.

 

Download the seasonconfiguremod again and place everything inside the mods directory you mentioned above. Make the change to the properties file for winter always and restart client.

 

Should look like this:

 

WurmLauncher

   seasonconfiguremod.properties

   connectionfix.disabled

   custommap.disabled

   serverpacks.disabled

   Mods folder

     seasonconfiguremod folder

 

 

  • Like 1

Share this post


Link to post
Share on other sites

BTW - If the zip file already contains a seasonconfiguremod.properties file instead of a seasonconfiguremod.disabled file then this is ok. Just change the WinterAlways setting in that file, save it and then restart your wurm client.

  • Like 1

Share this post


Link to post
Share on other sites

i unzipped the seasonsconfiguremod.7z again as you said and now i got what i should i guess. 2 things were inside: 1 folder named "seasonconfiguremod" and one file named "seasonconfiguremod. disabled"

 

But they are all within the mod-file actually. changed the ".disabled" to ".enabled" and in this file winterAlways to "true" and checked that all other seasons are to false. Restart of my client showed no change, so i still do something wrong. I will try now to throw the seasonconfiguremod.enabled into the wurmLauncher folder, maybe that helps.

Will edit and tell the result.

 

Edit:  Did not help. And i found another mistake i made: renaming into .enabled instead of .properties . Changed that and put the file back into the mod-folder, but did not help. Then i changed the temperature also to -20, did not help also. Still have green landscape.

Edited by Sizan

Share this post


Link to post
Share on other sites

Let's start from the beginning ok?

 

1) Start by unzipping all the files in the zip file.

 

2) You want to move seasonconfiguremod.disabled to the Wurmlauncher/mods folder.

 

3) You also want to move the seasonconfiguremod folder to the Wurmlauncher/mods folder so that it becomes a sub folder (ie Wurmlauncher/mods/seasonconfiguremod)

 

4) Rename the seasonconfiguremod.disabled to seasonconfiguremod.properties

 

5) Edit the seasonconfiguremod.properties file and change the following :

 

winterAlways=false

 

to:

 

winterAlways=true

 

6) Save the file.

 

7) Shutdown your wurm client.

 

8) Startup your wurm client.

 

See if it's now winter.

  • Like 1

Share this post


Link to post
Share on other sites

The other question I have is:

 

When you installed the client modlauncher did you run the patcher.bat file?

  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, Nappy said:

The other question I have is:

 

When you installed the client modlauncher did you run the patcher.bat file?

 

Yes, for a few seconds the black little command-window showed up, then disappeared, that was it.

I will repeat now all the steps you mentioned the post before and edit in here what happened

 

Edit:  WORKS !!!!

Many many thanks for your help ! I have so sweet wurm-memories with winter, the impalong and the first time i played wurm in 2004, the newbie area south of freedom market on indy, it was there former days. And its christmas time so snow is a must here lol. Live in an area with very little snow in winter, that really sucks ! I came from another area of my country to this one, but the area i grew up we had much snow and i remember the happy (and painful) feeling to defrost my blue  hands at the oven..snow is AWESOME :D

Edited by Sizan

Share this post


Link to post
Share on other sites
13 minutes ago, Nappy said:

That's awesome!

 

Just a pity that it doesn't work in WO ...yet :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this