ago

[RELEASED] Client mod loader

Recommended Posts

Version 0.7

modloader

  • Discover mods from installed mods/modname/modname.jar files
  • Always activate custommap and serverpacks by default
  • Log game version, log mod versions earlier
  • Extract packaged config files (serverpacks has no config file packaged yet)

serverpacks

  • Replace existing packs when redownloading a pack
  • Allow forced pack downloads

patcher

  • Fix java path on linux

 

https://github.com/ago1024/WurmClientModLauncher/releases/tag/v0.7

 

It's now sufficient to install client-modlauncher-0.7.zip to have the modloader, serverpacks and the custommap mod active. If you don't want them active add a "depend.ondemand=true" line to serverpacks.config or custommap.config.

Share this post


Link to post
Share on other sites

One thing, Ago, that gets a lot of people hung up when trying to install mods for WU is that when you download and install your Mod loader, the clientmodloader.zip installs almost everything necessary except for connectionfix.properties, custommap.properties, and serverpacks.properties files in the proper locations.

It would be a lot smoother for non-savvy folks if those files were also included when downloading the clientmodloader.zip, instead of manually having to retrieve those 3 files from their individual .zip folders.

Share this post


Link to post
Share on other sites
  • Always activate custommap and serverpacks by default

With this change you don't need the .properties files for the two mods anymore. Connectionfix will still need a separate install but I don't want to enable it for all users by default.

Share this post


Link to post
Share on other sites

Getting this error running patcher.bat:

Error: Could not find or load main class org.gotti.wurmunlimited.patcher.PatchClientJar

OK, seems I forgot to move patcher.jar into WurmLauncher folder and it worked. However, the launcher doesn't show up and gives this error in client.log:

 

SEVERE org.gotti.wurmunlimited.clientlauncher.DelegatedLauncher: javassist.NotFoundException: com.wurmonline.client.resources.textures.PlayerTextureBuilderGL

 

How to uninstall?

 

 

 

 

 

 

 

Edited by Eep

Share this post


Link to post
Share on other sites

Validate the game data in Steam. This will redownload the modified files and revert to the latest unpatched version.

 

you can also rename client-patched.jar to client.jar.

Share this post


Link to post
Share on other sites

If you validate the steam files once complete you can run the patcher again, and should be fine.

Share this post


Link to post
Share on other sites
11 hours ago, Eep said:

Thanks but no fix for the error?

 

I already replied to your PM that you probably run an older version of the game, I also sent you the link to the last client modloader for the 1.4 client. What do you want more?

Share this post


Link to post
Share on other sites

I've done everything like i should and after i try launch client process disapear after moment. ;/

Share this post


Link to post
Share on other sites

Having same error; "Error: Could not find or load main class org.gotti.wurmunlimited.patcher.PatchClientJar"

 

Wurn Unlimited version 1.5.2.1

 

Win 10 x64 version 1709 OS Build 16299.125
WU installed location is L:\SteamLibrary\steamapps\common\Wurm Unlimited
client-modlauncher-0.7 installed location is L:\SteamLibrary\steamapps\common\Wurm Unlimited\WurmLauncher
livemap-1.6 installed location is L:\SteamLibrary\steamapps\common\Wurm Unlimited\WurmLauncher\mods

java.exe installed location is C:\ProgramData\Oracle\Java\javapath

 

Verified WU installed program files.

 

Ran as administrator; error on native patcher bat is, "The system can not find the path specified."

( note no patched client.jar created )

 

Verified WU installed program files.

 

After editing patcher bat as: 
L:ProgramData\Oracle\Java\javapath\java -classpath patcher.jar;javassist.jar org.gotti.wurmunlimited.patcher.PatchClientJar
pause

 

Ran as administrator; error on edited patcher bat is, "Error: Could not find or load main class org.gotti.wurmunlimited.patcher.PatchClientJar"

( note no patched client.jar created )

 

Any advice or thoughts is greatly appreciated. I have used livemap on previous versions of WU and Win10. 

 

Edited by Morph46

Share this post


Link to post
Share on other sites

Solved issue.  Turned out I was right clicking the native patcher.bat file and selecting run as administrator. This always failed.

 

What did work was left double-clicking the native patcher.bat file. Then the bat file ran without error.

 

 

Edited by Morph46

Share this post


Link to post
Share on other sites

Hi guys,
i haven't seen anywhere how to prepare modding environment, so ill write here what i found.

1) i clonned current master of mod loader from github
2) i called mvn install
3) i installed dependencies from jars within steam wurm unlimited folder (needed if you want to see wurm game internal APIs):
mvn install:install-file -Dfile=/d/games/steamapps/common/Wurm\ Unlimited/WurmLauncher/client.jar -DartifactId=client -DgroupId=org.gotti.wurmunlimited -Dpackaging=jar -Dversion=2182556
mvn install:install-file -Dfile=/d/games/steamapps/common/Wurm\ Unlimited/WurmLauncher/common.jar -DartifactId=common-client -DgroupId=org.gotti.wurmunlimited -Dpackaging=jar -Dversion=2182556
4) then i created my new mod's folder inside of loader and append it in my IDE as mvn module
5) everytime i want to build final jar and copy it into the server i call mvn install in folder of my mod and than, ill copy builded jar into the server mods structure and restart server.

Edited by palmic
fixes

Share this post


Link to post
Share on other sites

Does anyone have a workaround for the behavior where you fall down to the ground level when logging in, if you logged off from the second story or above? The behavior goes away when I disable serverPacks on either the server or the client.  I suspect the same issue is what causes me to get dumped from my boat when crossing server boundaries.

Edited by Brian

Share this post


Link to post
Share on other sites
3 hours ago, Brian said:

Does anyone have a workaround for the behavior where you fall down to the ground level when logging in, if you logged off from the second story or above? The behavior goes away when I disable serverPacks on either the server or the client.  I suspect the same issue is what causes me to get dumped from my boat when crossing server boundaries.

 

It's a timing thing, it does happen even in vanilla without serverpacks, but serverpacks does an extra reload after the packs are loaded which makes it more likely to happen to some people. I don't think there's any known fix for it yet.

 

The best thing would be if we could download and activate packs for the server before you enter the world, but it's not really possible with the current infrastructure.

Share this post


Link to post
Share on other sites

Stumped.  I have rechecked my steam files - no problems.  I am double-clicking patcher.bat and the the error "The system cannot find the path specified".  

 

Looking at patcher.bat it starts with: 

..\runtime\bin\java -classpath patcher.jar;javassist.jar org.gotti.wurmunlimited.patcher.PatchClientJar

But ..\runtime is not a folder anywhere on my computer (Windows) so I don't see how it can ever work (is this some magical java thing?).

 

So I just pasted the bulk of the command into a command prompt:  

java -classpath patcher.jar;javassist.jar org.gotti.wurmunlimited.patcher.PatchClientJar

And receive the following error: 

s:\Steam\steamapps\common\Wurm Unlimited Dedicated Server>java -classpath patcher.jar;javassist.jar org.gotti.wurmunlimited.patcher.PatchClientJar
java.nio.file.FileSystemNotFoundException: s:\Steam\steamapps\common\Wurm Unlimited Dedicated Server\client.jar
        at com.sun.nio.zipfs.ZipFileSystem.<init>(ZipFileSystem.java:120)
        at com.sun.nio.zipfs.ZipFileSystemProvider.newFileSystem(ZipFileSystemProvider.java:117)
        at java.nio.file.FileSystems.newFileSystem(Unknown Source)
        at java.nio.file.FileSystems.newFileSystem(Unknown Source)
        at org.gotti.wurmunlimited.patcher.PatchClientJar.run(PatchClientJar.java:30)
        at org.gotti.wurmunlimited.patcher.PatchClientJar.main(PatchClientJar.java:44)

s:\Steam\steamapps\common\Wurm Unlimited Dedicated Server>pause
Press any key to continue . . .

What am I missing?

Share this post


Link to post
Share on other sites

The "runtime" folder is in the "Wurm Unlimited" directory, which is just above the "WurmLauncher" folder, which is where you should be running your client patcher from. It looks like you're trying to run it from the Dedicated Server directory. Move the patcher files to the WurmLauncher folder and try there, if you're trying to patch the client.

Share this post


Link to post
Share on other sites

Can anyone tell me if the server-side httpserver and serverPacks mods would only be appropriate for the login server of a clustered arrangement? That would make sense to me, but I don't know the inner workings of those things.

Share this post


Link to post
Share on other sites
32 minutes ago, Brian said:

The "runtime" folder is in the "Wurm Unlimited" directory, which is just above the "WurmLauncher" folder, which is where you should be running your client patcher from. It looks like you're trying to run it from the Dedicated Server directory. Move the patcher files to the WurmLauncher folder and try there, if you're trying to patch the client.

 

I am doing something SOOOOO wrong here then.  There has never been a "WurmLauncher" folder in my "Wurm Unlimited Dedicated Server" folder.  There is one in my "Wurm Unlimited" folder though.

 

I have always unzipped directly into my "Wurm Unlimited Dedicated Server" folder and not had issues over many upgrades... I feel like I am way off course right now.... is this a client mod patcher or something?

 

Share this post


Link to post
Share on other sites

This topic is called "[Released] Client mod loader".  If you grabbed a mod loader listed in here, it's probably for clients, not servers. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now