Sign in to follow this  

Weird texture bug

Recommended Posts

Ever since installing the game on my laptop I've been having this weird texture bug. I have to play on minimum settings just to get a decent frame rate and I think I may have changed something I shouldnt have.




The laptop is an i7 with a GTX 840M. I can play GTA V and get 60 FPS no problem so it's kind of frustrating having to lower everything in this game just to get 20 FPS.

Share this post

Link to post
Share on other sites

Does your laptop have dual graphics?

If it does, then it's probably trying to run wurm on the intel gpu, you should have a setting under you nvidia control panel to tell it to run java as accelerated.


The texture corruption you are seeing is a very common bug with Intel graphics. WO used to have an option to fix it in the settings, but for some reason they have taken it out. pbuffer support or something like that.

  • Like 1

Share this post

Link to post
Share on other sites

Fixed! Turns out it was running on my Intel graphics driver instead of the 840M as mentioned above.


Step by step:

  • Open the NVIDIA Control Panel.
  • Click the Manage 3D Settings link.
  • Click the Programs Settings tab.
  • Hit Add
  • Find javaw.exe from the drop down and select it (If you recently ran Wurm it will appear)
  • Select the preferred graphics driver (in my case "High-performance NVIDIA Processor")
  • Hit Apply
  • Run the game!

This not only fixed the bug but I can now run at a smooth 60+ FPS with all the graphics on the highest setting.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this