Sign in to follow this  
AbsolutelyNobody

[RELEASED] Creatures Mod

Recommended Posts

I loaded this mod onto my server and it at first seemed to work fine.  Now I have a complaint about horses changing their breed.  One of my players has a pen where she was keeping 3 Knabstruppers and twice now the horses have changed to grey or another color.  No one else is breeding the Knabstrupper horses so I can't confirm that it is happening a lot.  Has anyone else seen this issue?  It only seems to be happening to the Knabstruppers.

I have noticed a LOT of Grays out there in our world.  Wondering if all the Knabstruppers are changing out in the wild as well.

 

Also several of my members are only seeing grey horses where there are suppose to be the new skins.  How do they fix that?

Edited by solarus225

Share this post


Link to post
Share on other sites

There is a bug in this mod. I've made an attempt to fix it (see my neighbouring thread) but it was ~ 2 year ago so I'm not really sure if attempt is working or not. 

 

Problem is that it saves species but pushes wrong model to clients, if i rcall correctly.

Share this post


Link to post
Share on other sites
1 hour ago, nekoexmachina said:

There is a bug in this mod. I've made an attempt to fix it (see my neighbouring thread) but it was ~ 2 year ago so I'm not really sure if attempt is working or not. 

 

Problem is that it saves species but pushes wrong model to clients, if i rcall correctly.

Yes, and i miss pintos.. :( 

Share this post


Link to post
Share on other sites
12 hours ago, Elsa said:

Yes, and i miss pintos.. :( 

Do you mean that you are not getting pintos? We are still getting them on my server. No problems at all with this mod for us.

Share this post


Link to post
Share on other sites

For folks having problems with this mod, PLEASE make sure you are using the updated version for it.
There is a link somewhere on these pages for a more recent version. DO NOT use the one in the OP!

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Zera said:

For folks having problems with this mod, PLEASE make sure you are using the updated version for it.
There is a link somewhere on these pages for a more recent version. DO NOT use the one in the OP!

Thanks, now i know why it didnt work other day when i tried to install it ..

Share this post


Link to post
Share on other sites
4 minutes ago, Martynas5 said:

Thanks, now i know why it didnt work other day when i tried to install it ..

Seems everyone fails to mention there is a newer release within the thread's pages. They automatically assume everyone's gone through to find it. XD

Glad you found it and got it up and running. :)

Share this post


Link to post
Share on other sites
2 minutes ago, Martynas5 said:

Haven't tried yet. I assume it's that 2.2v ago's edit ?

Yeah that one works with little to no problems :)

Share this post


Link to post
Share on other sites
10 hours ago, Batta said:

Do you mean that you are not getting pintos? We are still getting them on my server. No problems at all with this mod for us.

I had wrong mod, i didn't have Ago's edit ^^

Share this post


Link to post
Share on other sites
4 hours ago, Martynas5 said:

Works, but dont see new models in client.hmm

Make sure you have client modloader and serverpacks on your client.
Otherwise you won't see the new creature models and skins.

  • Like 1

Share this post


Link to post
Share on other sites

@ago Could you make textures for Calfs too? Now i a black angus calf that look like belted galloway.. 

Share this post


Link to post
Share on other sites
22 hours ago, Elsa said:

@ago Could you make textures for Calfs too? Now i a black angus calf that look like belted galloway.. 

 

No. Anything with graphics is beyond what I can do.

 

I just ported AbsolutlyNobodys mod to the the modloader and made a few fixes to keep it running but I never touched the textures or models.

Share this post


Link to post
Share on other sites
30 minutes ago, ago said:

 

No. Anything with graphics is beyond what I can do.

 

I just ported AbsolutlyNobodys mod to the the modloader and made a few fixes to keep it running but I never touched the textures or models.

Ah thats bad, but oh well. 

Share this post


Link to post
Share on other sites

Version 2.3

  • Shift knabstrupper and xappaloosa trait ids due to conflicts with traitor and valrei traits

 

https://github.com/ago1024/CreatureMod/releases/tag/v2.3

 

Unfortunalty this means all your existing knabstrupper and xappaloosa horses will lose the trait but there should be less problems until WU picks new traits.

Edited by ago
  • Like 3

Share this post


Link to post
Share on other sites

The problem I am experiencing with the creature mod is the model horse shown does not match the examine description.  I am using Tooltips updated version, when the cursor is on the horse it reports the model I am seeing, just does not jive when I examine it?

 

Share this post


Link to post
Share on other sites
9 hours ago, sailingsuzye said:

The problem I am experiencing with the creature mod is the model horse shown does not match the examine description.  I am using Tooltips updated version, when the cursor is on the horse it reports the model I am seeing, just does not jive when I examine it?

 

Yes, same here for me..

Share this post


Link to post
Share on other sites

I don't think there was a different colour message before.

 

I'm not so sure if "Its colour is piebald pinto" is a fitting message but since the server uses it i'll add something to match it for the other traits. I'm not sure if I can make the custom colour show up on any other creature but horses.

It'll probably have to wait until the 1.6.1.1 version goes live. I don't want to create a new intermediate modloader version just for the horse colours.

  • Like 3

Share this post


Link to post
Share on other sites
On 5/2/2018 at 3:28 PM, ago said:

I don't think there was a different colour message before.

 

I'm not so sure if "Its colour is piebald pinto" is a fitting message but since the server uses it i'll add something to match it for the other traits. I'm not sure if I can make the custom colour show up on any other creature but horses.

It'll probably have to wait until the 1.6.1.1 version goes live. I don't want to create a new intermediate modloader version just for the horse colours.

There wasn't.
It's because Wurm itself has added the ability to show the horse + hellhorse colors on examine. It's a core-game thing now and this mod wasn't written with that in mind originally.

Share this post


Link to post
Share on other sites

@ago This mod is no longer working, with tonight's WU update to 1.6.3.2

It causes my server to crash, whether I use the older version or the newer Version 2.3

Edited by Batta

Share this post


Link to post
Share on other sites
31 minutes ago, Batta said:

@ago This mod is no longer working, with tonight's WU update to 1.6.3.2

It causes my server to crash, whether I use the older version or the newer Version 2.3

 

Same issue here. 

Drake Mount Mod also broke in the update :(

Share this post


Link to post
Share on other sites
3 hours ago, ago said:

Version 2.4

  • Update to Wurm 1.6.3.2
  • Added colour support for horses in examine message

https://github.com/ago1024/CreatureMod/releases/tag/v2.4

 

I'm able to download this to my computer, but when I try to upload it to my server I get the following error. I've re-downloaded it twice, to be sure.  I also notice that on the Github page it says it's version 1.6.1.1, not 1.6.3.2.

404 - File or directory not found.

The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Edited by Batta

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this