ago

[RELEASED] Server mod loader + priest + crops + seasons + server packs + bag of holding

Recommended Posts

2 hours ago, Sklo:D said:

Apr 09, 2019 7:26:42 AM com.wurmonline.server.Server pollIntraCommands
WARNING: null
java.lang.NullPointerException
        at org.gotti.wurmunlimited.modloader.ReflectionUtil.getPrivateField(ReflectionUtil.java:73)
        at org.gotti.wurmunlimited.modcomm.intra.ModIntraServer.getConnection(ModIntraServer.java:89)
        at com.wurmonline.server.intra.ModIntraServerMessage.poll(ModIntraServerMessage.java:79)
        at com.wurmonline.server.Server.pollIntraCommands(Server.java:4046)
        at com.wurmonline.server.Server.run(Server.java:2561)
        at java.util.TimerThread.mainLoop(Timer.java:555)
        at java.util.TimerThread.run(Timer.java:505)
 

 

When did this happen, was it critical to the server/cluster?

I think the first server poll will actually run before the server startup was completed.

 

Share this post


Link to post
Share on other sites

Where are the config files or property files?  There are none in the downloads

Share this post


Link to post
Share on other sites
43 minutes ago, BigTex said:

Where are the config files or property files?  There are none in the downloads

Those always require a separate download for each of the mods.

Share this post


Link to post
Share on other sites

hi

 

When I run the patcher it doesn't create the WurmServerLauncher-patched.exe, any idea why that would be?

 

thx

 

....i deleted and install all again and is it ok

Edited by byxoft

Share this post


Link to post
Share on other sites

Hello, just a quick FYI the priest mod isn't working. I assume its due tot he new priest checks someone posted a few posts ago. 

Share this post


Link to post
Share on other sites

Is it important to update the other mods too, or is just the version number changed on them?

Which mods of the collection are realy new?

 

Eject

Edited by Eject

Share this post


Link to post
Share on other sites
10 hours ago, ago said:

 

When did this happen, was it critical to the server/cluster?

I think the first server poll will actually run before the server startup was completed.

 

 

On startup yes. Investigated and had no real influence on neither of the servers, so just a cosmetic thing to fix.

Share this post


Link to post
Share on other sites
3 minutes ago, Eject said:

Is it important to update the other mods too, or is just the version number changed on them?

Which mods of the collection are realy new?

 

Eject

You have to update all the associated mods, like actiondemo, announcer, bagofholding, etc.  Not all of them need reconfiguring after updating, but some do so it's good to check.

 

  • Like 1

Share this post


Link to post
Share on other sites

Is there any documentation anywhere that explains what each of ago's mods do? I see a few I don't recognize now. Can I just ignore the ones I haven't used before, like scriptRunner, serverFix, etc?

Share this post


Link to post
Share on other sites
21 minutes ago, Brian said:

Is there any documentation anywhere that explains what each of ago's mods do? I see a few I don't recognize now. Can I just ignore the ones I haven't used before, like scriptRunner, serverFix, etc?

I think they're all important. Should add them all.  For example, serverpacks allows players  to see kingdom tabards, custom creatures and so on.

Share this post


Link to post
Share on other sites

In the past, some of the mods used .config files. I don't see any in the new mods releases. Are they no longer needed then?

Share this post


Link to post
Share on other sites
1 minute ago, Brian said:

In the past, some of the mods used .config files. I don't see any in the new mods releases. Are they no longer needed then?

You're the second person who has said they didn't get the config files. Not sure why.  What I did was delete the old server modlauncher and all the associated files.  Then I uploaded server modlauncher and each of the individual associated mods one by one.  I got the config files.

Share this post


Link to post
Share on other sites
3 hours ago, Brian said:

I see .properties files but no .config files.

You're right. What I had been doing was navigating to here for example and manually grabbing any config files. Seems to work fine, not too many seem to actually have config files anyway.
Just remember that all the config options are commented out by default. Remove the poundsigns to make them actually function.

Edited by Metallumere
  • Like 1

Share this post


Link to post
Share on other sites

server-modlauncher-0.43.zip contains the modlauncher and all mod but it does not contain any .properties or .config files. This is to update the mods but will not activate any that has not been active before.

If you want to activate one of the mods it's best to download the mod only packge (e.g. cropmod-0.43.zip). Those contain the .properties file for mod and activates the mod.

https://github.com/ago1024/WurmServerModLauncher/wiki/Installation

 

Documentation for the mods is at https://github.com/ago1024/WurmServerModLauncher/wiki

  • Like 3

Share this post


Link to post
Share on other sites

an idea which im not sure if it has been brought up before.

What if modloader checked for a version number as it loads mods and then has a command which for GM only prints mod name and version number. Of course means the people making mod would need to add in this value or it would just print some default version number.

 

Thoughts?

Share this post


Link to post
Share on other sites

There's already the #versions command.  Is that what you mean?

 

Share this post


Link to post
Share on other sites

Yeah #versions does the trick, but so many mods are built without the required version tag for the functionality to be very useful. Could work towards a standard of adding it.

 

public String getVersion() {

return "vX.X";

}

 

I think Governor's mods are the only one's that include it from what I'm looking at on my server. A fairly simple addition, but reliant on the mod author to push it.

Edited by Ayluin

Share this post


Link to post
Share on other sites

I didn't either until your post :') But I often wondered why my mods would be loaded as 'unversioned' in the modlauncher.bat

Share this post


Link to post
Share on other sites

By default the version is read from the Implementation-Version field from the jar manifest. But you can override the getVersion() method on the WurmMod class and return any version string you like.

Share this post


Link to post
Share on other sites

Is there an official way to specify the version number of a created mod so that it appears in the server console on startup? As an alternative to just outputting something like "NappyServerMod_v1.9.1.1" using output commands. I feel like I read something about there being a proper way to do this using modloader but I can't find a reference to it anywhere.

 

~Nappy

Share this post


Link to post
Share on other sites

I should have read Ago's & Cuddles and Ayluin's comment earlier, would have lead to a faster result.

 

Just needed to add to my class.

 

  public String getVersion () {
      return "MyMod Version 1.9.1.7";
  }

Edited by Nappy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.