ago

[RELEASED] Server mod loader + priest + crops + seasons + server packs + bag of holding

Recommended Posts

Oh. That one properties file was left over in the zip file. Simply delete mods\disciomod.properties and everything should work again

I removed the file from the release archive too.

Edited by ago

Share this post


Link to post
Share on other sites

We just tried this mod. My friend is hosting the server on his computer. It ran fine for him but as soon as we restarted with this mod I was experiencing consistent lag spikes and disconnects. We both tried resetting everything (PCs, routers, server/client). When we removed the mod and restarted the lag and DCs were gone. Anyone else experience this? Is it possible to overcome it?


 


Thanks


Share this post


Link to post
Share on other sites

We just tried this mod. My friend is hosting the server on his computer. It ran fine for him but as soon as we restarted with this mod I was experiencing consistent lag spikes and disconnects. We both tried resetting everything (PCs, routers, server/client). When we removed the mod and restarted the lag and DCs were gone. Anyone else experience this? Is it possible to overcome it?

 

Thanks

 

I connect to my server via LAN and my friend connects via Internet and we haven't seen any problems so far. I've left my server running for days and my client for 8+ hours at a time, so i'm not sure what you are experiencing. With just 2 players playing like you I assume it's not hardware related as the server really takes so little resources. Are there any errors in the server window?

Share this post


Link to post
Share on other sites

the only things running at runtime are the hook into the CropTilePoller and the setNumFaith()

The second one happens only if a player prays and the other is happening every 4h (or whatever you set the crop check timer too). It might be possible that the extra method call is actually slowing things down a little but this should not be noticable for two players with maybe a few 100 farm tiles

The bug that starts saving the protected zone with every server cycle after 4 hours should have a much greater impact.

Share this post


Link to post
Share on other sites

Ago,


 


A huge thank you for this most useful mod.  And an extra nod for making it so easy to load and use for tech stupid people like me.


 


 


A small tip for any new players to Wurm...if you make yourself a Fo priest using this mod, with 30+ favour  you can be non aggro to all animals (note only 'animals'). 

Share this post


Link to post
Share on other sites

I connect to my server via LAN and my friend connects via Internet and we haven't seen any problems so far. I've left my server running for days and my client for 8+ hours at a time, so i'm not sure what you are experiencing. With just 2 players playing like you I assume it's not hardware related as the server really takes so little resources. Are there any errors in the server window?

 

 

the only things running at runtime are the hook into the CropTilePoller and the setNumFaith()

The second one happens only if a player prays and the other is happening every 4h (or whatever you set the crop check timer too). It might be possible that the extra method call is actually slowing things down a little but this should not be noticable for two players with maybe a few 100 farm tiles

The bug that starts saving the protected zone with every server cycle after 4 hours should have a much greater impact.

Ok, I just looked at everything on my end (internet speed, router reset, etc...) and we tried it again. He can get the server up and running (on his PC) and we join in. We both get "Refreshing" lag and it DC'ed us both. There is no message to him from the server-side that gives any information about what the problem/error might be.

 

Is anyone else experiencing this at all? We really want to get this to work because this is the *perfect* mod!

 

Thanks All

Share this post


Link to post
Share on other sites

I have a DeedMod I've written using this framework. I'll be posting it soon.

 

Current features:

  • Specify number of deeds per SteamID

Specify max North+South (Y) and East+West (X) sizes

Specify max total tile size

Control at which GM power can the restrictions be ignored.

 

Working on upkeep costs at the moment.

 

Any other ideas would be great.

 

 

If possible decay on or off for deed... also cost to deed control...

Share this post


Link to post
Share on other sites

So for the beta build looks like 1/2 the mod works. The limits on prays per day and the no cooldown both dont work. Just a heads up. 


Share this post


Link to post
Share on other sites

So for the beta build looks like 1/2 the mod works. The limits on prays per day and the no cooldown both dont work. Just a heads up. 

 

They default to enabled, you'll have to change the properties file to disable them.

Share this post


Link to post
Share on other sites
# true: There are no restrictions on the number of faith gains per day

# false: Only 5 faith gains per day are possible 

unlimitedPrayers=true

# true: There is no delay between faith gains

# false: Prayers only yield faith if they are at least 20 minutes apart

noPrayerDelay=ture

 

Unless I'm totally doing this wrong I think they are enabled. With them enabled they do not work is what I'm saying. 

Share this post


Link to post
Share on other sites

 

# true: There are no restrictions on the number of faith gains per day

# false: Only 5 faith gains per day are possible 

unlimitedPrayers=true

# true: There is no delay between faith gains

# false: Prayers only yield faith if they are at least 20 minutes apart

noPrayerDelay=ture

 

Unless I'm totally doing this wrong I think they are enabled. With them enabled they do not work is what I'm saying. 

 

 

If this is a copy paste from the file, you might want to double check that noPrayerDelay=true, not ture.

Share this post


Link to post
Share on other sites

The beta server does not seem to reset the prayer counts on restarts. The mod resets the limit on every prayer with faith gain. This won't work if you are not eligible for a faith gain because of a previous limit.

The next version will do the reset before the the limits are actually checked.

Share this post


Link to post
Share on other sites

Does this mod work with a linux headless server as described here for Windows machines?


Share this post


Link to post
Share on other sites

It should do.

Not sure if the paths are correct:

LD_LIBRARY_PATH="$PWD/nativelibs" runtime/bin/java "-Dworkdir=$PWD" "-Djava.library.path=$PWD/nativelibs" -Xmn256M -Xms512m -Xmx2048m -XX:+OptimizeStringConcat -XX:+AggressiveOpts -jar modlauncher.jar

Share this post


Link to post
Share on other sites

Also with the beta build the Remove priest restrictions does not work. Just a heads up. Seems kinda random its like sometimes it doesnt load and other times it does.


Edited by nosferatuu

Share this post


Link to post
Share on other sites

I'm focusing on learning your mod loader atm and my first step was to go through your README.md file. I went ahead and put it in plain text on the wiki for your GitHub. I've no idea what program will open a .md with formatting and all that, so this seemed to be the best option, though I'm not super familiar with the language you are using, so some of the comments might be a bit off.


 


Link: https://github.com/ago1024/WurmServerModLauncher/wiki/Documentation


 


Edit: Well, the code block WAS working until I edited it to make the notes above the code look like proper bullets... Anyone familiar with GitHub enough to make it display properly?


Edit: I just realized that if you go to the homepage for the GitHub of the project, the readme displays nicely... I hadn't even considered looking at anything other than the .zip file, lol. Yay learning!


Edited by Llurendt

Share this post


Link to post
Share on other sites

https://github.com/ago1024/WurmServerModLauncher/releases/tag/v0.6

The configuration files in the zip file have been renamed to *.disabled This shold prevent overwriting configurations if you just extract the the zip file. New users will have to rename the .disabled files to .properties to enable a mod

CreatureAgeMod was added to increase grow up times for animals.


Version 0.6
Modloader

* Mods should use Initable and PreInitable interfaces to setup hooks
* Mods without Initable are configured last
* Mods should use InvocationHandlerFactory to avoid locking classes to early
* Mods can implement PlayerMessageListener to receive all player messages
* Fixed ReflectionUtil.setprivateMethod() method
* Introduced ReflectionUtil.getMethod(methodName) method

Mods

* Property files are now named *.disabled to avoid overwriting configurations. Rename or copy them to *.properties to enable a mod

SpellMod

* Removed some maluses for priests when improving (isPriest() returns false when called from those methods)
* Prayer limits are reset before the check is even performed

CropMod

* Added extraHarvest option for additional items from harvests

CreatureAgeMod

* Increased growing up to mature for all creature like for horses on pvp servers
* Allow excluding creature templates from aging

Edited by ago

Share this post


Link to post
Share on other sites

I've updated the zip file again to contain this .bat file

runtime\bin\java "-Dworkdir=%CD%" "-Djava.library.path=%CD%\nativelibs" -Xmn256M -Xms512m -Xmx2048m -XX:+OptimizeStringConcat -XX:+AggressiveOpts -jar modlauncher.jar %*
Parameters can be specified when starting the .bat file

modlauncher.bat "Start=Creative"
The quotation marks are important to avoid splitting the parameter at the =

Share this post


Link to post
Share on other sites

Downloaded your update and the patch to the game however I cannot get the server to start.  I double click your batch file and the server interface loads.  When I hit Start Server, the cmd prompt fills with a bunch of text related to java looks like this:


 


at com.sun.javafx.event.EventUtil.fireEventImpl(Unknown Source)


at com.sun.javafx.event.BasicEventDispatcher.dispatchEvent(Unknown Source)


etc etc


 


at the bottom of the cmd it says ... 79 more then it closes.


 


Everything with your mod and the game worked fine prior to the games update, I didn't try your newest update until after the server wouldn't start.


 


Edit:


 


Doesnt seem related to your mod, can't get the server to run when not using your batch file either.


 


Edit:


In case anyone else has this issue, my ip address changed.  Use a cmd prompt and type in ipconfig, check that your ipv4 address is the same as "Server External IP Address" in the server settings and under advanced server settings make sure "Server Internal IP Address" is 127.0.0.1


Edited by Vess219

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now