Sign in to follow this  
InositoL

I think someone forgot to set the dedicated server as private

Recommended Posts

Either they have released the dedicated server or someone has done a boo boo...  :o

 

I have been checking several times over the past few days and it's only just appeared. Good eye.

Share this post


Link to post
Share on other sites

yes it's nice to see all the functions first hand however there still are a few I'm unsure about  ;)


Share this post


Link to post
Share on other sites

It was meant to be released slightly earlier, to give people head start in setting up dedicated servers. :)

It might still need switch to beta branch due to various Steam stuff, but should work.

Share this post


Link to post
Share on other sites

Hm, since I am new to Steam I'll have to ask where to look for this.


Share this post


Link to post
Share on other sites

Open Steam, click your library button on top, and choose "Tools".


 


serverpiumv.png


Share this post


Link to post
Share on other sites

Hope to god you have even a basic guide for this, as I can already guess people are going to be constantly asking 'what does this option do?' as you really have done a perfect job with it and allowed us to customise almost everything.


Share this post


Link to post
Share on other sites

Exactly...


I am like a questionmark right now looking at the server settings and stuff :P


Share this post


Link to post
Share on other sites

Is there any way of running this as completely private?


 


As it seems that the dedicated server will always be added to the steam server list via the dedicated server software, even though in a lot of peoples cases they will just want to be the only person who connects to it. Only thing you can do is run the server with a password it appears.


 


So far (without me being able to play it) it seems to be very low on resources, the default maps are only using minimal cpu time and 600Mb of RAM. Its changed my plans as going to now go with a 4096 size map as it looks like my machine should be able to cope with it given will be a solo server.


Edited by WUPlayer

Share this post


Link to post
Share on other sites

Is there any way of running this as completely private?

 

As it seems that the dedicated server will always be added to the steam server list via the dedicated server software, even though in a lot of peoples cases they will just want to be the only person who connects to it. Only thing you can do is run the server with a password it appears.

 

So far (without me being able to play it) it seems to be very low on resources, the default maps are only using minimal cpu time and 600Mb of RAM. Its changed my plans as going to now go with a 4096 size map as it looks like my machine should be able to cope with it given will be a solo server.

Share this post


Link to post
Share on other sites

I hit the launcher thing and nothing happens it pops up a screen for a split second then nothing happens. (the screen looks like it might be a command screen but it just flashes so you can not really see what it is. 


 


Do we need any other stuff before the server will open up? I did just update to the new java this morning but wurm online is running fine on it. 


 


 


Edit: If anyone else has this problem launch another game on steam. When i had launched another game on steam it downloaded a few things but i can not remember what they were and now the WU server things works. 


Edited by Kegan

Share this post


Link to post
Share on other sites

Hm, I installed my server before I noticed the java update.


Share this post


Link to post
Share on other sites

Yea, unless I'm missing something, no reason to be allowed to change ip addresses, as anything but what is already in there causes server to crash.. 

Well you might want to configure using the gui and then upload it to a server running without gui, then you need to be able to change it.

Also when starting on Linux it tend to fail to get anything but localhost address (127.0.0.1) for some reason, and if you start the server with that it won't be possible to connect to it.

 

Share this post


Link to post
Share on other sites

Ah nvm, gotta activate key.


Edited by Talohan

Share this post


Link to post
Share on other sites

Well you might want to configure using the gui and then upload it to a server running without gui, then you need to be able to change it.

Also when starting on Linux it tend to fail to get anything but localhost address (127.0.0.1) for some reason, and if you start the server with that it won't be possible to connect to it.

 

So if I am reading this correctly, we should be able to have the server run, without needing steam?

Share this post


Link to post
Share on other sites

I've downloaded and installed it - and it runs fine for a minute before it freezes and I have to force close it.


Share this post


Link to post
Share on other sites

So if I am reading this correctly, we should be able to have the server run, without needing steam?

You can download the server through steamcmd. 

The server should start fine using steam's anonymous api then.

login anonymous

force_install_dir <path>   (think this might be optional)

app_update 402370

quit

Running those commands in steamcmd should download the server for you.

Think you can also do app_update 402370 validate so that it forces a validation of the files after the download to make sure all is there.

 

Share this post


Link to post
Share on other sites

So if I am reading this correctly, we should be able to have the server run, without needing steam?

its what im doing as to not spam my friends that are online with me having to restart the server constantly due to a startup error >.<

Share this post


Link to post
Share on other sites

You can download the server through steamcmd. 

The server should start fine using steam's anonymous api then.

login anonymous

force_install_dir <path>   (think this might be optional)

app_update 402370

quit

Running those commands in steamcmd should download the server for you.

Think you can also do app_update 402370 validate so that it forces a validation of the files after the download to make sure all is there.

Share this post


Link to post
Share on other sites

So was looking at the advanced settings and saw that the skill gain rate multiplier is at 10.0. Is that normal Wurm Online skill gain rate? Just wanted to make it 4x WO rates, so if that's normal would 40.0 accomplish what I want?

Share this post


Link to post
Share on other sites

normal WO is 1.0 on all settings (obviously except things like starter stats, max creatures, breeding, crop, hota timer etc)


Edited by JDBooker

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this