Karthannar

Members
  • Content Count

    319
  • Joined

  • Last visited

Everything posted by Karthannar

  1. I'll look into it, no promises though.
  2. Forked from Keenan and updated project on GitHub. Any updates I do will be there from now on: https://github.com/Karth32/DeedMod/releases/ Also fixed an instance of the mod ignoring the powerOverride config when counting deeds owned by a steam ID.
  3. *smacks forehead* Of course it was that simple, thank you @bdew!
  4. Is there a way to get around this? SEVERE org.gotti.wurmunlimited.modsupport.actions.WrappedBehaviour: null java.lang.NullPointerException at org.karth.wurmunlimited.mods.spookycreatures.KarthUtils.getVillageNum(KarthUtils.java:74) at org.karth.wurmunlimited.mods.spookycreatures.actions.GenericActions.action(GenericActions.java:69) at org.gotti.wurmunlimited.modsupport.actions.ActionPerformerBehaviour.action(ActionPerformerBehaviour.java:82) at org.gotti.wurmunlimited.modsupport.actions.WrappedBehaviour.lambda$action$9(WrappedBehaviour.java:102) at org.gotti.wurmunlimited.modsupport.actions.WrappedBehaviour.action(WrappedBehaviour.java:211) at org.gotti.wurmunlimited.modsupport.actions.WrappedBehaviour.action(WrappedBehaviour.java:102) at org.gotti.wurmunlimited.modsupport.actions.ActionPerformerChain.action(ActionPerformerChain.java:77) *snip* Basically I'm trying to call "getVillage().getDeedId()" but whenever I'm not on a tile that's part of a deed it tries to spit out a null value which causes the above. I've tried quite a bit and I can't figure out how to get around that. Anyone better at this than me have any insight?
  5. I managed to get this mod up and running again. Source and .jar in the link below. https://drive.google.com/open?id=17jq2XbjDZSGhEBtnzWj-Atc9xIrwjPJO See GitHub link below for future releases. Let me know if you run into any issues. For the most part mod functionality is the same as Keenan's original code. I however did add functionality that ignores deeds that are owned by a GM character with power equal to or greater than powerOverride when determining how many deeds the steam ID owns. I can't guarantee I will stay on top of this as much as I would like, as my interest in wurm frequently waxes and wanes. (Also, I am very much an amateur coder- so things aren't probably as clean as they could be )
  6. Cool, we'll see the fix in another six months!
  7. Same bug as https://forum.wurmonline.com/index.php?/topic/161843-fixed-post-update-visual-bug-on-tool-heads/ Whenever someone else is using a tool, the shadered parts of it are bright white. My own tools are their proper color/texture/shader when I use them. Running the vanilla client with no mods installed.
  8. No, they just sort of randomly roam around.
  9. Just tried this out, and all I've got to say is wow! It works great on my server. http://puu.sh/z8wqz/02c87d1aee.jpg
  10. Fantastic work Rico! I never was a fan of the Ironwood GUI, but missed some of the extra elements added in with it. Now I can just about have the best of both worlds!
  11. I saw somewhere that we may be able to plant woad in flowerpots. Is that on track for 1.3 or am I just imagining things?
  12. Dead MMO's

    Tabula Rasa. That game had some issues, but it's the only dead mmo that I hold real nostalgic feelings for.
  13. Updated! (How long does it take these guys to dump an updated map? Sheesh.) Could you folks provide X/Y coordinates from the community map? I do not use the in game map grid because it is not as precise.
  14. PSA: Once the updated map dump is released I will spend a day roaming the server checking for dead deeds. Also if you have anything to add now would be the time to post about it.
  15. Thanks for all the mods bdew! However I seem to be having an issue with the hots fixes mod: Mycelium doesn't seem to want to spread within Libila's domain. I confirmed the server has PvP turned off and it is set as a hots home server. I also made sure that the hots fixes mod was the only mod running on the server to rule out any possible mod conflicts. Checking the logs seems to indicate everything is fine, but here's the lines from where it talks about loading the mod just in case: I'm not sure what else to try after this. Edit: Tried it with PvP turned on. No change.
  16. Odd. I'll have to have another look at this, aside from occasionally shifting a tile on server restart the NPC sat still.
  17. Give them the "malformed hind legs" trait. That usually stops them from meandering about.
  18. I think something is buggered with trees. I planted a bunch of sprouts on my island a couple days ago and they're all gone.
  19. Map updated! Twice in one month! The blasphemy!
  20. I've been everywhere on the server and there doesn't seem to be any cedar trees anywhere. Is this an oversight or by design? (If it is an oversight I'll take a bunch of cedar sprouts, thanks )
  21. Map updated! I'm probably blind, but I couldn't find that spot. PM me with more specific coordinates and I'll reupdate the map with it. I also ignored all the requests to be added to the map that were made last year. Just put in another request and I'll update the map with it.