Jump to content


Photo

Launching error: missing required permissions manifest attribute?


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1 Smilingcat

Smilingcat

    Villager

  • Members
  • PipPip
  • 321 posts

Posted 14 January 2014 - 08:28 PM

Hi, currently we have a problem on our windows 7 laptop to launch the client.

At first, it crashed after a few steps ingame with a java platform SE binary problem.

Black screen, then an error message. Since we are from Germany, i doubt this will help you but I can post it anyways:

Anzeigetreiber wurde nach einem Fehler wiederhergestellt.

And this:

Java Platform SE Binary reagiert nicht.

 

So I updated the graphics drivers and java,

now I get this error when trying to launch the wurm client:

java.lang.securityexception:

Missing required Permissions manifest attribute in main jar: http://www.wurmonlin.../wurmclient.jar

 

 

Next I added that website to the java configuration as trustworthy, but it would still not launch, same error message.

 

I am out of ideas now. Help, please?



#2 Marlon

Marlon

    Villager

  • Members
  • PipPip
  • 370 posts

Posted 14 January 2014 - 09:25 PM

I am having the same issue, cannot launch. Tried everything every site could offer, clearing java cache, reinstalling wurm, reinstalling java 64bit. everything is right.

Thanks again oracle, for making such changes.


Main: 'Marlon', Prem Alt: 'Fumewort', Server: Independence


#3 Marlon

Marlon

    Villager

  • Members
  • PipPip
  • 370 posts

Posted 14 January 2014 - 09:32 PM

This is oracle's abrupt way of things. But it should have been done in the client too.

For now, the only fix working is setting java security down to medium.

 

I am on java u51, and mostly linux. But on win7 it seems to work too if you do 'start' 'run' 'javaws -version' 'security' and set it down to medium.

 

NOTE!!!!!

This lowers checking of the application, where these certifications are involved, do so at your own risk...


Main: 'Marlon', Prem Alt: 'Fumewort', Server: Independence


#4 Smilingcat

Smilingcat

    Villager

  • Members
  • PipPip
  • 321 posts

Posted 14 January 2014 - 10:14 PM

Ok after updating everything, lowering security... still on the windows 7 comp, i could get wurm to launch, but as soon as I moved, it crashed again with the same error as before the java update::

Java Platform SE Binary not responding.

 

So both old and new java seem to not do the job on windows 7 with wurm. what now?


Edited by Smilingcat, 14 January 2014 - 10:17 PM.


#5 Anothernoob

Anothernoob

    Villager

  • Members
  • PipPip
  • 96 posts

Posted 14 January 2014 - 11:45 PM

Have you managed to access the control panel for java? It is possible to keep the security level to high if you add the link to the wurm client to the exception site list but I don't know if it is completely safe at all as java seems to nag about it.


Edited by Anothernoob, 14 January 2014 - 11:54 PM.


#6 Budda

Budda

    Villager

  • Client Developer
  • 1,075 posts

Posted 15 January 2014 - 01:00 AM

This Permissions error will be fixed in an update later today.



#7 Shyana

Shyana

    Villager

  • Members
  • PipPip
  • 134 posts

Posted 15 January 2014 - 01:19 AM

i'm having the same problem before and after updating java


JK for Life!!

#8 Tarator

Tarator

    Villager

  • Members
  • PipPip
  • 38 posts

Posted 15 January 2014 - 07:07 AM

Will the fix also address the hard crash on splash screen ? 



#9 saguaroman

saguaroman

    Settler

  • Members
  • Pip
  • 1 posts

Posted 15 January 2014 - 07:51 PM

I resolved this on my computer....go to the java application on your computer ...click on the security tab and lower the security level to medium and hit apply! for me it was a no brainer...I only use java to control my label printing with paypal and usps labels.


Edited by saguaroman, 15 January 2014 - 10:53 PM.