Iberis

Two FSB Bugs

15 posts in this topic

I've noticed these two FSB related bugs and was wondering if anyone else was having the same issue or anyone knows a fix?

 

The first is if you put a partial weight catfish into a fsb then pull it out it will become full weight again.

 

The second is if you chop a load of veggies put them in your FSB. When you pull them out they are no longer chopped.

 

The only server mods I can think of that affect the FSB that the server is running is the bulk transfer mod.

1 person likes this

Share this post


Link to post
Share on other sites

The second one happens because all the cooking metadata is stripped, including the pstate/cstate (chopped, etc.).

 

It's also exploitable since chopping can raise the QL if your cooking is high enough, so you can chop the same items over and over raising the QL (for say, sacing).

 

Maybe prepared ingredients should be disallowed from putting in FSB, but that would be kinda annoying.

Share this post


Link to post
Share on other sites

That's why it was brought to my attention because someone thought it was an exploit that they could just chop up the same veg over and over for skill. Also if you can't store chopped veg in a FSB is there no way to chop up veg and save it for sac'ing later?

Share this post


Link to post
Share on other sites

Posted (edited)

Looks like they actually intended for them to not go in FSB but the check isn't working

 

                    if (this.isDish() || (this.usesFoodState() && (this.getAuxData() & 0x7F) != 0x0 && (this.getAuxData() & 0xFFFFFFEF) != 0x0)) {
                        if (mover != null) {
                            mover.getCommunicator().sendNormalServerMessage("Only unprocessed food items can be stored that way.");
                        }
                        return false;
                    }

 

Added: The way i understand it, you can't store chopped veggies either way, because in terms of game data there is no "chopped corn" item, it uses the normal "corn" item and stores the preparation state (chopped) in auxdata. Since in BSBs all metadata is removed and only item type and weight/volume is stored so they can't distinguish different preparation/cooking states.

 

 

Edited by bdew
1 person likes this

Share this post


Link to post
Share on other sites

Hm it looks like storing chopped veggies does work in vanilla WU. So this is probably on of the BSB related mods messing it up. Don't know which one yet.

Share this post


Link to post
Share on other sites

Probably the same mod that is clashing with the catfish issue I'm guessing. How strange :s

 

I have increased bulk storage mod on and bulk move mod. I can't think of anything else that would clash.

 

Is this happening on your modded WU server as well?

Share this post


Link to post
Share on other sites

Posted (edited)

Yes it does.

 

Do you use bulkitemsseparated mod by chance? I have a suspicion that it's his fault.

 

Edit: Confirmed that it was causing the issue on my server.

Edited by bdew

Share this post


Link to post
Share on other sites

I'm not using that mod :(

 

That is the mod that neko created right and seperates the items every 10ql? Yeah we are not using that. I wonder what else might be causing the problem for my server :S

Share this post


Link to post
Share on other sites

Did you try to disable mods one at a time till you find the problem?  I'd guess it's the bulk move mod because that appears to do a lot of changes (maybe even a complete method replacement) to RemoveItemQuestion.answer().

 

https://github.com/webba/bulktransportmod

Share this post


Link to post
Share on other sites

another one I noticed you c an no longer store camellias in there, they used to be able to store them in there...

Share this post


Link to post
Share on other sites

I haven't tried disabling mods yet to test which one might be causing the issue. Will have to do that on a test server and see if I can get back to you guys.

Share this post


Link to post
Share on other sites
2 hours ago, joedobo said:

 I'd guess it's the bulk move mod because that appears to do a lot of changes

 

It's definitely not the one that causes the 2nd bug, i checked.

Share this post


Link to post
Share on other sites

Ok, i was wrong. Bulk transfer mod was also causing problems, and it showed up after i fixed the other mod.

 

I posted a fix for it here: 

 

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now