bdew

Launching multiple clients without killing steam and without any 3rd party software

49 posts in this topic

1 hour ago, Rudie said:

I'm not able to do this for this reason:

 

Unexpected crash while setting up login The error was: <Could not start SteamApi Shutting down (Steam is not Running)>

 

any ideas? Steam is running.

 

Make sure your client and steam are running from the same user. If one is running as admin and the other as your normal user - this will not work.

Share this post


Link to post
Share on other sites

Wooot!  Works on the server I play on(Sklotopolis!)  Love it!  This is soooo much feckin' easier!

EDIT:  And for the love of all that is holy someone pin this thing!  Too ###### useful for otherwise!

Edited by kanashio

Share this post


Link to post
Share on other sites

justabump

 

I run the game on Linux, and this works; but one needs to add steam_Api.so to LD_PRELOAD (or its path to LD_LIBRARY_PATH) to run the game, else it crashes.

 

So:

	env LD_PRELOAD=./libsteam_api.so ./WurmLauncher

Share this post


Link to post
Share on other sites

Not working for me atm.. idk why.

Share this post


Link to post
Share on other sites
On 5/25/2016 at 7:25 AM, Wulfgarr said:

Not working for me atm.. idk why.

This never worked for me, either.

 

I have to go into task manager, skill steamservice, then steam, then gameoverlay, and then (most of the time) it works for me.

Share this post


Link to post
Share on other sites

Works for me too, you have to launch the actual program you can't use the desktop shortcut created when you installed the game. You can however make a new shortcut right clicking the actual program from the wurm launcher folder and move the shortcut you create to desktop.

Share this post


Link to post
Share on other sites

To make this even simpler, the server installation has an appid file to begin with.

You could just be telling people to copy that over :D

Share this post


Link to post
Share on other sites

@bdewSuggestion for instructions:

 

-Move character once to remove invulnerability/Stop "You have been idle for too long" Kicks.

 

Logged in 20 alts, All of a sudden "You have been disconnected", Rip that sermon attempt.

Share this post


Link to post
Share on other sites

If you have Win 10. Do as i, I took and copy the steam_appid file from WurmServerLauncher Folder to WUrmLauncher Folder. That did it worked for my anyway. 

Share this post


Link to post
Share on other sites

That does occur sometimes, yes. I belive that is more a dc issue or something like that.

But all in all it is perfectly easy way to run more than one client!

Share this post


Link to post
Share on other sites
4 hours ago, butterflygirl25 said:

Will this cause the Duplicate authentication error? fix it? or is it separate problem?

Duplicate Authentication happens most of the time from a bad connection from you to the server.

 

Was getting it constantly for about 2 week while my internet was crap.  After it was fixed, No issues in weeks.

Share this post


Link to post
Share on other sites
On 10/21/2016 at 8:20 AM, zentil said:

Duplicate Authentication happens most of the time from a bad connection from you to the server.

 

 

Or between the server and steam. Or you and steam. Or steam just being derpy/DDOSed. 

 

This method is tangential to the issue and shouldn't affect it either way.

Edited by bdew

Share this post


Link to post
Share on other sites
On 8/9/2016 at 11:03 PM, Elsa said:

If you have Win 10. Do as i, I took and copy the steam_appid file from WurmServerLauncher Folder to WUrmLauncher Folder. That did it worked for my anyway. 

 

That should work regardless of OS.

Share this post


Link to post
Share on other sites

I remember using this trick several months ago (for a priest alt), but it looks like it's not working anymore. Have they "fixed" it in one of the recent patches? 

Share this post


Link to post
Share on other sites

It still works for me, I've been using this method to launch several clients to test a server mod this weekend.

 

Share this post


Link to post
Share on other sites

Having not tried this, how is an alt created or "chosen" from the client? Is there a screen that shows alts?

Share this post


Link to post
Share on other sites

Ive been using it ever since it was released. i use it almost daily.

 

1 hour ago, Cik said:

Having not tried this, how is an alt created or "chosen" from the client? Is there a screen that shows alts?

 

essentially, it just opens the server list where you can select the server and the character from the drop down menu. Once you join a server you will have an additional client window.

Share this post


Link to post
Share on other sites

this has stopped working for me... now all I get is:

http://prntscr.com/f9mn53

 

Unexpected crash while setting up login The error was: <Could not start SteamApi Shutting down (Steam is not Running)>
It's possible you might figure out what's wrong from the log file below, but if you can't, post the full log on the wurm unlimited forums, and someone else might be able to help you.
Contents of temporary launch log:
Time is Fri May 19 20:27:10 AEST 2017
Running client version 
=== System information ===
Executing from C:\Program Files (x86)\Steam\steamapps\common\Wurm Unlimited\WurmLauncher\
Operating system: Windows 10 (arch: amd64, version: 10.0)
Java version: 1.8.0_121 (Oracle Corporation) <http://java.oracle.com/>
Jvm version: 25.121-b13 (Oracle Corporation) [Java HotSpot(TM) 64-Bit Server VM]
Available CPUs: 8
====== CLIENT CRASH ======
Unexpected crash while setting up login
java.lang.Throwable: Could not start SteamApi Shutting down (Steam is not Running)
    at com.wurmonline.client.launcherfx.WurmMain.start(WurmMain.java:180)
    at com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$162(LauncherImpl.java:863)
    at com.sun.javafx.application.PlatformImpl.lambda$runAndWait$175(PlatformImpl.java:326)
    at com.sun.javafx.application.PlatformImpl.lambda$null$173(PlatformImpl.java:295)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.sun.javafx.application.PlatformImpl.lambda$runLater$174(PlatformImpl.java:294)
    at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95)
    at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
    at com.sun.glass.ui.win.WinApplication.lambda$null$148(WinApplication.java:191)
    at java.lang.Thread.run(Thread.java:745)

I'm missing my alts... any ideas?

Share this post


Link to post
Share on other sites
3 hours ago, Vanyel said:

Steam is not Running

 

Make sure steam is actually running and under the same windows user (so if you run steam as admin, you need to run the client as an admin)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now